LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   How the heck do I log in? (https://www.linuxquestions.org/questions/mandriva-30/how-the-heck-do-i-log-in-91793/)

krazwerk 09-11-2003 06:41 PM

How the heck do I log in?
 
I'm extremely new to Mandrake Linux... in fact I just finished installing it for the first time 10 minutes ago.

I cannot seem to be able to get into the Graphical Interface mode of Mandrake? It asks me to log-in in text mode... but I have no idea what I'm doing. :(

My boot options are only:

linux
linux-nonfb
failsafe
floppy

None of them seem to get me into the GUI.

Any help would be GREATLY appreciated!

>> krazwerk the :newbie:

quatsch 09-11-2003 07:12 PM

when you get to the text console, type in your username that you set up and then the password (the screen won't respond to your typing the password).
Once you're logged in, type
startx
and hit return. If the setup went all right, then this should get you into a graphical environment, usually kde. Once in kde, go to mandrake control center and change settings, I think under boot, so that the X server starts automatically.

If startx does not work, look in the forum for similar problems (topics like 'X won't start'). If that doesn't get you further, post a new thread with your problem - if you get any error messages after startx, post them too. Hopefully, it won't get to this;)

TSloth 09-11-2003 07:18 PM

When you installed Linux, it should have asked you for a password for root (which is the username for the account you will use to do some administrative stuff) and a username and password for a non-privileged user.

If you get a prompt for username, type in the non-privileged username, and press return (or enter), and type in the password. If you don't remember the username and password, type in "root" for the username and the password that you set up for root.

If either of these work, then you will get a command prompt like $ (nonprivileged user) or # (for root). If so, type the command "startx" to start the windowing system.

Other commands you can type at the prompt include "exit" to log out, "df -k" to get a list of the filesystems (partitions) currently mounted, and "ls" (ell ess) to get a list of the files in the current directory.

If you get the windowing system up, start up the Mandrake control panel (on the task bar, or from the K menu). From there you can add more users and/or configure the window system to start automatically upon boot.

Hope this helps!

- TSloth

krazwerk 09-11-2003 07:29 PM

I've tried both of your solutions, but I get errno 13 and later errno 2. :(

The startx command does not seem to work!

mrnikeswsh 09-11-2003 07:32 PM

KDE
 
I'm a newbie too...but I think I ran accross this once and just typed in "KDE"

And I think it started..

my 2cents..

let me know if that worked

Brian

krazwerk 09-11-2003 07:34 PM

Where did you type "KDE"?

TSloth 09-11-2003 07:38 PM

karzwerk,

Did you get as far as the Username prompt?
Then were you able to log in?

If no Username prompt then you might want to try to re-install.

By the way, did you have enough disk space to install? Maybe 4 GB or so? and don't choose too much additional software... you can install that later using the Mandrake Control Center.

- TSloth

krazwerk 09-11-2003 07:41 PM

I can login as either root or krazwerk... my only other account.

After this point I cannot seem to get into the GUI using startx.

mrnikeswsh 09-11-2003 07:41 PM

Do you get anything?
 
if you can trype.....try it
if you can type..
then try to reinstall

krazwerk 09-11-2003 07:44 PM

Here is a sample of what I get, and I get the same thing for my root:

[krazwerk@localhost krazwerk]$ startx
Using authority file /home/krazwerk/.Xauthority
Writing authority file /home/krazwerk/.Xauthority
Using authority file /home/krazwerk/.Xauthority
Writing authority file /home/krazwerk/.Xauthority

execve failed for /etc/X11/X (errno 13)
giving up.
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error.

mrnikeswsh 09-11-2003 08:02 PM

try kde
 
try kde at your prompt


just where you typed startx
tryp kde

dont' give up

krazwerk 09-11-2003 08:04 PM

[krazwerk@localhost krazwerk]$ kde

execve failed for /etc/X11/X (errno 13)
giving up.
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error.

krazwerk 09-11-2003 08:06 PM

Please help. :(

quatsch 09-11-2003 08:11 PM

try configuring your graphics card using XFdrake. Login as root and then type
XFdrake

Try out various configurations. Maybe something works. If not, do post your hardware setup. In particular your graphics card - I don't know anything about graphics cards but a lot of people do and tehy can help if you tell us your hardware setup.

Mathieu 09-11-2003 08:11 PM

Login as root and type:
Code:

whereis xinit


All times are GMT -5. The time now is 05:19 AM.