LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   How install modem & Internet connection (https://www.linuxquestions.org/questions/mandriva-30/how-install-modem-and-internet-connection-124081/)

cauge 12-08-2003 10:53 PM

How install modem & Internet connection
 
I'm using mandrake 9.2 and trying to set up my modem & Internet connection. I have downloaded a Linux driver for my modem and have installed that driver in Mandrake in home/modem. In Mandrake Control Center, under hardware, then modem, there is no modem shown.
1. How do I get the modem set up?

2. As to the Internet connection, I've gone to Mandrake Control Center, then Network & Internet, then clicked on DrakConnect. Going through these steps,
I clicked the auto detect.
For modems, the /dev/modem was highlighted and I accepted that - the other choices were tso/com1 through com8
for domain name, enetered access4less.net which is my ISP
I've left out some here steps which I think were clear enough
after finishing the configuration, I tested the connection and got the message " The system doesn't seem to be connected to the Internet. Try to reconfigure your connection"
Any suggestions?
While I'm at it, I did read in the help about setting up a firewall. How di I find it?

adz 12-09-2003 01:25 AM

Make sure your modem/driver actually work. Install a package called minicom to double check which port your modem is actually configured on. Then change the /dev/modem symlink to the right port.

cauge 12-09-2003 01:55 PM

Thanks, adz, but I feel dumber all the time trying to use MDK, and I think I'm a pretty savvy XP user. Anyhow, where do I find this package called minicom? When I go to RPM to look for packages, there are none. Might I have not installed those with Mandrake initially? If I have to reinstall Mandrake, or upgrade it, how do I do that? Do I first open Mandrake? If so, what after that? Thanks for your help.

adz 12-09-2003 05:52 PM

Well I've never used used mandrake but it should be on the CDs. If you don't want to do that then try to use the dial up app and try different ports until you get a resonse from the modem. I'm assuming you've never gotten an audible response from the modem like a dial tone. If you get a response then you know where the modem is. The good thing about minicom is that you can send different commands to the modem and test it out.

cauge 12-09-2003 08:33 PM

modem trials
 
I tried connecting with all the modem choices. None of them connected. Also, in the hardware list, there is no modem shown. The name 'modem is there, but nothing in it. I have a modem driver in the home/modem file, but how does that get associated with the modem and the Internet connection?

BobGuy 12-10-2003 12:43 AM

Does this modem have a brand name?

adz 12-10-2003 07:07 AM

Well you have to load the driver. It will be a module. You'll have to load it with either the modprobe or insmod commands.

cauge 12-10-2003 09:56 AM

the modem is a Conexant HSF Data/Fax PCI Modem, but the driver that I'm trying to use is for Linux. I downloaded the driver form their web site and it's tailored to the specific Mandrake kernel I have, so I'm confident it's the right driver. As to adz' comment that I have to load the driver, that's what I needed to hear. Now would you please be specific as to how to do that. I have unzipped the driver and it's in home/modem.

adz 12-10-2003 05:26 PM

You've unzipped it and that's it? There will be a proceedure to install it. Like a readme file. Other than that therre might be something on the site you downloaded it from. The procedure varies from company to company.

cauge 12-10-2003 08:49 PM

You're right again. The modem website provided an rpm -i etc commmand to install. I tried that . When I typed the install command, I got this response-
warning: (then the install command) V3 DSA signature:NOKEY, key-ID 5dfbf7dc mkdir failed - Permission denied.
Can you advise me how to resolve that? I also emailed the modem site, but don't know if they'll respond. Thanks

cauge 12-10-2003 10:27 PM

More info since my last post: I did receive a quick reply from Linuxant saying to make sure I am running the install command as "root" and that I might have to sign run "su --login" first. The "NOKEY" warning can be safely ignored.
As far as I know, I am signed in as root. I tried the install command again and got the same message as before plus this - error: unpacking of archive failed on file /etc/hsfmodem: cpio: mkdir failed. Permission denied.
Can you shed any light on that?

Baldrick65 12-10-2003 11:13 PM

I had similar probs getting the RPM version to work, but the tar.gz version worked fine. I believe the latest versions are "speed locked" to 14.4k, but you can download an older version here . This is not "speed locked". To install, run this as root:
Code:

1. extract the package with "tar -xzf hsflinmodem-{version}.tar.gz"

2. change to the package directory with "cd hsflinmodem-{version}"

3. run "make install" from the top of the package directory.

4. run "hsfconfig" to complete the installation and configure your modem.

That should get it all working.

<EDIT>
BEFORE INSTALLING

Remove any old HSF modem drivers, either manually or by
running "rpm -e hsflinmodem" or "make uninstall" if using the
RPM or tar versions of this package respectively.
</EDIT>

HTH
Baldrick

cauge 12-11-2003 08:43 PM

Installing modem
 
Thanh's guys. I was not logged in as root. In terminal, I typed the kdesu command, which logged me in as root. The install command was connected and I'm in business.


All times are GMT -5. The time now is 09:22 AM.