LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   How do you disable NFS so that it doesn't try to start on bootup? (https://www.linuxquestions.org/questions/mandriva-30/how-do-you-disable-nfs-so-that-it-doesnt-try-to-start-on-bootup-326755/)

FunBunny 05-24-2005 08:13 PM

How do you disable NFS so that it doesn't try to start on bootup?
 
Hello All,

You may know me from the thread "Getting NFS Quota errors, among others, with Mandrake 8.2".

I've been reading a bit since creating that thread and I've come to the conclusion that I don't really need it. Would somebody please tell me if this is true and also tell me how to disable NFS Services, Quotas, Mountd, deamon, etc.? Thanks.

FB

osvaldomarques 05-24-2005 11:23 PM

Hi FunBunny,

You have some administrative commands on all the descendants of the Red Hat systems. Mandrake, conectiva, mandriva are some of these. For control what services you want to be started you have chckconfig. This tool has several options to turn on and off and to display the state of the daemons.
To disable a daemon you have to do:
Code:

chkconfig --del <daemon>
In your case, the daemons are nfsd, quota. Mountd is associated with nfsd; if you disable nfsd you already do it to mountd.
To list the daemon's state:
Code:

chkconfig --list
Pay attention to the fact that even after you delete nfsd it will appear on this list; just the state of it will be all off. And, last but not least, to activate automatically a daemon on boot, you will have to do 2 commands, as far as I know for guaranty:
Code:

chkconfig --add <daemon>
chkconfig <daemon> on

Don't ask me why. It just works.

Cheers,

Osvaldo.


All times are GMT -5. The time now is 03:50 PM.