LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 01-21-2005, 08:55 AM   #1
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Rep: Reputation: 15
Help! Can't start with GUI MDK 10


This may be in the wrong forum, if so, please move.

I really don't know what I did but somehow while trying different desktops I
managed to mess things up so I can no longer just start the system with a
GUI, I can only run the sys. with CLI. In the process of all this I also lost the
ability to auto mount the cd along with the ability to shut down the sys.

This whole process started when I wanted to change the fonts in GTK1 and
GTK2 apps.

In reading these forums there were suggestions to use Gnome and change the
fonts in there and that would do the trick. Well, it changed alright, the fonts
went from very small to very large and I couldn't get them any smaller. I then
deleted Gnome and from that point, things have gone downhill.

As my wife uses this machine also I need to get things back to the GUI with
auto log in.

Surely someone out there will have compassion on me and not let me go
hungry until I get this straightned out.

Thanks in advance.
Dooley
MDK 10 OE
 
Old 01-21-2005, 09:34 AM   #2
jerm1701
Member
 
Registered: Nov 2004
Location: Wisconsin
Distribution: Mandriva 2007
Posts: 94

Rep: Reputation: 15
You deleted gnome??

How, exactly did you delete it? Did you remove it using urpme (or rpm -e)? Is so, you can re-install it if you use this command:

Code:
urpmi gnome
But you need to be root in order to do that. If you just deleted a random folder, do you recall which one?

Jeremy
 
Old 01-21-2005, 10:02 AM   #3
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jerm1701
You deleted gnome??

How, exactly did you delete it? Did you remove it using urpme (or rpm -e)? Is so, you can re-install it if you use this command:

Code:
urpmi gnome
But you need to be root in order to do that. If you just deleted a random folder, do you recall which one?

Jeremy
Jeremy, thanks for the reply.

To the best I remember I unstalled Gnome thru the MDK software uninstall. I was getting a little confused at this point. All I wanted to do was get the fonts to look right.

I don't recall all of the depen. which was included in the Gnome package when I uninstalled it. I sure hope I don't but I might have to reinstall MDK to get things working right again.

Again, Thanks
Dooley
MDK 10 OE
 
Old 01-21-2005, 10:09 AM   #4
jerm1701
Member
 
Registered: Nov 2004
Location: Wisconsin
Distribution: Mandriva 2007
Posts: 94

Rep: Reputation: 15
You can use the method above to re-install gnome since you uninstalled it using MCC. It should take care of the dependencies for you.

Good luck!
Jeremy
 
Old 01-21-2005, 10:50 AM   #5
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jerm1701
You can use the method above to re-install gnome since you uninstalled it using MCC. It should take care of the dependencies for you.

Good luck!
Jeremy
Jeremy,
Tried urpmi gnome with the following:
Some package requested cannot be installed:
xine-gnomevfs-1-0.rc5.9.1.101mdk.i586 (due to unsatisfied libgnomevfs-2.so.0) (Y/n)
Makes no difference if I select either Y or N it still want load.

Thanks
Dooley
 
Old 01-21-2005, 11:08 AM   #6
jerm1701
Member
 
Registered: Nov 2004
Location: Wisconsin
Distribution: Mandriva 2007
Posts: 94

Rep: Reputation: 15
Well, first, make sure you have all the other media turned off besides your original installation CDs/DVD. That way, you should be able to install just like you did the first time.

Second, if you run into trouble with dependencies like that again, force the installation of the individual rpm using.

Code:
rpm -i --force rpmname.rpm
I think turning off your updates, contrib and other media will be the best bet, though. That way you won't have to worry about updates conflicting with the orginal packages.
Jeremy
 
Old 01-21-2005, 11:08 AM   #7
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
If you reinstall MandrakeLinux using "upgrade" you will not lose your home (personal) files. It might be the easiest course at this point.

When prompted "Is this an upgrade or install?" (or words to that effect) be sure to reply by checking the "upgrade" box and your home directory will not be affected; at worst you might have to reinstall some programs you were using before.

I have done this numerous times because of mistakes I've made that resulted in it being the easiest way to get back to working. It may not be elegant or a good way to learn things, but it works.
 
Old 01-21-2005, 11:21 AM   #8
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Thanks to both Jeremy and jonr.
I will see if I can get this worked out.
If I don't post again you will know everything is ok.

Dooley
MDK 10 OE
 
Old 01-21-2005, 11:44 AM   #9
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by Dooley
Thanks to both Jeremy and jonr.
I will see if I can get this worked out.
If I don't post again you will know everything is ok.

Dooley
MDK 10 OE
Good luck! But please post and tell how it went.
 
Old 01-21-2005, 02:07 PM   #10
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jonr
Good luck! But please post and tell how it went.
I tried both suggestions, force install of depends. and the upgrade and no go, still have the CLI log in.

Everything was fine until I uninstalled Gnome. I must have missed something or removed something that has to do with KDE and the GUI log in. Each to his own poision, but I just don't like Gnome and it runs slower on my machine than KDE.

I will keep plugging at it and see what comes up. Any further help would be appreciated.

Dooley
MDK 10 OE
 
Old 01-21-2005, 02:33 PM   #11
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by Dooley
I tried both suggestions, force install of depends. and the upgrade and no go, still have the CLI log in.

Everything was fine until I uninstalled Gnome. I must have missed something or removed something that has to do with KDE and the GUI log in. Each to his own poision, but I just don't like Gnome and it runs slower on my machine than KDE.

I will keep plugging at it and see what comes up. Any further help would be appreciated.

Dooley
MDK 10 OE
Well, I can tell you how to get your GUI login, but you need to back up the file in question
(just copy it with another name) in case you slip up.

Assuming you can access an editor of some kind, as root copy the file /etc/inittab to something like
inittab.safe or some other name you will remember, for safety.

Then edit /etc/inittab so that the default runlevel is 5 instead of three. You will see near the top
of the file a list of 6 runlevels and a statement about each of them. Runlevel 5 is X11, or what will
give you your GUI login. Runlevel 3, which it's undoubtedly set at now, is the command line
login.

Change the "3" to a "5" in the line that reads "id:3:initdefault:" and reboot and you should be
at a GUI login.

Once again, you have to do that editing as root.
 
Old 01-21-2005, 04:27 PM   #12
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jonr
Well, I can tell you how to get your GUI login, but you need to back up the file in question
(just copy it with another name) in case you slip up.

Assuming you can access an editor of some kind, as root copy the file /etc/inittab to something like
inittab.safe or some other name you will remember, for safety.

Then edit /etc/inittab so that the default runlevel is 5 instead of three. You will see near the top
of the file a list of 6 runlevels and a statement about each of them. Runlevel 5 is X11, or what will
give you your GUI login. Runlevel 3, which it's undoubtedly set at now, is the command line
login.

Change the "3" to a "5" in the line that reads "id:3:initdefault:" and reboot and you should be
at a GUI login.

Once again, you have to do that editing as root.
I might be missing something here again so I will list the settings in etc/initab:

I copied and pasted as is.

# Default runlevel. The runlevels used by Mandrakelinux are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

This is all greek to me but I would say it is set at 5.
I want be able to do anything else until tomorrow.

Thanks for the help.
Dooley
 
Old 01-21-2005, 04:54 PM   #13
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by Dooley
[B

# Default runlevel. The runlevels used by Mandrakelinux are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:
[/B]
Well, I was hoping it would read "3." Back to the proverbial drawing board, then.

For some reason your X Window system must not be working. I don't understand why,
after a new installation--which should have supplied all the working parts again.

I and I hope some others more knowledgable here will give this more thought and if
I get any clue that might help you I'll post it. Don't give up. Something simple but not
obvious may have happened.

Rest assured it CAN be fixed.

If you have to, you can do a new fresh install (choosing "install" instead of "upgrade" and still not lose any of your home files, as long as you're very careful to only let the installation process format /hda1. Your home files are on partition /hda6. If you are careful and don't format /hda6, they will remain intact and untouched by this fresh installation.

If you make a mistake and have "all disk space" formatted or for some reason format /hda6, you will lose EVERYTHING. So just be very careful and think twice before you check any boxes.

If that doesn't solve the problem, I have no idea (at this point) what would. You won't have to worry about any dependencies or updates or anything--it will be just like the first time you (successfully) installed, only the home files you've created since your first installation will be there too.

I have done this and though I don't like doing it (and would like it even less if I didn't have my home files backed up in a separate location) it is sometimes, like the "upgrade" trick, the fastest way to get back to "normal."


Last edited by jonr; 01-21-2005 at 05:02 PM.
 
Old 01-21-2005, 10:27 PM   #14
Lakota
Member
 
Registered: Oct 2003
Location: London, ON, Canada
Distribution: Mandriva 2007 Free
Posts: 507

Rep: Reputation: 30
http://www.linuxgazette.com/issue93/yuan.html

link above for fixing font server

Last edited by Lakota; 01-22-2005 at 05:56 AM.
 
Old 01-22-2005, 09:22 AM   #15
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
I would like to thank all who so kindly tried to help with my problem.

The mystery has been solved.

While trying to get the fonts to look better I add -dpi100 to the
etc/x11/xdm/xserver file. I have no idea why that crashed the GUI log in, but it did.
As I have A.G.E. I had forgotten about adding that to the xserver file.
As soon as I removed the -dpi100 everything started working correctly again.

Again, thanks to all.
Dooley
MDK 10
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing MDK 10.1 GUI DesyphER Linux - Software 4 02-20-2005 02:26 AM
MDK 10.1 GUI runs on a P133 cachinnare LinuxQuestions.org Member Success Stories 1 01-20-2005 08:59 PM
I replaced my CD drive and Mdk won't start GUI Melon Mandriva 3 12-23-2004 05:41 PM
How do I login to GUI as root in MDK 10 dc101 Mandriva 8 06-23-2004 06:36 AM
No Package GUI After Upgrade to MDK 10 mooreted Mandriva 2 05-03-2004 04:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 08:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration