-   Mandriva (
-   -   GUI would not load, stops loading before login screen (

jeffshen 04-16-2005 07:55 PM

GUI would not load, stops loading before login screen
I have tried installing Linux on a Athlon 1700+ desktop with 512 Ram, 200gb hard disk with 120 left for the linux system, SIS 650 display adaptor, sound blaster sound card with a 15" Hyundai Imagequest L50S LCD monitor DVD drive USB2.0+firewire card.

I have also tried on an IBM X21 laptop as well. However the same symptom occurs.

Here is the symptom
However, when i boot the system up, it would only load on failsafe and would stop loading before the login screen before booting up. I have tried installing linux on this machine before, but i deleted it. Now i cannot perform a clean dual-boot install. I have tried installing both from the downloadable CD image and the DVD image. Can someone please help me?



rarsa 04-16-2005 10:30 PM

Not enough information to be able to help
Please provide more information. With the information provided it is impossible to figure out what is your problem.

What distribution are you using.
What is your 'other' OS in your dual boot.
You 'tried' to install it before: Was it working then? Did you have the same problem? another problem?
What are the symptoms? (You left that paragraph blank)
Provide a transcript of the system log if available.

Without knowing anything else here is a general recommendation:

Try using a CD Bootable distribution. That will help you narrow the problem and identify if it is a problem with your computer, with the installation or with the distribution. I would recommend Knoppix. It has a very nice partition manager. Or Linux Puppy: it has a very small footprint.

After you make sure that your computer works with the CD bootable distribution do the following:

1. Remove all linux partitions,
2. Fix the MBR (if your primary OS is windows here is how )
3. Reinstall from scratch using a stable distribution.

If this does not work, you may need to repeat steps 1 to 3 using different distributions. (Actually as a newbie I tried three different distributions until I found one that did a clean install for my computer)

If this response was helpful please click the Thanks button below.

jeffshen 04-16-2005 10:49 PM

I have a windows XP chinese, I have also tried using both GRUB and LILO... installed Ubuntu and that works... but i cant seem to install Mandrake Linux 10.1, the 3 CD install and the DVD install, just kept clicking next in the installation unless it was for passwords and stuff and the options screen before the updates page... set my location and time zone both to Hong Kong. didnt alter anything else. The problem is that it can load in failsafe mode ie. text-based prompt mode but i cannot seem to load the proper GUI version... the login screen dosent ever seem to come up. I have also tried to check the login automatically box with both KDE and GNOME but both times there is no response after all the devices are loaded and the blue screen with the mandrake thing at the bottom right shows up.

can someone please help?



dexter11 04-17-2005 03:57 AM

Ubuntu is a great distro but if you don't like it you can wait a few weeks and the new Mandriva 2005LE isos vill be publicly available (on the 1st of may).
Sorry I don't have the real solution just guessing here. The login manager which is not showing called kdm, you can choose an another login manager: gdm and see if it works.

blair 04-17-2005 10:01 PM

I am having a similar problem I am trying to work through. I have different video hardware. My guess is that you have a video card driver or monitor config problem. Suggestion is to restart the install process and ensure you have the correct video card (or a lowest common denominator) selected and proper monitor (or a lowest common denominator selected).

I have had several other distros and Live CDs boot up fine so am looking at those to see what video config they are applying. I intend to then try and apply those same settings to Mandrake. You could try this as well. Suggested easy lightweight distros include Beatrix, PCLinux and Knoppix.

good luck.

dipal_z 05-13-2005 01:36 AM


I had similar problem. After booting up it switches to graphics mode (display Mandrake logo) and stops there instead of showing login screen. (As it displays Mandrake Logo I assume that display card and monitor is configured correctly. Make sure you are reaching to this point before following steps given below)

I tried following steps and its working:

1. When the GUI is stopped before showing logging screen switch to any virtual terminal (Ctrl+Alt+F1 to F6).
2. Login as root
3. Give command "init 3" to switch to console mode.
4. Give command "gdm"

It will start the X server again and you will be able to see login screen.

Hope this helps

- Dipal

rarsa 05-13-2005 09:12 AM

Check your display parameters
Not all distributions are able to correctly identify all the hardware. Ubuntu must be doing a better job at identifying your configuration.

Here are two alternatives you can try:

1.- If you feel comfortable editing the /etc/X11/xorg.conf do the following:

back up the xorg.conf
Open the xorg.conf
Check that the mouse, keyboard, video card, monitor and display match your hardware. (Specs can be found in your hardware vendor web site)
Modify the xorg.conf file accordingly

try to startx

2.- If you don't understand the /etc/X11/xorg.conf or don't know what to put there:
Install Ubuntu
Copy the xorg.conf generated by ubuntu to a floppy or to another partition.
Install Mandrake.
Back up the xorg.conf
Use the Ubuntu generated xorg.conf file as a guide to modify your mandrake generated xorg.conf

try to startx

webterractive 05-13-2005 12:50 PM

If your login manager(kdm,gdm,dm,xdm) don't appear, this is usually because your vidcard isn't working propertly. A way to figure this out is to vi /etc/X11/xorg. After take a look at your video driver, in your case its sis. Press : and the q to end vi and then as a root vi /etc/modprobe.preload and press the insert key and enter another line underneath the last entry and add the name of the sis driver your system uses. Then press esc and then : and w to write. After just exit (: q) and restart your system. This seems to be a problem with some cards, Nvidia being a good example. I had that problem with my nvidia card.

webterractive 05-13-2005 12:51 PM

i don't even have a le 2005 iso, i just use a 10.1 mini-install cd, i have been doing it since.

All times are GMT -5. The time now is 07:30 PM.