-   Mandriva (
-   -   Grub error 17 after installing Mageia (

nigelc 08-28-2011 02:22 AM

Grub error 17 after installing Mageia
Have tried to install Mageia. Now it gets grub error 17. It has written no file in /boot/grub just a sample file.

yancek 08-28-2011 08:20 PM

Most distributions of Linux with Grub give you several options with the bootloader. The default is usually to install to the mbr, and you usually have the option to install to the partition on which you installed Linux or not install Grub at all. The first thing you would need to do is tell us which option you selected. If you don't have any files in your /boot/grub directory, you will need to reinstall Grub. Is Mageia the only operating system? If not, post partition information.

Error 17 indicates Grub cannot mount the selected partition which is usually because the entry is pointing to a swap, Extended or windows partition with an incorrect entry.

nigelc 08-29-2011 12:29 AM

I have found the problem.
When I tried to install Mageia an external USB drive was plugged in. This was called /dev/sda1 and the system was installed to /dev/sdc1 instead of /dev/sdb1. All the drives had moved up one.

Silly me!


All times are GMT -5. The time now is 06:54 AM.