-   Mandriva (
-   -   graphical environment not working (

mouse46 08-05-2004 02:37 PM

graphical environment not working

I have just installed Mandrake 10.0 and am having difficulties in getting the graphical interface working. During installation on the summary page, I had the option to configure the interface, but for some reason it wouldn't allow me to select the option. I have already installed KDE (when installing) and would like to know how to get this running.

Thank you in advance

MunterMan 08-05-2004 03:23 PM

Type init 5 at the command prompt. This will take you into mutliuser mode and should start your desktop (graphical interface) automatically. If it doesn't start type


at the prompt. If not working it should return some error messages.

mouse46 08-05-2004 04:08 PM


Originally posted by MunterMan
Type init 5 at the command prompt.
Once I login and type "init 5" it says

-bash: init: command not found

when I type "startx" is says

using authority file /home/yellowmonkey/.Xauthority
writing authority file /home/yellowmonkey/.Xauthority
using authority file /home/yellowmonkey/.Xauthority
writing authority file /home/yellowmonkey/.Xauthority
execve failed for etc/X11/X (errno 2)
xinit: Server error

MunterMan 08-06-2004 07:42 AM

You have to be superuser to run init, but that does not appear to be the problem.
Looks like your xserver software isn't installed.
Type this at the console (remember linux is case sensitive) and post the results.

rpm -qa | grep XFree

mouse46 08-06-2004 08:37 AM

ok, I logged in as root this time and typed what you asked, and I got this..


otish1000c 08-06-2004 08:59 AM

since you couldn't configure the graphics during install, perhaps you don't have the proper video drivers installed. what vid card are you using? you can try typing XFdrake in terminal as root to configure the card properly.


MunterMan 08-06-2004 09:07 AM

Comparing it to my 9.2 you are missing the server package.

Boot from the mandrake 10 cd 1
From this you should be given the option to "upgrade" your current installation (by pass all the disk partitioning stuff, and DONT format the hard drive).
When it shows the package choosing screen, make sure the KDE box is checked.

If it doesnt bring up kde automatically, try init 5 as root and see what happens.

mouse46 08-06-2004 05:36 PM

I'm using a generic video card and my motherboard is Nvidia based. Nevertheless I tired to upgrade my system as such and manually selected XFree86-server-4.3-30mdk since I was missing it. However, it seems my cd's may be faulty as when it specifically searched for XFree86-server-4.3-30mdk it said there was an "error". So I am making new cd's as I type this, and this may solve the problem. Although I did checksum it and verfiy the burn, I still dont know why this happened. Nevermind, it could be a 1 in a million thing.

I'll try an install again and post my results.

Thanks for the help so far, much appreciated :)

mouse46 08-07-2004 11:45 AM

ok, this is getting strange. Ive burnt new cd's and have tried to install again. But each install is never the same. The first time, I thought ill install kernal 2.6.XX to see if this works...I was wrong. I then seleted kernal 2.4.XX and although I was able to configre my monitor settings during install, after reboot it went to command line again. I have tried to select the XFree86-server-4.3-30mdk individually and still nothing. I have tried to upgrade my current installation and nothing. Another error occured during install saying that "not all GRUB dependancies were satisfied". I cant understand this, since I am using the graphical LILO for booting.

Should I try an install on a different hard drive (I have 4 with 2 in hardware raid) and see if this works?

alternatively, should I just install fedora, since I will be using this machine for email?

I need more help on this.

MunterMan 08-08-2004 05:49 AM

You are going to have to configure your video server manually. You need to install the kernal sources with the command

urpmi kernel-source

Then you have to use the link that otish1000c provided.

Gaz25 08-08-2004 09:35 PM

I am having the same issue, and have KDE installed.

Mine gets near to login and then flickers and coverts to command prompt login, I have tried this and startx to no avil.

Have you sorted your problem yet?

mouse46 08-09-2004 08:33 AM

I am getting frustrated with this. I was getting the same problems with Mandrake 9.2. None of my Nvidia Drivers worked and I have to complie them all. I was a true newbie then and was intimidated by this, since it was my first encounter with linux.

I was curious why this was happening again, so I downloaded Fedora Core 2 and see it I had the same issues, and amazingly it worked first time. I think I will stay with Fedora since I will be using the computer as a server, and use MDK on my second workstation.

But Thanks for your help MunterMan, it did solve a few mystries along the way. I will rate you for the help you gave me, much appreciated :)

Gaz25, you might want to try the link MunterMan gave in his last post, it looks like it might work, I didn't use it as I havn't got that much time to sieve through the work around.

good luck Gaz25 with your GUI and Thanks again for the help MunterMan.


All times are GMT -5. The time now is 04:15 PM.