LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 09-05-2003, 11:09 AM   #1
Crazystorm2002
LQ Newbie
 
Registered: Sep 2003
Distribution: Mandrake
Posts: 1

Rep: Reputation: 0
Glib problem


Hey people, i found this site and i thought it would be a great resource for linux 'ies

Anyway here is my problem:

I installed glib 2.2.3 and pkgconfig... so i can install gaim and a variety of different apps but when i run the configure for gaim i get this:

Quote:
checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at [glib site].
My distro is Mandrake and the kernal version is 2 2.4.21-0.13

i686 install

Any help is appreciated


And before you say "read the error" i have but i dont understand what to do.

Please help...
 
Old 09-05-2003, 05:16 PM   #2
kundor
Member
 
Registered: Aug 2003
Distribution: GoboLinux
Posts: 167

Rep: Reputation: 30
Well, gaim comes with mandrake, so you don't really need to compile it at all...:s
And if you want a newer version (which is a very good idea) follow the directions at http://plf.zarb.org/~nanardon, making sure to add texstar, then (as root) type "urpmi gaim" and it will get the latest version for you.
 
Old 09-22-2003, 11:23 PM   #3
Suryana
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
Unhappy GLib problem

Actually, i faced same problem about glib when i configure sctplib so if you have any idea please send emel to me ok.
 
Old 09-23-2003, 04:01 AM   #4
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Linux Mint 13 Maya
Posts: 729

Rep: Reputation: 32
I think you need to change ld.so.conf. so that it has the location of where you installed glib
a) First copy it to ld.so.confold in case you make a misake
b) Search the forums in case someone has explained it better than me !!!
 
Old 09-23-2003, 08:41 PM   #5
Suryana
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
Unhappy Confuse

I confuse for sctp application because when i configure sctplib and socketapi it will come with mistake.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 02:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
glib problem sameer666 Linux - Newbie 2 12-03-2005 12:49 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
GLIB problem abdullahgee Programming 2 06-04-2004 12:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 03:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration