LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 07-19-2005, 05:26 PM   #1
a_r_cook
LQ Newbie
 
Registered: Jul 2005
Posts: 10

Rep: Reputation: 0
Getting files from a USB device???


Hey, i just installed Mandrake10.1 and it is pretty smooth and seems sound. BUT i cant seem to do anything when i plug my MP3 player into my computer. I was just curious if there is something i need to download in order to get plug n play access devices to come up smoothly? any suggestions would be nice. Thanks
 
Old 07-19-2005, 05:38 PM   #2
J_K9
Member
 
Registered: Nov 2004
Distribution: Slackware 11, Ubuntu 6.06 LTS
Posts: 700

Rep: Reputation: 30
Hi,

1) You could try going into terminal and doing:
Code:
$ su
Password:
# mount -a
This will automatically mount everything your computer can find. If that doesn't work, and your mp3 player's icon doesn't appear on your desktop, then move onto step 2.

OR

2) Unplug your mp3 player. Good, now go into terminal, and plug in your mp3 player. Now run "dmesg" from the terminal (without the quotes), and you should be able to find a line which will describe your mp3 player. Is should be something like "/dev/sda: ..." Just look around for it and you should find a line referring to your mp3 player.

Once you've found that line, take a look at the /dev/---, and then go into terminal again and type:
Code:
$ su
Password: 
# mkdir /mnt/mp3
# mount /dev/--- /mnt/mp3
In the code above, replace the "/dev/---" with whatever you found out from the "dmesg" command. Best of luck!

J_K9

P.S Does your mp3 player have a FAT32-formatted hard drive, or something else?
 
Old 07-19-2005, 06:45 PM   #3
a_r_cook
LQ Newbie
 
Registered: Jul 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by J_K9
Hi,

1) You could try going into terminal and doing:
Code:
$ su
Password:
# mount -a
This will automatically mount everything your computer can find. If that doesn't work, and your mp3 player's icon doesn't appear on your desktop, then move onto step 2.

OR

2) Unplug your mp3 player. Good, now go into terminal, and plug in your mp3 player. Now run "dmesg" from the terminal (without the quotes), and you should be able to find a line which will describe your mp3 player. Is should be something like "/dev/sda: ..." Just look around for it and you should find a line referring to your mp3 player.

Once you've found that line, take a look at the /dev/---, and then go into terminal again and type:
Code:
$ su
Password: 
# mkdir /mnt/mp3
# mount /dev/--- /mnt/mp3
In the code above, replace the "/dev/---" with whatever you found out from the "dmesg" command. Best of luck!

J_K9

P.S Does your mp3 player have a FAT32-formatted hard drive, or something else?
well i tried this, but when i type the password i dont see the text i am typing, which i assume is a security feature, but i keep getting incorrect password. is it possible i am not typing it in correctly, i am typing exactly as you have it written
 
Old 07-20-2005, 11:21 AM   #4
a_r_cook
LQ Newbie
 
Registered: Jul 2005
Posts: 10

Original Poster
Rep: Reputation: 0
just wanted to bump this because i still havn't figured it out, i was reading somwhere else that i have to go to some system settings and switch something to "USB=YES"
Any help?
 
Old 07-20-2005, 01:10 PM   #5
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
You really must find your password. when you type su, then password, did you use your 'root' password or your 'user' password?

What you should type is your root password. Try that, then do as instructed above.

Adrian
 
Old 07-20-2005, 04:59 PM   #6
webterractive
Member
 
Registered: Apr 2004
Location: Richmond, Canada
Distribution: Mandriva 2006/XPSP2
Posts: 265

Rep: Reputation: 30
a_r_rock rpm -qa | grep and see if you have something called dynamic instlled. Dynamic handles the mounting of USB device like stuff. Second install it if you don't have it, and if you do have it make sure that hotplug daemon starts @ boot time to make sure you're able to plug stuff in. I have had the same problem before and that seem to have worked. If it doesn't automatically mount, you will have to define your mount points yourself in /etc/fstab.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB drive not working properly, read only device? (USB key storage device) Arodef Linux - Hardware 14 01-01-2010 07:32 AM
Failed to open device /dev/usb/ttyUSB0: No such device efm Linux - Newbie 2 04-04-2005 08:46 PM
Two USB flash drives keep swapping device files pwalden Linux - General 8 12-30-2004 03:48 PM
HP Deskjet (USB) & CUPS & Slackware 9.1: Unable to open USB device "usb:/dev/usb/lp0&qu arnostienen Slackware 2 01-29-2004 03:22 PM
how can I mount this device: da0: <USB 2.0 Storage Device alkad_mzu *BSD 2 11-15-2003 06:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 08:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration