LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 09-24-2005, 11:30 AM   #1
hummus
LQ Newbie
 
Registered: May 2005
Posts: 4

Rep: Reputation: 0
frame rate slow down


Within the past week, I have noticed a significant slow down in the frame rate of my video card when I run games such as tuxracer and bzflag. Am not seeing this slowdown on other apps including watching DVD video.

When I run "glxgears", I get frame rates on the order 8-10 FPS.

Here is a breakdown of my system:

Athlon XP 2900+
512MB System Memory
GeForce MX5200 w/ 128MB
Mandrake 10.1 OS
NVIDIA-Linux-x86-1.0-7174 driver

This setup had been working great with "smooth" openGL performance until "something" happened which caused the slowdown.

Any thoughts on what event may have happened? Have not changed any HW config or installed any software recently. I don't think it's bad HW in that it seems to be isolated to openGL.

Also, any suggestions on how to recover? I have already reinstalled the driver, but no improvement.

Here are the "Device" and "Modules" sections of xf86config:

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "/usr/X11R6/lib/modules/extensions/libglx.so"
Load "glx"
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia"
BoardName "NVIDIA GeForce FX (generic)"
Driver "nvidia"
Option "DPMS"
Option "IgnoreEDID" "1"
EndSection

Thanks for any suggestions.
 
Old 09-25-2005, 06:51 AM   #2
aerogate
Member
 
Registered: Jun 2005
Location: UK
Distribution: Mandriva 2006
Posts: 154

Rep: Reputation: 30
Hi there,

Not sure if this applies to you, but last week there was a Mandivaonline update to Xorg, if you did the update you now need to re-install you nvidia drivers.

This has happened twice, the drivers still load, but the 3d acceleration part is killed. Re-installing nvidia drivers fixes the problem.

Sorry just read the rest of your post, you tried re-installing already, but I`ll leave it here incase it helps someone else.

Last edited by aerogate; 09-25-2005 at 06:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Terrible frame rate in Xine Mr. Hill Linux - Newbie 3 06-02-2005 02:27 PM
ATI frame rate RedRaven Fedora 0 01-20-2005 12:09 AM
howto get frame rate with geforce 4 carboncopy Slackware 7 09-18-2004 09:59 AM
Frame Rate LImiter qwacko Linux - Games 2 06-20-2004 05:23 PM
frame rate thegreatgatsby Linux - Software 2 10-07-2003 12:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 07:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration