-   Mandriva (
-   -   Floppy drive very slow with Mandriva 2006 (

jeanmm 11-10-2005 01:35 AM

[solved] Floppy drive very slow with Mandriva 2006

I noticed that writing to floppy is really slow in Mandriva 2006 : 32 KB written every 30 seconds only :( . The same problem was observed on 4 different PC's, so it seems to be a real problem related to Mandriva 2006 (the same test on my PC started with 2005LE shows that there is no hardware problem related to the floppy drive, and the drive is then nearly 10 times quicker !).

I compared floppy driver parameters between 2005LE and 2006 with "floppycontrol -p" (utility included in fdutils package) : no difference :

abort= 3
readtrack= 1
recalibrate= 0
reset= 2
reporting= 2
cmos= 4
hlt= 16
hut= 16
srt= 4000
spindown= 3000
spinup= 400
select_delay= 20
rps= 5
spindown_offset= 10
cylinders= 83
tracks= 83
timeout= 3000
interleave= 20
checkfreq= 1500
native_format= 7
autodetect seq.= 7,4,25,22,31,21,29,11

In fact, until now I don't know weather it's a general problem, or if it works on some PC's. So if someone could perform a test, in order to compare, it would be interesting.

Thanks for any advice or suggestion.

andygo 11-10-2005 02:07 AM

fdformat /dev/fd0 && mkfs.ext2 /dev/fd0
mount -t ext2 /dev/fd0 /mnt/floppy/

jeanmm 11-10-2005 10:40 AM


Originally posted by andygo
fdformat /dev/fd0 && mkfs.ext2 /dev/fd0
mount -t ext2 /dev/fd0 /mnt/floppy/

ext2 is a bit better : 4.8 KB/s, but not yet former 10 KB/s...
there must be something changed since 2005LE, but what ?

jeanmm 11-12-2005 05:56 AM


I made a new kernel, with floppy driver source coming from 2005LE, but the result is the same.

I also made a test with Knoppix 4.0, which has the same kernel as Mandriva 2006 (and I suppose the same floppy driver) : the measured write speed is not 1, nor 10, but 25 KB/s !

My conclusion is : there must be something wrong inside Mandriva 2006, not necessarily the floppy driver itself, but something else ...


jeanmm 11-14-2005 01:36 AM

I finally tried to post a bug in Mandriva's bugzilla, and got immediately following answer :

That's because the floppy is now mounted with 'sync' as default...
If you want the speed back, change in /etc/fstab the line regarding /mnt/floppy from ...,sync,... to ...,dirsync,...
You will only get a little bit longer umount as the kernel flushed the writes to the floppy... but the overall total speed is faster that way...

I tried this solution, and it works : now writing to floppies is really faster, BUT, it's very important not to remove a floppy without unmounting it first. In fact, without former supermount it's now very important to perform systematically mount/unmount. I noticed that mount/unmount options exist at user's level with a right click on the floppy icon in the new devices window.

All times are GMT -5. The time now is 11:29 AM.