-   Mandriva (
-   -   firefox dos not open when run under user (opens only in root) (

saso 06-09-2005 12:51 PM

firefox dos not open when run under user (opens only in root)
well i think the subject says everything... ive installed mandriva 2005LE and then installed firefox that comes with it (1.0.2-6). but i am not able to open it under an user, it does however run under root... what to do?

regards, saso

nadroj 06-09-2005 12:56 PM

log in to your GUI as your normal user (which i hope you have been doing?) then open a console/terminal and load the program from there.. it should show you what happens when you execute it and why it doesnt want to.. post that output here. the command to open it should just be 'firefox'

tom_orrell 06-09-2005 12:58 PM

try this
I recently installed FireFox on Fedora2. Here is what I did.
Went to and downloaded the linux version
After unzipign and untarring the file, I saw an executable installer file, which installed fine.

If you need more detail, please let me know. tom orrell

saso 06-09-2005 03:39 PM

thank you for the fast replays! before i go and test your suggestion i will post some more info about this, maybe someone allredy knows about the problem and has a solution...

before mandriva 2005LE i had mandrake 10.0. in that version there was no firefox package, so i had to download and install the installer from mozilla. at the begining i had the same isue, i was not able to run it in user. the solution was to remove the firefox (delete the mozilla folder), reinstall it and then to run it in root for the first time. it seems that this creates "valid" directories and files. then i was also able to run it as user.

the problem this time is that i have install it from the mandriva install center and since i am a bit new to linux i dont know what to do since i dont know where firefox is installed this time (since i was using the madriva install center).

i can add that i have tried to remove it using the mandriva uninstall center, and then reinstall it and run in as root the first time. but this didnt help (i guess i shoudl find the firefox profile folder after the uninstall and delete it before instaling the firefox again).

and it is also a bit strange that the instalation of the firefox from mandriva instalation center does not work out of the box :(

tom_orrell 06-10-2005 09:16 AM

forget the rpms
Sounds like you are using the rpm package. When I tried to install from rpm package on my Fedora2 box, the only thing that happened was that the package unzipped. Then the installation just did not work. Strange since I was using rpm on a Red Hat type box like you are doing. The install package that I got from worked on the first try. Sounds like the rpm package is outdated.

If you need a quick fix, I can put the installer file on my web site. If you are just tinkering, carry on. tom orrell

saso 06-10-2005 01:46 PM

thank you tom for your help... i know where to get the installer from mozilla ad it is probably the next thing i will do since it seems i am not able to fix this usinf the installer from mandriva.

saso 06-11-2005 10:20 AM

ok, i was able to find the problem and fix it :)

the problem: \home\user\.mozilla was set that the owner and group was set to root

the fix: chane the owner and groop of \home\user\.mozilla to user

with other words, firefox was not able to create the profile in \home\user\.mozilla because it did not had the rights when starting under user :)

the only problem i still whave with that box is to install some solitare for my mom :D where are the gnome games :confused:

tom_orrell 06-13-2005 09:21 AM

Here is the link for gnome games,

Well done on your FireFox troubleshooting!

joemill 06-15-2005 10:07 AM

same problem here
ok saso so how did you change the ownership from root to user? I have this same problem. From reading the posts in here I think I started having this same problem when I tried upgrading from firefox 0.8 to the latest (I think its 1.4 maybe 1.0.4 not sure) Anyway, I noticed that it didn't upgrade. I have 0.8 in my startup list (don't know how to get it outta there) but the latest is in its own folder. For further info please read my post under "mandriva boot question" submitted by NikoJ. Thanks for any help you could give me.

All times are GMT -5. The time now is 12:58 PM.