-   Mandriva (
-   -   Extreme slow boot after updating to Mandrake 10.1 (

TommyB 04-03-2005 02:14 PM

Extreme slow boot after updating to Mandrake 10.1

I have update my Mandrake 10.0 machine to Mandrake 10.1 using Mandrake Update.
Everything went fine but when booting it takes years until the graphical login is appearing. Although the machine seems to do nothing.

Has anybody an idea what the machine is doing and how I can persuade it to show the login screen a bit faster.


CragStar 04-03-2005 08:52 PM

What stage seems to be taking longer?

It could be an init script that is waiting for something to happen whilst booting. Try pressing F2 or escape next time you get the loading bar appear to see if a particualr script is stalling. I've had problems from the network script when it's trying to get a DHCP IP address and it can't find one, takes a while to timeout.

Maxplayer14 04-04-2005 09:23 AM

Yeah, could you look at it in verbose mode and see what is taking longer?

And it my depend how you upgraded. I upgraded from Thac's urpmi's and it installed and started tons of services that I didn't use before. I had to go in and stop about 10 things from starting that in the past didn't start. Just food for thought. Also for some reason when I updgraded a few things took a little longer on boot. Not much a but a few seconds.

TommyB 04-06-2005 03:50 PM

All the script loading I can see at the boot seems to be OK.

From my point of view the starting of X is the problem as everything goes smoothly until the display changes to graphics. Then I can watch the sand clock for minutes.

For those that are interested, I posted the log file of a boot at

How can I initiate the verbose mode so that I can see what happened during the startup of X?

I did the update using the Actualize Mandrake Menu item of KDE (as I am using a German version I don't know what the exact English name is.


CragStar 04-06-2005 05:37 PM

Verbose mode is only during the stage when the boot scipts are ran (e.g. setting up network connections, any server services that need setting-up etc...).

As for your problem, it sounds similar to this:

Check the things that opjose suggests in that thread. not sure if they resolved the problem though.

TommyB 04-07-2005 05:53 PM

I think I solved the problem

I think I solved the problem without doing a clean installation. Although I do not know up to now which functions don't work due to my workaround.

What I did:
I installed udev and deinstalled devfsd.
However before you deinstall devfsd I advice to make a backup of your system as some kernels will refuse to boot. This happened to me with my 2.6.3 kernel. However lucky me the 2.4.25-2mdkenterprise kernel still booted. I got just an error message saying that udev cannot be used because it needs a 2.6.x kernel.

Thanks to all of you for giving me the helpful hints.

All times are GMT -5. The time now is 08:11 PM.