LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 02-02-2005, 11:30 AM   #1
mac57
Member
 
Registered: Nov 2004
Location: Texas
Distribution: openSUSE 10.3, Yoper Linux 3.0 , Arch Linux 2007.08
Posts: 253

Rep: Reputation: 30
Excessive Shorewall Logs - Solved


With the kind help of several posters here on the forum, I have resolved this issue, and thought I would post the solution in case it helps others.

The problem turned out to be CUPS doing a broadcast to the broadcast IP, apparently advertizing it availability. This must be standard behaviour, as I have done zero configuration on CUPS - just a standard MDK 10.1 install, and addition of my Canon i950 printer.

I checked the CUPS configuration (point your browser at http://localhost:631), but there were no options to control this behavior. Following a lead from one of the posters on this forum, I decided to solve the symptom, as opposed to the problem, which I cant seem to configure (CUPS broadcasting).

To turn off logging for the dropped broadcast messages, do the following as root:

- cd to /etc/shorewall
- edit the file "policy" in your favorite text editor.
- delete the word "info" from the two rules "net all" and "all all". Save and restart.

That did it for me. No more shorewall logs cluttering up dmesg output. I can now actually see the dmesg info - it used to be just a mass of shorewall logs (a "mess of shorewall logs? ), with "real" info interspersed here and there. No it is just "real" info.

Thanks to everyone who posted, and I hope that this may help a few folks.
 
Old 02-03-2005, 01:57 AM   #2
sgrayban
Member
 
Registered: Nov 2004
Location: Spokane, WA
Distribution: Debian 6.0
Posts: 369

Rep: Reputation: 30
you can also add in the rules file the following:

ACCEPT loc:127.0.0.1 all all -

Which will alow anything from your local box through
 
Old 02-11-2005, 01:54 PM   #3
DontPanic42
LQ Newbie
 
Registered: Feb 2005
Location: Mobile, AL, USA
Distribution: Mandrake
Posts: 1

Rep: Reputation: 0
I was able to fix this by changing the BrowseInterval in the cupsd.conf file from 30 to 0. Since I'm only using cups to print from my linux box, and not sharing out a cups printer, I'm not sure if this affects cups ability to share out a printer on a network.

I never had any success in modifying my Shorewall rules file to allow this traffic through.
 
Old 02-11-2005, 10:49 PM   #4
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
BTW:

THANKS!

For posting the resolution to your problem.

If more people did this we would not have to repeatedly type the same answer over and over... and the added feedback lets the people who reply know if they were on the right track.

Kudos.
 
Old 02-12-2005, 01:34 PM   #5
mac57
Member
 
Registered: Nov 2004
Location: Texas
Distribution: openSUSE 10.3, Yoper Linux 3.0 , Arch Linux 2007.08
Posts: 253

Original Poster
Rep: Reputation: 30
Thanks, even though I fixed the logs problem already, it always bothered me that CUPS was wasting my computer and network bandwidth mindlessly advertising itself when there was no one there to hear it (or care!). Thanks for the tip on how to disable this behavior.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
shorewall config question with /etc/shorewall/rules peter72 Linux - Networking 3 01-01-2007 10:33 PM
excessive cpu temp ? dukeinlondon Linux - Hardware 7 12-20-2005 06:10 PM
excessive paging utkanbir Linux - General 3 07-25-2005 04:41 AM
Excessive Shorewall Logs - Help! mac57 Mandriva 8 07-11-2005 07:36 PM
'PEAR.php' (include_path=''.:/usr/local/lib/php'') SOLVED SOLVED adengua Linux - Software 0 04-02-2004 04:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 09:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration