-   Mandriva (
-   -   Ethernet Card Realtek 8139 not working on MDK 10.1 community (

[MDK]NooB 05-09-2005 07:23 AM

Ethernet Card Realtek 8139 not working on MDK 10.1 community
i just installed the 4 disks version of mandrake 10.1 community and tried to configure my ethernet card.

i have a router working like a gateway [] and some machines linked to it through a switch.

this machine, addressed like worked for some days, until i added some more ram... and then stopped working, so i removed the ram... and it seemed to be losing lots of ping reply... i tried in many ways to make it work again, with no results...

the card works (i'm writing here, as you can see), but not on MDK...

how do i force link speed? would it make the ethernet card work?

any other suggestion?

acid_kewpie 05-09-2005 07:49 AM

you can use either mii-tool of ethtool to force a link speed if the card is supported, or you can usually pass these as direct options when loading the module. that's only useful if the problem actually IS the link speed. i had a similar problem last week where a NIC wasn't negotiating the speed correctly, and ethtool forced it and it was fine. This was coupled with a torrent of up / down errors visible in dmesg, so check there.

SlipAway172 05-09-2005 07:10 PM

fyi, 10,1 community is like to be considered a final beta. i would reccomend upgrading to 10.1 official or 2005

[MDK]NooB 05-10-2005 03:54 PM

ok... now it works... i just needed to force down 10 mbit FD...

i learned a little thing...
bye ;)

All times are GMT -5. The time now is 08:44 AM.