LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   error connectiong to the net (https://www.linuxquestions.org/questions/mandriva-30/error-connectiong-to-the-net-189633/)

shams 06-04-2004 08:40 AM

error connectiong to the net
 
hi,
i installed the apropriate driver for my hsflinmodem the result of
installation was"successfully installed"and with query modem in kppp it is
responding successfully,now when i want to connect to the internet with kppp
there is no any dial tone,but finally there is "loging on to the network" and
it is establishing the connection, but the connection is for no use i tried
the netscape and the gaim but the result was 'failed to connect' aparently
there is an estalblished connection but in the fact it is not connected to
the net.i use mandrake 10 with kernel 2.4.26,any idea plz.

otish1000c 06-04-2004 03:32 PM

try this in terminal, as root...........

Code:

ifdown eth0
hit enter

then type..........

Code:

ifup eth0
hit enter

try to connect. also, if you have a firewall running, disable that before issuing those commands. to see if it's running, again in terminal as root, type...........

Code:

service shorewall stop
hit enter

if it was running, it will tell you so & say it is now stopped.

otis

RockmanExe 06-04-2004 06:44 PM

otish1000c: i think eth0 is for an ethernet card, not a modem ;) but you're right about the possibility of a firewall issue

shams: from console type: 'ifconfig ppp0' and check if you're getting ip and dns addresses from your isp. Then ping to any url by its ip address like:
ping 216.239.57.99 ---> (google.com)

Regards

shams 06-04-2004 09:18 PM

thnaks for reply
 
hi Rockmanexe,
thanks for reply the problem was with shorewall firewall it is blocking the
whole net so i stopped it and problem is solved now ,but i want to use a
firewall or possibley this shorewall but if it is blocaking the whlole net
then what to do?
;)

shams 06-04-2004 09:45 PM

thanks for reply
 
hi Rockmanexe,
thanks for reply ,the problem was with shorewall it is blocking
the net so i disabled it now the problem is solved but still there is no dial tone.


;)

RockmanExe 06-05-2004 10:55 AM

Use iptables as firewall and guarddog as its frontend, which lets you manage iptables rules graphicaly, is very nice and easy to admin :)

shams 06-05-2004 08:47 PM

hi RockmanExe.
thanks i will try guarddog firewalll.
:)


All times are GMT -5. The time now is 07:17 PM.