LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 01-28-2006, 01:39 PM   #1
flibby
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Rep: Reputation: 0
Exclamation DVD drive doesn't mount automatically


Hi there,

ok, so I finally made a clean install of Madriva 2006.

I have a big problem now:

My DVD drive doesn't mount automatically when i put a CD or DVD in.
My CD burner mounts without a problem.

If i mount the DVD drive manually, i can access my files without a problem. But it doesnt auto mount.

I already tried activating Supermount, but my system hangs when i put a cd or dvd in when it is enabled.

Here is my fstab (the DVD drive is cdrom2):

Code:
# This file is edited by fstab-sync - see 'man fstab-sync' for details /dev/hda1 / ext3 defaults 1 1 /dev/hda6 /home ext3 defaults 1 2 /dev/hdc /mnt/cdrom auto 
umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0 /dev/hdd /mnt/cdrom2 auto 
umask=0,user,iocharset=iso8859-15,codepage=850,ro,users 0 0 none /mnt/floppy supermount 
dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 
0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

Any suggestions?
 
Old 01-29-2006, 12:34 AM   #2
bobbelfield
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Mandriva 2006
Posts: 154

Rep: Reputation: 30
Ill watch this thread myself as I have had CD mount problems all the way since Mandrake 10 and Mandriva is the only one that has given me a really useable drive . It mounts drives automatically and unmounts them when I take the dik out . Finally it worke like I would expect it to.

Do you have the devices icon on the Desktop and does the DVD mount in there?

Here is my fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/hda1 / ext3 defaults 1 1
/dev/hda6 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto umask=0022,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
/dev/hdd /mnt/cdrom2 auto umask=0022,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0022,iocharset=iso8859-15,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/sda1 /mnt/removable vfat pamconsole,exec,noauto,noatime,codepage=850,iocharset=iso8859-15,managed 0 0
 
Old 01-29-2006, 12:41 AM   #3
bobbelfield
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Mandriva 2006
Posts: 154

Rep: Reputation: 30
Lost the edit button
So notice umask=0022 yours is umask=0
Try changing this maybe
 
Old 01-29-2006, 08:14 PM   #4
Lakota
Member
 
Registered: Oct 2003
Location: London, ON, Canada
Distribution: Mandriva 2007 Free
Posts: 507

Rep: Reputation: 30
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
My automounting fstab entries for dvd rom & dvd burner

/dev/hdc /mnt/cdrom auto umask=0022,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
/dev/hdd /mnt/cdrom2 auto umask=0022,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
bobbelfield's automounting entries

/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-15,codepage=850,ro,users 0 0 none
Your top entry automounting, bottom entry not automounting.

Try this line out for your cdrom2 entry:
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
 
Old 01-30-2006, 03:49 AM   #5
sam.pedraglio
Member
 
Registered: Jul 2005
Distribution: Mint 14 64bit
Posts: 71

Rep: Reputation: 16
First of all, just a suggestion, if you post a log or a file, please post it with the right structure.
It's hard to follow all your mount points across the lines.
If yuor DVD it's the /dev/hdc mounted as cdrom, it's necessary to remove the noauto option from
fstab.


Quote:
Originally Posted by flibby
Hi there,

ok, so I finally made a clean install of Madriva 2006.

I have a big problem now:

My DVD drive doesn't mount automatically when i put a CD or DVD in.
My CD burner mounts without a problem.

If i mount the DVD drive manually, i can access my files without a problem. But it doesnt auto mount.

I already tried activating Supermount, but my system hangs when i put a cd or dvd in when it is enabled.

Here is my fstab (the DVD drive is cdrom2):

Code:
# This file is edited by fstab-sync - see 'man fstab-sync' for details /dev/hda1 / ext3 defaults 1 1 /dev/hda6 /home ext3 defaults 1 2 /dev/hdc /mnt/cdrom auto 
umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0 /dev/hdd /mnt/cdrom2 auto 
umask=0,user,iocharset=iso8859-15,codepage=850,ro,users 0 0 none /mnt/floppy supermount 
dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 
0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

Any suggestions?
 
Old 01-30-2006, 04:27 AM   #6
Lakota
Member
 
Registered: Oct 2003
Location: London, ON, Canada
Distribution: Mandriva 2007 Free
Posts: 507

Rep: Reputation: 30
Quote:
Originally Posted by sam.pedraglio
If yuor DVD it's the /dev/hdc mounted as cdrom, it's necessary to remove the noauto option from
fstab.
I may be wrong, but if you don't have the "noauto" option when you boot your system it will try to mount the cd or dvd, regardless of whether there is media in it. Not so sure you want that option for removable media.

Here is some useful reading on fstab structure: http://www.tuxfiles.org/linuxhelp/fstab.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to mount usb floppy drive automatically kushalkoolwal Debian 7 01-24-2006 08:18 PM
DVD Drive and CDRW Drive Will not mount on Slackware 10.1 Kernel 2.6.1 necrozen Linux - Hardware 1 09-13-2005 08:21 PM
My cd drive doesn't mount automatically in Slack thorney Linux - Newbie 3 08-03-2005 07:14 PM
can't mount a dvd on a cd burner/dvd rom drive dr_zayus69 Linux - Hardware 7 12-09-2004 08:56 AM
DVD drive doesn't mount Choey Slackware 7 10-05-2003 07:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 10:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration