Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.


  Search this Thread
Old 10-02-2003, 03:31 PM   #1
LQ Newbie
Registered: Sep 2003
Posts: 17

Rep: Reputation: 0
DVD DMA Won't Stay On

I have a DVD drive that Mandrake mounted at /mnt/cdrom2 and shows up as /dev/hde

When I enable DMA with hdparm -d1 /dev/hde and then do hdparp -d /dev/hde is shows DMA as enabled but when I access the drive it turned DMA off.

Does anyone know what could be causing this?

Old 10-03-2003, 12:06 PM   #2
Senior Member
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
How did you eneble DMA, from a command line or from the rc.local init script?

I have set the SCSI-Emultion on my DVD and turned on DMA on rc.local with the standard /dev/hdd device. It works flawelessly. Hrere's how:
  • Pass the scsi emulation parameter to your kenrel. In GRUB you do so by just adding to the following to the first kernel line:
    kernel /vmlinuz-<kernelversion> ro root=LABEL=/ vga=792 hdc=ide-scsi hdd=ide-scsi
  • Then you have to tell rc.local to add support for DMA for your drive. To so open in any text editor the file /etc/rc.d/rc.local and add this:
    hdparm -d1 /dev/hdc /dev/hdd
    Here I enabled DMA for both my cd-writer (/dev/hdc) and my DVD-Rom (/dev/hdd) drives
  • You will have to reboot for the changes in grub.conf to take effect and to start the SCSI emulation.
Hope this helps.

Last edited by Thetargos; 10-03-2003 at 12:07 PM.
Old 10-04-2003, 11:46 AM   #3
LQ Newbie
Registered: Sep 2003
Posts: 17

Original Poster
Rep: Reputation: 0
Thank you for thei tips, unfortunately, it still doesn't work. I made the changes to lilo and ran lilo with no errors. After rebooting the drive still showed up as /dev/hde and not scd1 (my cd reader is scd0).

The DVD drive is running off of a maxtor ATA 100 controller card so I'm guessing this could be causing the problem.

Old 10-04-2003, 12:06 PM   #4
Senior Member
Registered: Oct 2003
Posts: 2,559

Rep: Reputation: 213Reputation: 213Reputation: 213
Post your /etc/fstab file. When you change to scsi emulation you have to edit the cdrom line in fstab from /dev/hdx to /dev/scdx. Usually, the new hardware detection will pick up the scsi emalted drive on the first boot with it enabled and cofigure it for you, editing fstab. But if you ticked "Cancel" when the new hardware screen came up during boot, you'll have to edit it by hand.
Old 10-04-2003, 12:33 PM   #5
LQ Newbie
Registered: Sep 2003
Posts: 17

Original Poster
Rep: Reputation: 0
I made the change in fstab before I rebooted. Also, new hardware detection did not come up.

I'm thinking about getting a combo CDRW/DVD to replace both of my current drives and eliminate the Maxtor ATA 100 card today.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
No DMA on DVD Drive cootetom Linux - Hardware 12 06-01-2006 08:38 AM
DMA Mode won't stay set to "ON". morrolan Linux - General 2 09-23-2005 03:55 AM
How do I enable DMA for my DVD jbasement Debian 2 10-14-2004 07:55 PM
Suse 8.2 change my DMA setting on my DVD-R drive to off & IDE DMA MODE NOT SHOWING IT maximalred Linux - General 0 08-23-2003 04:58 AM
dma and dvd MightyKC Linux - General 11 07-04-2003 08:29 AM > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 09:04 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration