-   Mandriva (
-   -   Dual Booting WinXP/MDK with Lilo and Grub (

StealthSpectar 11-03-2004 10:02 PM

Dual Booting WinXP/MDK with Lilo and Grub
Hey everybody!
I got a serious problem here: Ive been on MDK and WinXP since a good 2 months, everything was perfect, Lilo was working without a problem. Then I decided to upgrade to MDK 10, I installed the Bootloader on MBR, I reboot my machine and all I see is an L with a blinking underscore....the bootloader just wont does the same thing for Grub.... I was able to restore the WinXP loader on MBR but I tried almost anything I could I wasn't able to launch lilo nor grub.
I have 60GB HD
A 40 GB partition for WinXP -Hda1
A 6 GB for Root
A 500 MB for Swap
And a 10.5 GB for Home

I would really appreciate if anyone could help me...

P.-S. I know that the problem doesn't come from the bootloader of the MDK 10 distribution because I also tried Suse 9.1 , does exactly the same thing.

Andrew Skinner 11-04-2004 07:18 AM

have you moved any partitions between having a working system and now ?
you don't say what you upgrded from. Upgrading from mdk 9.2 to 10 didi not work for me, I ended up formatting the linux partitions and starting from scratch

is the MBR at the botom of the disk ?

aus9 11-04-2004 09:29 AM

you may want to have a peep at this

StealthSpectar 11-04-2004 09:35 PM

I did start from scratch I reformated my Lin Partitions... But I just can't figure out whats wrong....
Yes, the MBR is at the beginning of the HD...

simjii 11-05-2004 08:22 PM

If the problem is simply caused by Lilo or Grub there is a way to fix it.
Boot with the installation CD, the first CD, and go to 'rescue' mode. You can reinstall Lilo from there.
If reinstall does not work you may have to uninstall lilo first and install it again.
To uninstall Lilo, go to command window in rescue mode and uninstall from there. There are a couple of options that allow to clean MBR to uninstall lilo but I don't remember since I have not been using lilo long time.

I hope it helps.

Andrew Skinner 11-09-2004 01:02 PM

is Linux on a continuous part of the the HD or has it partitions split across the drive ?
it could be that it you are now trying to put Linux at too high cyclinder count on the HD or are trying to put root in a different place to previous installtion. You could try deleting the linux pertitions using partition magic (or similar) and leaving them as empty space then Linux installer can decide how to use the space and will format as needed.

All times are GMT -5. The time now is 05:26 AM.