LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 11-25-2003, 02:48 PM   #1
ifurita
LQ Newbie
 
Registered: Aug 2003
Posts: 16

Rep: Reputation: 0
Unhappy Dependancy nightmare


I had bittorrent 3.3 working great under mandrake 9.1 however I installed 9.2 and now bittorrent is broken.

I've been able to reinstall bittorent itself from the RPM but when I try to install the Gui tools I get all sorts of dependancy problems. Here is what it reports when I try to run the gui rpm

It needs to do something with kdelibs-common-3.1.3-35mdk.i586 due to conflicts

So I tell it okay at which point I get these errors

Fail kdelibs-common-30000000:3.1.3-35mdk is needed by installed libkdecore 4-3

and something about it being needed by

libkdebase 4-3.1.3-79mdk

So at this point I don't know how to make the RPM work. I've tried the tar.gz but likewise I can't get the gui tools to behave.

Anyone know why this all worked under 9.1 but not under 9.2 and is there a way to fix it so it does work with 9.2?

Thanks
 
Old 11-25-2003, 03:30 PM   #2
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 570

Rep: Reputation: 30
I never but never (ok rarely) use rpm anymore with Mandrake. Go to url http://plf.zarb.org/
and setup your souces. Then do a urpmi bittorrent. This will dl the latest stable version and all dependences required. Then it will install everything required

Hope This Helps
 
Old 11-25-2003, 04:16 PM   #3
ifurita
LQ Newbie
 
Registered: Aug 2003
Posts: 16

Original Poster
Rep: Reputation: 0
Urpmi

I just gave it a try but I don't think it worked. After following all the steps then finally doing the urpmi bittorent it came back with the response
Please insert the medium named "International CD (x86) (cdrom3)" on dev/scd0]


Then my CD rom drawer opened. The problem is I know the Mandrake CD's only have bittorrent version 3.2.1 not the 3.3

So I'm afraid to proceed.

Any recommendations?
 
Old 11-25-2003, 07:08 PM   #4
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 570

Rep: Reputation: 30
It's looking a a missing file that just happens to be on cd3 or if you do a urpmi ./(filename) it will load the one you and still get all dependencies
 
Old 11-26-2003, 09:41 AM   #5
ifurita
LQ Newbie
 
Registered: Aug 2003
Posts: 16

Original Poster
Rep: Reputation: 0
Tried that

Well I did insert the third disk as it wanted and it decided it wanted to installed Bittorrent 3.2.1 rather than the 3.3 I had been trying to install. I kind of suspected that was what was going to happen since the Mandrake 9.2 disks only have 3.2.1 on them.

Anyway even trying to use the gui tools from 3.2.1 they still seem to be broken under Mandrake 9.2 There are curious errors when the btdownloadgui.py runs and it reports the first error at line 14.

I'm curious to know if anyone has bittorrent 3.3-gui running under Mandrake 9.2 or the 3.2.1 version for that matter. So far I haven't found any way in which to make this work.

Any suggestions would be appreciated!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dependancy HELL! JustinS Linux - Newbie 2 10-16-2004 12:29 PM
Dependancy Confusion Utah Linux - Software 12 06-10-2004 04:49 PM
penggy dependancy AbalamDemon Red Hat 1 05-18-2004 03:33 PM
Dependancy Nightmare slooper Linux - Software 2 08-17-2003 03:33 AM
cdbakeoven dependancy Johng Linux - Software 2 12-07-2002 04:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 07:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration