-   Mandriva (
-   -   Cpu "hlt" command and Mandrake 9.2 RC2, how do I get my laptop to run cooler? (

adamis 10-24-2003 07:34 PM

Cpu "hlt" command and Mandrake 9.2 RC2, how do I get my laptop to run cooler?
I have been messing with Mandrake 9.2 RC2 on my emachines 5310 laptop for some time. Problem is I can't get the dumb thing to run cool. I've read in several places that Linux like win2k is supposed to issue the hlt command to keep the processor cool when not used. I'm pretty sure my system isn't doing this. From what I have read there is the kapm-idled process but for some reason it's not running. Is this an APM thing only? If so, what is the equivalent for it in ACPI? ACPI seems to be working, at least it is reporting temps and bat stats, but I don't think it is doing much to decrease power usauge. Any help would be appreciated. This thing is cooking my lap whenever I use it.

benoxoft 10-25-2003 05:13 PM

Same problem...
Hi there,

I have the same problem with my laptop (Compaq Presario). I'm still working at
it but I know somes things that can help you. First, somes says than ACPI support is broken under Mandrake 9.1, so 9.2 might be too.

I found interesting sites about peoples who successfully solved the problem, go to for an example. He said he downloaded the latest ACPI Patch for his kernel at and then recompiled it with ACPI support. It worked for him but not for me, I have trouble with my configuration. Maybe you'll have to modify the /etc/lilo.conf file to enable ACPI support (by default, I think it's set to ACPI=ht).

Right now, that's all. If you find something about it, let me know.


P.S. I'm speaking french, I hope my message is comprehensible.

adamis 10-26-2003 01:49 AM

Hi, thanks for the response. As far as I can tell ACPI is working. I get battery status and CPU temp. I don't notice any sort of CPU cooling process that is giving the hlt command while not in use. Is ACPI supposed to have some sort of process that issues low power commands to the processor?

All times are GMT -5. The time now is 04:25 PM.