LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Conflict between glibc upgrade and initscripts in Mandrake 9.0, help! (https://www.linuxquestions.org/questions/mandriva-30/conflict-between-glibc-upgrade-and-initscripts-in-mandrake-9-0-help-229090/)

mvent2 09-10-2004 05:25 PM

Conflict between glibc upgrade and initscripts in Mandrake 9.0, help!
 
I am using Mandrake 9.0 and want to upgrade to glibc 2.3.2. But when I try to, it says glibc2.3.2 conflicts with initscripts. When I try to upgrade initscripts, it says I need an updated version of glibc!! I tried to upgrade to 2.3.1, as my rpms awaiting install requires > glibc2.3, but that conflicts with initscripts as well, and it also says locales requires glibc 2.2.5! This is what happens when I try to install glibc 2.3.1:

error: failed dependencies:
initscripts < 6.91-18mdk conflicts with glibc-2.3.1-10mdk
glibc = 2.2.5 is needed by locales-2.3.1.3-7mdk
glibc = 2.2.5 is needed by locales-2.3.1.3-7mdk

I can't go anywhere unless I upgrade my glibc to > 2.3. The programs I want to install are clanlib2-0.6.5-9mdk and pingus-0.6.0-5mdk. Somebody please help me out of this endless spiral of dependencies!!


All times are GMT -5. The time now is 03:31 PM.