-   Mandriva (
-   -   conexant accessrunner drivers won't install, just get "everything already installed" (

xxvm1 07-18-2004 01:19 PM

conexant accessrunner drivers won't install, just get "everything already installed"

in the left panel where it shows "detected hardware" you need to click on the modem entry, which you say is under "unknown/others". when you click on the modem entry, it should show info about your modem in the right panel labeled "information". under that panel should be 2 button bars labeled "configure module" & "run config tool". is there not? if not, then i'm a bit stumped because those are what you need to detect/set the modem up. those bars should be there for any hardware you click on in the left panel. is there any way you can post a screenshot of what you're seeing?

as for the "everything already installed" message.......... try right clicking on the rpm then, choose "open with"->"software installer". that will open up rpmdrake to install the package. it doesn't matter that you're not root, because it will ask for the root password before it lets you install.

if you can't get the config options set for the modem, there's one final sorta dirty hack you can try. unplug the modem, shutdown the computer, then restart it with the modem unplugged from the computer. let it boot into the desktop. run the hardware wizard in MCC. that should now show your modem not being detected. shutdown the computer again, plug the modem back into the computer, reboot & then then run the hardware wizard in MCC again to redetect the modem, then try installing the drivers with the RPM.
RE: otish1000c

I found the MCC > Hardware > Harddrake > Unknown/Other > ADSL USB Modem and click on it easily. Your directions were spot on, and yes i saw the info on the page to the right. Unfortunately i do not see any "configure module" or "run config tool" buttons. You are welcome to a screenshot. Provide an email address and i shall send it as an attachment.

I had already tried right clicking the driver file and selecting "software installer" aswell but it still produced the "Everything already installed" message box. I also tried searching for the new driver i want to install (which i have placed on the desktop) in the Software Installers thingy searching "ppp" but it doesnt find it for some reason, despite the fact i can see it sitting on the desktop.

I followed the "dirty hack" to the letter aswell i'm afraid, but upon trying to install the rpm "Everything already installed" message box again. It's all very frustrating. I've never yet been prompted to provide a root password when messing about. Is there a chance that for some reason the lack of prompts mean i'm attempting to uninstall/install drivers as a normal user instead of root?


xxvm1 07-18-2004 08:43 PM

ive messed about in root but i cant even find my USB pendrive running as root, so no chance of finding the drivers on it

xxvm1 07-19-2004 04:44 PM

as root for some reason /dev/sda or /dev/sda1 don't have any files on them, and thats the normal place where my USB pendrive lives i think. If i can find my usb pendrive as root i would be able to have a go at installing the rpm again, however i'm sure i will just get that stupid message again, despite the fact its not installed

X gmessage

Everything already installed

otish1000c 07-20-2004 05:35 AM

i'm sorry, but i don't have use any USB drives or removable USB storage, so i'm not real familiar with the procedures of using them. not sure, but they may need to be mounted first. first, try inserting your pendrive before booting, then boot. it may need to be detected as active during boot for an automount. if that's not the case, then with pendrive inserted, open a terminal, su to root, then type....... mount /dev/sdX (with X being the letter/number of your usb device) ....... hit enter. that should mount it. if that works, to unmount it type....... umount /dev/sdX (hit enter) as root. also, can't you just either transfer the rpm to a floppy or CD in Windows should the above fail to work? then you can just install it in MDK from one of those instead of the pendrive.


xxvm1 07-20-2004 07:36 AM

i still think it's a bit weird that i'm not getting prompted for the root password when i'm changing things as my normal username, but the old ppp-2.4.1-12mdk type drivers are long gone now and i just want to put the ones i've downloaded in. But this is never going to happen whilst this "Everything already installed" message keeps coming up.

i've tried logging in as root and i've tried opening a terminal and typing every variation of 'mount /dev/sda' i can think of but nothing works. I've tried booting into linux with the removable device already in, and i've tried putting it in after boot up, nothing works. Strange thing is, when i'm running on my normal username instead of root it picks up the usb drive fine either straight from boot up or hotplugged.

i've also looked in the MCC > Hardware > Harddrake > Unknown/Others > ADSL USB Modem and clicked it. The info about the modem displays in the box on the right as expected but there arent any "config" options of any form anywhere.

i guess now i'll try burning the drivers i downloaded onto a RW disc and see if i can install them as root from there. But i reckon i'll just get the same problems as i am with the usb drive.

has anybody got the foggiest idea why mandrake is being so gay about installing these simple drivers?

xxvm1 07-20-2004 10:42 AM

is this problem i'm having Mandrake's fault or the Linux kernel's fault? Because access to the internet is important to me in linux and if Mandrake isn't up to the task then i shall move on YET AGAIN in the search for a good one. I hope i don't have to though because Mandrake is by far the most user friendly install and use i've had yet.

xxvm1 07-21-2004 07:54 AM

would SuSE 9.1 be any better at handling these drivers ?

xxvm1 07-21-2004 06:11 PM

don't tell me i've stumbled upon the only problem that no mandrake user knows the answer to.

heema 07-21-2004 07:13 PM

i also have a USB conexant accessrunner (pppoa) and it works gr8 with mandrake 10 , i made a Howto i hope it works for u :

I made this HowTo to help others like me to connect with ease
Note : i am still a newbie and this is my first howto so bear with me :)

Connecting by Conexant USB Adsl (pppoa) using Mandrake 10 official :

1) Go to ,
download cxacru-2003-10-05-src.tgz and patch-upto_2.6.5_20040517_accessrunner.gz

2) Install the kernel source from rpmdrake

3) Patch the kernel
# cd /usr/src/linux
# gunzip -c patch-2.6.x_YYYYMMDD_accessrunner.gz | patch -p1

4) Recompile the kernel
# cd /usr/src/linux

backup the .config by copying to any other location

# make mrproper

restore the .config

# make menuconfig

Go to section

Device Driver -> Networking Support -> Networking Options -> ....

<M> Asynchronous Transfer Mode (ATM) (EXPERIMENTAL)
<M> Classical IP over ATM (EXPERIMENTAL) [*] Do NOT send ICMP if no neighbour (EXPERIMENTAL)
<M> LAN Emulation (LANE) support (EXPERIMENTAL)
<M> Multi-Protocol Over ATM (MPOA) support (EXPERIMENTAL)
<M> RFC1483/2684 Bridged protocols [*] Per-VC IP filter kludge

Then Go to section

Device Driver -> USB Support ->
<M> Support for USB
.... (go near the end of the page)
<M>Alcatel Speedtouch USB support (NEW)

then save

# make

# make bzImage

# make modules

# make modules_install

# make install

5) Restart

6) Go to rpmdrake and search for atm these packages will be the result
liblinux-atm1 , liblinux-atm1-devel , linux-atm , ppp-pppoatm
install them

7) Untar cxacru package to any folder and type
# make new

8) Substitute and in "/usr/sbin" with the modified ones that you have downloaded from the site

9) Edit file /etc/cxacru to your needs
here is mine :

# Config file for Conexant AccessRunner

# Driver mode
DRIVER_MODE=1 # 1 = normal, 2 = debug, 3 = normal+max speed (without ask adsl status), 4 = debug+max speed (without ask adsl status)

# Protocol
PROTOCOL_MODE=2 # 1 = RFC1483/2684 routed, 2 = PPP over ATM (pppoa), 3 = RFC1483/2684 bridged, 4 = PPP over Ethernet (pppoe)

# Paths

# if OPEN_MODE is blank then cxload uses default mode acoording VID & PID
# Values for OPEN_MODE are:
# 0 = auto selection, G.Handshake
# 1 = auto selection, T1.413
# 2 = G.Handshake
# 3 = ANSI T1.413
# 4 = ITU-T G.992.1 (G.DMT)
# 5 = ITU-T G.992.2 (G.LITE)


# Specific for RFC1483/2684 routed/bridged
# if IP_ADDRESS is blank in bridged mode then it uses DHCP to get IP

10) Edit your options file in /etc/ppp

lcp-max-configure 50
name any
user "insert your username here"
plugin /usr/lib/pppd/2.4.1/ 8.35

11) Edit the pap-secrets file
# Secrets for authentication using PAP
# client server secret IP addresses
'username' * 'password'

12) Edit the chap-secrets file
# Secrets for authentication using PAP
# client server secret IP addresses
'username' * 'password' *

13) Edit the resolv.conf in /etc and insert in it your DNS
if you dont know it you could get it from windows by typing ipconfig /all

14) Go to /usr/sbin
# su

# ./

And wish that it will connect the first time :)

heema 07-21-2004 07:20 PM

sorry i just noticed that u use mandrake 9.2
for mandrake 9.2 u dont have to patch the kernel as this patch is meant for kernel 2.6 , and if the options above are already in ur kernel config then u dont have to recompile the kernel

xxvm1 07-22-2004 08:28 AM

Hey i'm not opposed to changing to Mandrake 10 if it gets me online. The only problem is i changed from Mandrake 10 to the older 9.2 version in the first place because it kept crashing constantly. So much so that it rendered it more or less unusuable.

But being a newbie i really just look at all that code and the idea of "recompiling a kernel" and just stare opened mouthed.

So bearing in mind that i'm currently using Mandrake 9.2, any idea how i can install this rpm package with my drivers on without getting that "Everything already installed" message?

otish1000c 07-22-2004 01:52 PM


frankly, i'm stumped as to how to correct your problem. i was hoping somebody else would have an answer. but, apparently not. i've seen so many "weird" internet connection problems lately & i don't understand how to fix them because everything i can think of that should work, doesn't seem to work. personally, i've never had a problem since i started using Linux with MDK9.0 up through 10.0. maybe it's because my DSL modem is supported (Westell) & so is my eth0 card (Linksys). maybe it's 'cause i have a straight forward ADSL connection with no router, no USB, no network. i dunno.........

as for your dilema, i really don't think recompiling the kernel will help, but then again, since i've never been in this situation, it might be worth a try. be warned.......a kernel compile on MDK can sometimes be a total nightmare, due to the way MDK sets up there OS. it's usually best to use a proprietary MDK kernel & leave it be. in lieu of a better idea from somebody else, here's what i'd try.......

1. give 10.0 another shot. you said it kept crashing for you? how so & when? i haven't had it crash for me once, nor lock up, nor have i had any problems with it. if you don't have anything on MDK you care about losing, i'd do a fresh install of it instead of an upgrade & just back up what you might not want to lose.

2. if you're totally against 10.0, then i'd first try upgrading the 9.2 install with 9.2. meaning, boot from the 9.2 install disk & choose "upgrade" when you are asked. that will detect what's already installed, what might be buggered & replace things as neccessary. or, you could also just start fresh with 9.2 & reinstall it.

regardless of what you choose, i'd pay special attention to the final configuration settings screen after the software installation part is done. before you accept the configs, even if you don't get any red "not configured" messages, double check the settings of things, especially where your modem is concerned. if it can't find a compatable driver at that stage, find something that may be close, then as soon as you get to desktop, uninstall the MDK drivers & then install that plf rpm before you do anything else. also pay close attention to your internet config settings & make sure everything looks cool in there.

i wish i could offer a "magic bullet" to you, but i can't. having not ever had these problems or ever used the hardware you have, i can only offer what i think should work to fix things. obviously, that line of thinking isn't working.


xxvm1 07-23-2004 02:48 PM

RE: otish1000c

On the plus side i've always found your tips and advice very positive. Even though my problem is still in the air somewhat i have learned from it so far. Clearly it doesn't help that my modem in particular doesn't have any linux drivers written specifically for it. However i have heard that these Conexant AccessRunner drivers will do it. If only i could get the pesky things in. It would probably be just my luck to get them in and find that they aren't in fact compatible afterall. Luckily i am soon changing my internet situation. Currently i am on 512k with my unsupported(?) USB modem, but i will shortly be on a 50/50 shares 1mb connection. So hopefully i will be able to choose a compatible modem/router for linux and windows OS.

I had a horrible time with Mandrake 10 which i installed before i tried 9.2, as my common sense told me that the latter one would be more suitable. It crashed a lot, and i mean A LOT and completely at random. The input i got in here was a problem with my sound drivers causing trouble. Rest assured as it was Mandrake 10 in my case was unusuable. My hardware is as follows:

Shuttle SN45G small form factor case, FN45 shuttle mainboard, AMD 3200+, 2 x 512mb Crucial DDR400 dimms, ATI (yeah i know) 256Mb 9600XT, nForce2 chipset, nForce integrated sound, Seagate 160Gb ATA100 8mb cache HDD, Sony DVD R/RW dual format 4x, Origo ASU-8000 USB (only) modem, 128Mb USB Lexar JumpDrive Secure (removable storage).

So if any of my hardware is ringing alarm bells over there in Linuxland give me a shout eh.

In the time being, i will "upgrade" my existing Mandrake 9.2 installation from the CD's just in case it is buggered like you say. And no i really don't have anything worth keeping on my Mandrake 9.2 and my only gripe with going back to 10 is the huge problems i had with it. If you maybe know how to pre-empt those by installing/not installing certain parts then i'm all ears for sure. I just fear the same thing happening again is all. But yes i have no problem going back to Mandrake 10, some people seem to have it running stable somehow and i guess the drivers are more up to date.

What do you reckon ?

otish1000c 07-23-2004 03:23 PM

i see nothing in your hardware that should be troublesome for a working install. proprietary ATI/Nforce drivers could be a little headache inducing afterwards, should you try to use them, but the MDK drivers will work fine to get you going.

the modem................. :rolleyes:

you're correct when you say that 10.0 has better driver support. whether that will help your particular case, i don't know. 10.0 seems to be very hit or miss with people. some folks (like me) haven't had a problem with it & love it. others (like yourself) have nothing but headaches & loathe it. all i can recommend is if you go the 10.0 route, just pay special attention to that final configuration screen during install. (you should actually pay attention to that part during any version install, IMHO) alot of people neglect to check things there. and, like i said before, there are times when a particular piece of hardware will show as configured properly there, but if you open up the settings for it you'll discover that it isn't really. i've had that happen on my old machine with ATI drivers & on this new on with my SB Live card. if you catch something not right during that stage & can fix it there, it can save a lot of troubles later on.

after re-reading heema's post about recompiling your kernel, it might not be such a bad idea to follow his instructions & give it a try. all he's having you do is add driver/module support for your connextant stuff, so it isn't really gonna bugger your kernel, only add something to it that it doesn't currently have. again, i've never dealt with this particular driver issue, so you'd have to trust that heema's instructions are correct. (no offense, heema) i can vouch for the basic kernel recompile info, but i plead the 5th on the driver specific stuff.

since you said there's nothing you care about losing, give the kernel compile a try, or try one of my theories about reinstalling/upgrading. what have you got to lose at this point?

if i think of anything else, you'll be the second to know.


xxvm1 07-23-2004 03:58 PM

You are right, i certainly have nothing to lose. As its currently 21.40 here i shall probably try reinstalling Mandrake 10 tomorrow and examining it thoroughly before completing the install.

But my god that kernel recompilation looks extremely difficult and surely i'd be well out of my depth there. Is it possible for me to recompile it whilst following his advice on an Open Office document? Because otherwise i just wouldn't be able to remember all that.

All times are GMT -5. The time now is 11:49 AM.