-   Mandriva (
-   -   compiling mdk 10 kernel (

DAChristen29 05-05-2004 10:12 AM

compiling mdk 10 kernel
what commands do i do (and what order) to compile a new kernel in mdk 10 kernel 2.6.x???

ive already read 2 articles, one from LQ, and one from techTV's website from Chris Di'Bona. they both tell me to do two different things. i tried the one from linuxQuestions, and it compiles and installs. but when i reboot, i boot into my custom kernel, and it gives me the error (after Lilo boots) "kernel panic: try passing a init= option to the kernel" and it has also modified my default mandrake kernel, making my system unbootable. ive ficed it now, but i want to recompile another kernel to get better ACPI support, and i dont want to mess it up this time.

i would do more google searching, but ive found too many articles that tell me to do different things. im confused.

i did this: (i think this is what i did, i may be wrong)
make mrproper
make xconfig
make modules
make modules_install
make install

Stanely Pain 05-05-2004 01:42 PM

Did you properly modify your lilo.conf (if using lilo) to point to the proper initrd file?

The order of compilation looks ok.

cb_linus 05-05-2004 01:51 PM

I generally use this one and it works fine as a guide. Unfortunately, the options in Lilo both seem to refer to the new kernel (so if I make a mistake, which I've done plenty of times, I don't have the old kernel to go back to).

I think you basically need to keep a copy of your old kernel (kernel image?) before recompiling it (or compiling a new one) and make sure there is a reference to it in your lilo.conf (/etc/lilo.conf). I'm not actually too sure the best way of doing this (I find it slightly confusing that there are so many differing ways of achieving the same thing :()

There should also be an interesting readme in /usr/src/linux which helps to explain things a little bit. This is probably what you need to do (from the readme):


If you boot Linux from the hard drive, chances are you use LILO which
uses the kernel image as specified in the file /etc/lilo.conf. The
kernel image file is usually /vmlinuz, /boot/vmlinuz, /bzImage or
/boot/bzImage. To use the new kernel, save a copy of the old image
and copy the new image over the old one. Then, you MUST RERUN LILO
to update the loading map!! If you don't, you won't be able to boot
the new kernel image.

Reinstalling LILO is usually a matter of running /sbin/lilo.
You may wish to edit /etc/lilo.conf to specify an entry for your
old kernel image (say, /vmlinux.old) in case the new one does not
work. See the LILO docs for more information.

DAChristen29 05-05-2004 03:00 PM

thanks for that link, ill try that way.

i used mandrake control center to point it to the default "initrd.img", i had that error, so i used a rescue cd and changed it to "initrd-2.6.4mdkcustom.img", i tried all the other variations of initrd, and none of them worked.

ill try this tonight.

Francis Pontes 05-05-2004 03:04 PM

type (make help) in /usr/src/linux
make clean
make all
make modules_install
make install

This is only for 2.6.x series

I have another problem. My network module (8139too) don't work with my new kernel.

DAChristen29 05-05-2004 04:09 PM

ooo, i had that problem. with kernel 2.6.0, y network or sounds didnt work, but for some reason, it works with 2.6.4 kernel on mandrake 10. you probably just have to wait until your next distro version is released.

DAChristen29 05-06-2004 09:51 AM

well, i did it again. i get the same problem. i did
make bzImage
make modules
make modules_install
make install

and i get the "kernel panic, no init found, try passing init= to the kernel" same darn thing, and no i cant boot my system. this is imperative that i get a custom kernel, because the stock kernel is having heat issues with my CPU, and it is constantly overheating. i can barely compile the kernel withouth it being on the verge of melting my case (laptop).

what else can i do? i think "make install" makes an initrd automatically, and configures LILO.

Stanely Pain 05-06-2004 05:05 PM

Verify that your /etc/lilo.conf file does indeed contain the proper initrd.img file and that it is setup properly.

DAChristen29 05-06-2004 05:49 PM

did that. i just switched to grub. ill try something else. ill try doing it all WITHOUT the make install, and treat it as a 2.4 kernel. ill check back here tomorrow and report the results.

DAChristen29 05-07-2004 10:02 AM

just spent all last night recompiling and installing 5 kernels and initrd files, and nothing has worked. i even tried the default initrd from mdk10 and it doesnt work either. somehting isnt right here.

DAChristen29 05-07-2004 03:10 PM

for more specifics, it says it cant mount the ReiserFS, which is strange, because if it was the initrd, shouldnt the default initrd from mdk10 work? it works with the default kernel.

im making such a big fuss because the other day, my laptop just about melted onto my desk because of the heat issues. i NEEEED to rebuild the kernel with (better)ACPI support so that wont happen.

doesnt the default kernel have ACPI built-in? im sure its turned on in my boot loader (acpi=on), but it still isnt working.

All times are GMT -5. The time now is 07:24 PM.