LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 11-15-2004, 04:41 AM   #1
mouth
LQ Newbie
 
Registered: Nov 2004
Posts: 15

Rep: Reputation: 0
Compile error for KaxTV


MDK 10.1 AMD64 (x86_64) RC1
2.6.8.1-12.5mdk #1 Fri Oct 22 09:49:19 EDT 2004 x86_64 AMD Athlon(tm) 64 Processor 3200+ unknown GNU/Linux

Am trying to compile KaxTV (perso.club-internet.fr/hftom/kaxtv/) but get the following error...

[root@phantom kaxtv-0.23.2]# ./configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
[...]
checking for Qt... configure: error: Qt (>= Qt 3.0.3) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

but I do have qt-mt....

[root@phantom kaxtv-0.23.2]# ldconfig -p | grep qt-mt
libqt-mt.so.3 (libc6,x86-64) => /usr/lib/qt3/lib64/libqt-mt.so.3
libqt-mt.so.3 (libc6) => /usr/lib/qt3/lib/libqt-mt.so.3

and also...

Code:
[root@phantom kaxtv-0.23.2]# ls -la /usr/lib/qt3/lib64/libqt-mt*
-rw-r--r--  1 root root     808 Sep 27 17:05 /usr/lib/qt3/lib64/libqt-mt.la
-rw-r--r--  1 root root     915 Sep 27 17:05 /usr/lib/qt3/lib64/libqt-mt.prl
lrwxrwxrwx  1 root root      17 Nov 13 01:25 /usr/lib/qt3/lib64/libqt-mt.so.3 -> libqt-mt.so.3.3.3*
lrwxrwxrwx  1 root root      17 Nov 13 01:36 /usr/lib/qt3/lib64/libqt-mt.so.3.0.3 -> libqt-mt.so.3.3.3*
-rwxr-xr-x  1 root root 8422992 Sep 27 17:06 /usr/lib/qt3/lib64/libqt-mt.so.3.3.3*
[root@phantom kaxtv-0.23.2]# ls -la /usr/lib/qt3/lib/libqt-mt*
-rw-r--r--  1 root root     804 Sep 23 19:21 /usr/lib/qt3/lib/libqt-mt.la
-rw-r--r--  1 root root     913 Sep 23 19:21 /usr/lib/qt3/lib/libqt-mt.prl
lrwxrwxrwx  1 root root      17 Nov 13 01:38 /usr/lib/qt3/lib/libqt-mt.so.3 -> libqt-mt.so.3.3.3*
lrwxrwxrwx  1 root root      17 Nov 13 01:36 /usr/lib/qt3/lib/libqt-mt.so.3.0.3 -> libqt-mt.so.3.3.3*
-rwxr-xr-x  1 root root 7254960 Sep 23 19:22 /usr/lib/qt3/lib/libqt-mt.so.3.3.3*
Anyone able to tell me what the issue is and how to correct?
 
Old 11-15-2004, 04:51 AM   #2
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
To correct this problem... as root from a console prompt... type in

urpmi libqt3 qt3-common linqt3-devel

You are missing one of the required DEVELOPEMENT Libraries.

Also set your URPMI sources correctly....

http://www.zebulon.org.uk/urpmi_en.html
 
Old 11-15-2004, 08:08 AM   #3
mouth
LQ Newbie
 
Registered: Nov 2004
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks.

I have libqt3, lib64qt3, qt3-common, and lib64qt3-devel. But not libqt3-devel ....

[root@phantom kaxtv-0.23.2]# urpmi lib64qt3
Everything already installed
[root@phantom kaxtv-0.23.2]# urpmi libqt3
Everything already installed
[root@phantom kaxtv-0.23.2]# urpmi qt3-common
Everything already installed
[root@phantom kaxtv-0.23.2]# urpmi lib64qt3-devel
Everything already installed
[root@phantom kaxtv-0.23.2]# urpmi libqt3-devel
no package named libqt3-devel

I don't have any URPMI sources set for the i586 (32bit) packages. Since the x86_64 install doesn't come with it pre-installed (many other 32 bit libraries are installed), is it an oversight or a reason? Would I break anything or cause any problems by installing the 32bit libqt3-devel rpm?
 
Old 11-15-2004, 08:30 AM   #4
mouth
LQ Newbie
 
Registered: Nov 2004
Posts: 15

Original Poster
Rep: Reputation: 0
"file /usr/lib/qt3/bin/qmake from install of libqt3-devel-3.3.3-26mdk conflicts with file from package lib64qt3-devel-3.3.3-26mdk"

Seems there is a reason why the 32bit qt3-devel library isn't installed with base install on 10.1 x86_64.

I guess I need to be looking at some way of correcting KaxTV's mis-decision that qt3 isn't installed?
 
Old 11-15-2004, 12:45 PM   #5
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Except that this program is not looking for the 64 bit version...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
(s)vcd with k3b from kaxtv recordings??? Bikerpete SUSE / openSUSE 0 12-27-2004 05:10 AM
compile error laxi Slackware 3 07-01-2004 06:26 PM
compile error with 2.6.5 jamaas Linux - Newbie 6 04-17-2004 02:11 AM
compile error: #error unknown processor family kmack2001 Linux - Newbie 0 02-14-2004 12:52 PM
Alsa compile error, and a WINE error scheidel21 Linux - Software 1 12-08-2003 09:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 02:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration