LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 03-06-2004, 03:17 PM   #1
chinaundead
Member
 
Registered: Feb 2004
Location: UK
Distribution: Mandrake 10 Official
Posts: 123

Rep: Reputation: 15
Chinese Input Problem


Hi,

How can I input chinese in mandrake9.2?
It seems like there is a Chinese input in my computer named "XCIN" by default, but when i type
"xcin" in command line, error accured, it says:

XCIN (Chinese XIM server) version xcin 2.5.2.3.
(module ver: 20000831, syscin ver: 20000210).
(use "-h" option for help)

xcin: locale "en_GB.UTF-8" encoding "utf-8"
xcin: error: /etc/chinese/xcin/xcinrc:
locale section "en_GB.UTF-8": DEFAULT_IM: value not specified


Any solutions about XCIN?
or is there any other Chinese Input system i can use?

Thank you in advance!!!
 
Old 03-08-2004, 07:27 AM   #2
chinaundead
Member
 
Registered: Feb 2004
Location: UK
Distribution: Mandrake 10 Official
Posts: 123

Original Poster
Rep: Reputation: 15
 
Old 03-10-2004, 02:49 PM   #3
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
Chinese Input Problem

Hi,

Basically you need to make sure that your locale settings are set to zh_CN, which is for simplified Chinese (zh_TW.Big5 for traditional Chinese).

If you are using Simplified Chinese, then you may be better off using fcitx instead of xcin, it looks nicer and is pretty easy to set up. Go to www.fcitx.org to download and set it up, there is a good instruction page (in English & Chinese).

Also, you can type "Chinese Input" or "fcitx" in the Linux Questions.org search function, and this should list several postings/threads in which we have sort of collectively worked out how to set up Chinese in Mandrake and other distros...there are step by step instructions in some of these postings..."How to enter characters in another language" was one of them...

cheers,

jdw
 
Old 03-11-2004, 11:01 PM   #4
Burna
LQ Newbie
 
Registered: Jul 2003
Location: Beijing - Berlin - Beijing
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
Hi,
If you are interested in an English desktop and chinese input, take a look at my HOWTO http://gerrit-worldwide.de/chinesischlinux2_eng.html
It is written for a German desktop and SCIM as input system, but at the end it is the same procedure. FCITX is working as well.
Hope that helps.
Burna
 
Old 10-09-2004, 06:17 AM   #5
kozaki
Member
 
Registered: Jun 2004
Location: France, UE
Distribution: Arch Linux, Bodhi, Debian, Mageia, OpenMediaVault, Q4OS
Posts: 133

Rep: Reputation: 20
Thumbs up

Burna, in the howto you nicely to provide to us, you wrote :
Quote:
modify the file /etc/X11/xinit/XIM (...) If you want to use SCIM make sure the file contains the following under and delete everything that was listed there previously
Well, on my system, this file is full of instructions related to Enlightement as well as Gnome, etc. Which are not in the code you provide.

So i hope this won't affect something (and make a backup of XIM first).

[EDIT] It works !
I'm so happy to follw your link Burna
Is it you who wrote this howto ? Names differ..

Anyway, only OOo still doesn't want to get it. With other apps, i now can write in chinese [/EDIT]

Otherwise, as yourself i don't want to have a chinese system, but input Chinese (zh_cn).

Hope it works !

Last edited by kozaki; 10-09-2004 at 04:07 PM.
 
Old 10-09-2004, 08:45 AM   #6
hulkt
Member
 
Registered: Oct 2003
Posts: 172

Rep: Reputation: 30
u have to edit the xcin file in /etc... but i warn, it 's hassle, iwasnt able to configure it myself (exact same error) and i ended up screwing fonts on my install. beware!
 
Old 10-09-2004, 08:13 PM   #7
Burna
LQ Newbie
 
Registered: Jul 2003
Location: Beijing - Berlin - Beijing
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
Quote:
Originally posted by kozaki

Anyway, only OOo still doesn't want to get it. With other apps, i now can write in chinese [/EDIT]

Otherwise, as yourself i don't want to have a chinese system, but input Chinese (zh_cn).

[/B]
Hi kozaki,

What distribution do you use? Since I wrote this HowTo for Mandrake 9.1, I don't know, if it works also for later versions. I'm know using Slackware and just installed SCIM (which is IMHO better then FCITX) and added the line

export LC_CTYPE=zh_CN.UTF-8

to the file /etc/profile. So, if you have this file on your system, do the same and I guess OO will work as well.
 
Old 10-09-2004, 10:19 PM   #8
yktang
LQ Newbie
 
Registered: Jul 2003
Posts: 15

Rep: Reputation: 0
The new mandrake Community 10.1 supports Chiniese inputs. You can only type Chinese in some programs like Mozilla. But it doesn't work in OpenOffice.
 
Old 10-10-2004, 09:09 AM   #9
kozaki
Member
 
Registered: Jun 2004
Location: France, UE
Distribution: Arch Linux, Bodhi, Debian, Mageia, OpenMediaVault, Q4OS
Posts: 133

Rep: Reputation: 20
Quote:
Originally posted by Burna
Hi kozaki,

What distribution do you use? Since I wrote this HowTo for Mandrake 9.1, I don't know, if it works also for later versions. I'm know using Slackware and just installed SCIM (which is IMHO better then FCITX) and added the line

export LC_CTYPE=zh_CN.UTF-8

to the file /etc/profile. So, if you have this file on your system, do the same and I guess OO will work as well.
Hi Burna,

Again, 谢谢 (Thank you) for your howto, and for letting me publish a French translation

I followed it --> it works perfectly on a Mandrake 10.0 with SCIM-0.99.2

The fonts trouble I had with OOo are gone with a reboot. And yeah! it's nice beeing able to write chinese like a snap on Linux

Does the /etc/profile edit replace some of ~/.i18n editing ?

Please tell me whenever you manage to test a quicker solution than the one you wrote in Beijing last year.

I'll return here as soon ASAP ang add the French translation url.


ps : what made you shift from Mdk to Slackware 10 ?


[EDITn] French translation in here > Ecrire en chinois (there's a small chinese flag)[/EDIT]

Last edited by kozaki; 10-10-2004 at 07:36 PM.
 
Old 10-10-2004, 09:07 PM   #10
Burna
LQ Newbie
 
Registered: Jul 2003
Location: Beijing - Berlin - Beijing
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
Cool to see, that typing Chinese works now for you.

First, you can directly change the fontsize under Scim setup - panel - gtk.
Under Slackware, I don't have a -/.i18n file anymore. My guess is, that all programs get there information from another place. KDE has it in its -/.kde directory somewhere. For GTK I haven't figured out yet, since I have just English locales installed. Editing the /etc/profile is as if for opening a program you type everytime in a console

LC_CTYPE=zh_CN.UTF-8 the_program_you_want_to_open

which allows you to type Chinese in that program. Of course "scim -d" has to be running.
Just rename your -/.i18n, add the entry in /etc/profile and see, what happens!

Slackware also has no XIM file anymore. You can also try to rename it and see what happens. That way you have probably to start scim -d in a console with every new WM-session. As for KDE I put "scim -d" in autostart. So in Slackware I just installed SCIM and edited /etc/profile. That is actually much more simple than before.

For me Slackware was even easier to install and I like its straight nature. Mandrake and most other distribution split a program in too many packages IMHO. A single package including the header files makes it later easier to compile other programs and you get a better overview over everything installed. I wanted a plain KDE and I always ended up to compile it by myself under Mandrake. I also dislike the dependency checking. If you install many programs from source sooner or later you can forget urpmi. I'm know spending less time to fiddle around on my system, because out of the box Slackware is like I want it to have. But just a matter of taste.
 
Old 11-03-2004, 12:40 PM   #11
teledyn
LQ Newbie
 
Registered: Nov 2004
Location: Sauble Beach, Ontario, Canada
Distribution: Mandriva/Mandrake, RedHat, Debian, Ubuntu, Gentoo, Morphix, Knoppix, Peanut
Posts: 21

Rep: Reputation: 15
Mandrake Community 10.1 and xcin

Quote:
Originally posted by yktang
The new mandrake Community 10.1 supports Chinese inputs. You can only type Chinese in some programs like Mozilla. But it doesn't work in OpenOffice.
This is exactly the same behaviour we found, updating a machine from 9.2 to 10.1 -- I've noticed the Community 10.1 was missing a lot of essential RPMs, for example it includes XEmacs but not the critical XEmacs-packages and they split spamassassin into several modules but only included the main RPM; I wonder if perhaps something similar was done to the Chinese support, where the upgrade had deleted some RPM now broken into multiple packages, but only installed, or only shipped, the main package update.

We find Chinese input works in the terminal window, and of course all the menus and Gnome prompts are Chinese, and the fonts are all present and readable, but the fonts do not show in OOo or in XEmacs when input with xcin -- the locale SET vars seem fine too.

Also curious, OOo shows the chinese fonts in the selection list, but when you choose one and then enter a character, OOo displays a box (missing char) and the selector reverts to the default; in XEmacs, I can display the Big5 "Hello" demo and even cut and paste that string into another buffer, but entering any Chinese with xcin only produces strings of vertical bars and tilde symbols.

This is very frustrating -- this all worked fine under Mandrake 9.x and nothing has been changed except the upgrade; I've logged a trouble ticket at qa.mandrakesoft.com, but haven't had any reply yet -- it had been months since May had asked me to "switch it back to Windows"

My plan is to carefully work through the Seba Chinese HOWTO and see if something had become mis-set.

Last edited by teledyn; 11-03-2004 at 12:44 PM.
 
Old 11-03-2004, 11:29 PM   #12
Burna
LQ Newbie
 
Registered: Jul 2003
Location: Beijing - Berlin - Beijing
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
Take a look here and you may find help

http://gerrit-worldwide.de/chinesischlinux2_eng.html
 
Old 11-04-2004, 09:53 AM   #13
teledyn
LQ Newbie
 
Registered: Nov 2004
Location: Sauble Beach, Ontario, Canada
Distribution: Mandriva/Mandrake, RedHat, Debian, Ubuntu, Gentoo, Morphix, Knoppix, Peanut
Posts: 21

Rep: Reputation: 15
Burna, thank you for that link because it was right on the button for OpenOffice.org software:
Quote:
make sure you update to OpenOffice 1.1, as CJK support has finally been implemented decently. Now you still have top configure everything at tools->options->language For mixed documents, for language set German i.s.o. default (or standard).
Adjusting that advice for Big5, we now have xcin input to swriter.

Our only problem now is with XEmacs.
 
Old 11-04-2004, 10:10 AM   #14
teledyn
LQ Newbie
 
Registered: Nov 2004
Location: Sauble Beach, Ontario, Canada
Distribution: Mandriva/Mandrake, RedHat, Debian, Ubuntu, Gentoo, Morphix, Knoppix, Peanut
Posts: 21

Rep: Reputation: 15
OT: Mandrake Linux News (Google Ads)

BTW, and sorry for the off-topic post, but I hope everyone here notices those bogus Microsoft linux-bait ads such as the one that appeared a moment ago here in the banner on LinuxQuestions. They are always the same, this one claimed to be Mandrake Linux News (ha ha) but they can be titled as the 'news' for just about any distro of Linux or even opensource news -- they always follow with some bit of nonesense about how we are all wasting our money and damned for all time unless we let them save us, and then link to Microsoft Canada on a truly hilarious bit of non-sequiteur FUD mongering.

Anyway I just wanted to post a note to tell everyone that those spamming ads are worth big money to sites like LinuxQuestions; Microsoft has paid a huge premium to spam our sites with these lunatic rants, sometimes as much as $5/click, so it is in our own best interests to click every one of these that we find in the name of supporting free software. If you use Mozilla or Firefox, you can Mouse-2 click them into a new tab that you don't even need to read (but read it at least once because it is hilarious), and every time you click it (no more than once a session!) that's significant Microsoft money being spent to support great free software support websites like this one.

So make sure you click these things, and tell all your friends to do the same -- if they are going to spam our websites, they might as well pay for the privilege!
 
Old 11-25-2004, 11:30 AM   #15
kozaki
Member
 
Registered: Jun 2004
Location: France, UE
Distribution: Arch Linux, Bodhi, Debian, Mageia, OpenMediaVault, Q4OS
Posts: 133

Rep: Reputation: 20
Update

Update on a Mandrake 10.1 with KDE-3.3.1, Smart Common Input Method 0.99.9, scim-tables-0.4.3-1mdk, scim-chinese-0.4.2-2mdk & skim-1.0.0-1mdk

As pointed out by LaoNiu here, SCIM only works in ZH LOCALE.

Burna > I've tried to rename ~/.i18n and add
Quote:
export LC_CTYPE=zh_CN.UTF-8 kwrite
into /etc/profile but it doesn't work at all (same when i try to add export LC_TYPE into ~/.bashrc

I've also followed Internationalization in Mandrakelinux 10.1 : a mini guide to SCIM/UIM with no success so far.

When i installed skim (SCIM for KDE), i got a nice help document integrated with KDE, but i could neither make it works (despite that i tried for hours) :-/

Say; it won't work unless ~/.i18n shows LC_CTYPE="zh_CN" (or other CN locale)
So one has to login into another user with appropriate locale for scim/skim to show chinese input.


OK that works --fine-- but is quite uneasy way to do, at least for a newbie user
I think of my Chinese friends in France being stocked-glued to their virus infested Zindoze : i certainly won't convince them to shift to Linux as long as it is much easier for them to type chinese on a english/french/european localized Zindoze

Everyone who may have a clue to this Asian input method, please share it !


[EDITn] Config files :
  • ~/.i18n
    _chinese_user_
    Quote:
    LANGUAGE=zh_CN.GB2312:zh_CN:zh
    GTK_IM_MODULE=scim
    ...
    LC_CTYPE=zh_CN
    XIM_PROGRAM="scim -d"
    XMODIFIERS=@im=SCIM
    _french_user_
    none
  • ~/.scim/global
    _chinese_user_
    Quote:
    /DefaultConfigModule = gconf
    /DefaultIMEngineFactory/zh_CN = 05235cfc-43ce-490c-b1b1-c5a2185276ae
    /DefaultPanelProgram = scim-panel-gtk
    /DisabledIMEngineFactories = 856f06f6-8c57-49d3-8a96-7a5a34023624,...
    /SupportedUnicodeLocales = en_US.UTF-8,zh_CN.UTF-8,fr_FR.UTF-8
    _French_user_
    Same as chinese_user. I'll rip it off, since it doesn't work for this user unless i change the locale
  • /etc/scim/global
    Quote:
    /SupportedUnicodeLocales = en_US.UTF-8,zh_CN.UTF-8,fr_FR.UTF-8
    /DefaultPanelProgram = scim-panel-gtk
    /DefaultConfigModule = simple
    ...

Last edited by kozaki; 11-25-2004 at 11:47 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Chinese input denning Slackware 16 02-24-2005 12:39 AM
Chinese input Cyberian Fedora 2 02-15-2005 06:32 AM
chinese fonts and input problem nived Linux - Software 3 09-13-2004 07:44 AM
the chinese input problem vanbastern Linux - Newbie 3 04-04-2004 05:38 PM
RedHat 9.0 and Xcin Chinese input problem kooyue Red Hat 3 02-13-2004 01:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 06:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration