LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 09-18-2004, 03:47 AM   #1
ruse
LQ Newbie
 
Registered: Apr 2004
Location: australia
Distribution: Fedora 11
Posts: 14

Rep: Reputation: 0
CDROM mount? problem


Problem - Mount problem? attempting to use CDROM causes system freeze.
Distribution Mandrake 10.0

Bios information - Sony CDR/RW is master and only device on secondary ide

Harddrake information for hdc
Bus: ide
Drive Capacity: burner
Channel:secondary
New devfs device: /dev/ide/host0/bus1/target0/lun0/cd
Old device file: /dev/hdc
Media class: cdrom

/var/log/messages on boot
localhost kernel: hdc: Sony CD-RW CRX230E, ATAPI CD/DVD-ROM drive
localhost kernel: ide1 at 0X170-0X177, 0x3f6 on irq 15
localhost kernel: hdc:ATAPI 52X CD-ROM CD-R/RW CD-MRW drive, 2048kB Cache, UDMA(33)
localhost kernel: Uniform CD-ROM driver Revision: 3.20

fstab
none /mnt/cdrom supermount dev=/dev/hdc,fs=auto,ro,exec,--,user,sync,suid 0 0
mtab
none /mnt/cdrom supermount ro,noexec,nodev,sync,dev=/dev/hdc,fs=auto,-- 0 0

When trying to access data CD using desktop icon the system crashes after displaying this error message:

Warning Kwin
Window with title devices:/devhdcmntcdrom - Konqueror"is not responding.
Window belongs to application Konqueror PID2411 hostname localhost

If i try and mount /dev/cdrom as root the system also crashes.

The only thing which I know was odd about the instal was that to get the CD to load I had to specify "expert ide=nodma"at the splash screen.
 
Old 09-18-2004, 11:27 AM   #2
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Rep: Reputation: 30
Re: CDROM mount? problem

Quote:
Originally posted by ruse
fstab
none /mnt/cdrom supermount dev=/dev/hdc,fs=auto,ro,exec,--,user,sync,suid 0 0
Try changing the fstab entry for your CDRW so that it doesn't use supermount. I've had problems with it refusing to mount the install CD's automatically the first time I rebooted my pc after installing.
Code:
/dev/hdc /mnt/cdrom iso9660 ro,user,exec 0 0
You will need to mount the cd's manually in a terminal using "mount /dev/hdc" or "mount /mnt/cdrom" or if you use KDE, right click on your desktop and create a new CD-ROM device icon which will allow you to right click on the icon to mount/umount.
If things are still dodgy after that try adding "ide=nodma" to the kernel append lines in your bootloader.
 
Old 09-18-2004, 11:31 AM   #3
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
you can also disable/enable supermount via the command line, without having to edit fstab. in terminal as root do...........

supermount -i disable

or

supermount -i enable

otis
 
Old 09-20-2004, 05:10 PM   #4
ruse
LQ Newbie
 
Registered: Apr 2004
Location: australia
Distribution: Fedora 11
Posts: 14

Original Poster
Rep: Reputation: 0
Nafan / Otish

Disabling supermount, modifying the etc/fstab cdrom mount entries and appending ide=nodma to lilo.conf have done the trick.
Thanks for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NOOB needs help with cdrom mount problem moore757 Linux - Hardware 6 04-03-2005 12:30 PM
cdrom mount problem suguname Mandriva 4 01-28-2005 02:34 AM
CDROM Mount Problem grover77 Linux - Newbie 13 07-01-2004 01:35 PM
Mount CDROM problem KMcD Slackware 4 02-17-2004 08:03 PM
floppy/cdrom mount problem thar Linux - General 6 10-15-2003 07:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 01:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration