LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Can't format 120 gig sata HD to ext3 (https://www.linuxquestions.org/questions/mandriva-30/cant-format-120-gig-sata-hd-to-ext3-193321/)

jackstoage 06-14-2004 10:04 AM

Can't format 120 gig sata HD to ext3
 
I have been trying to format a sata 120 gig HD to ext3 using Mandrake 10 community partition manager. On every attempt the system seems to hang (takes too long). I bail out of configuration manager and get back in to find it formated to ext2. I tried to split the HD into 2 partitions and format each separately. That seems to work (system doesn't seem to hang) all seems successful but when I check the check back it says both are ext2. Does the drive being sata have anything to it?

Jack

d4d4n9 06-14-2004 10:56 PM

You can try with QTParted, download from this link : http://www.icewalkers.com/Linux/Soft.../QtParted.html
I have tried to partitioned 120GB hard disk into 6 ext3 partitions with QTParted without problem.
You should try it :)

indeterminate 06-15-2004 02:08 AM

Well, it has to format as ext2 before it can make it ext3, so it sounds like something is working, at least.

The sata might be the problem, there might be some motherboard chipsets out there that aren't fully supported yet, but I dunno.

You might try running "mke2fs -j <drive name, like /dev/hdc3 or whatever>" as root. If it hangs or takes a really long time, you might try it with -v as well, to see more info. Anyway, if it's failing to add the journal (which it sounds like it is), running that program from a console will hopefully give a more detailed error message in the output. It also might succeed where the gui failed.

I guess there's also a chance that it might actually be formatting the drive properly, but that it incorrectly shows it as ext2. I don't know how you could check that, just an idea.

anyway, hope that helps

jackstoage 06-15-2004 12:10 PM

After the post I did more internet research and tried mkfs.ext3 -c /dev/hd?. The process took a long time as it read checked the disk for bad blocks first. That took 15 -20 minutes. That done the subsequent format was fast and successful. I mounted it and checked the properties and did a df on it all of which indicated the correct size and file system. There was a lost and found file put there by the formatting process.

The only problem was when I went to Mandrake's partition manager to use that to mount it and write the mount to fstab it saw the disk as being still unpartitioned and unformatted.

Soooo, I formatted the whole 120 gig again as ext3 with a single partition. It was almost instantaneous that time and worked out fine. I mounted it and the partition manager offered and added the mount to the fstab. Great!

I can only figure that what was taking so long the first time and lead to my post was the check for bad blocks that having already been done on the second attempt was skipped.

I guess I should have been more patient.

Thanks for all your suggestions!

jack


All times are GMT -5. The time now is 06:56 PM.