-   Mandriva (
-   -   Can't compile anything (

simeandrews 01-13-2005 02:01 PM

Can't compile anything
Help me! I want to install GAIM, GIMP, and XMMS, but when I try to ./configure, here's the message I get.


[simon@localhost simon]$ cd /home/simon/gimp-2.2.1/
[simon@localhost gimp-2.2.1]$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
[simon@localhost gimp-2.2.1]$

So what am I missing and how do i get it, or what do I have to do?

Also, I downloaded a Unreal Tournament demo, and it is run.gz, so how do I run that file, that's a simpler question, if you can, please answer either one!!

gerrit_daniels 01-13-2005 02:18 PM

If you want to compile software, you need to install gcc. You can install it with the command "urpmi gcc". You can also install gaim, gimp and xmms in this way, so you don't really need to compile them.

reddazz 01-13-2005 02:23 PM

Urpmi is the best way to manage your packages on Mandrake. To find out more info on how to use it and setup external repositories, go to

simeandrews 01-13-2005 02:58 PM

I like compiling because it gives me something to do instead of studying for exams lol!

simeandrews 01-13-2005 03:22 PM

Gimp 2.2 isn't on urpmi.

So, when I tried to compile this time, heres what I got.


[simon@localhost gimp-2.2.1]$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for egrep... grep -E
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking how to run the C++ preprocessor... /lib/cpp
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.

Now what's wrong?

reddazz 01-13-2005 04:07 PM

Do you have gcc-cpp (or something close to that, can't remember the exact name) installed. If not install it and then try to redo your installation.

simeandrews 01-13-2005 04:43 PM

Yea, it's installed.

reddazz 01-13-2005 04:59 PM

Ok, it's gcc-c++ that you are supposed to have.

simeandrews 01-13-2005 05:14 PM

Im getting sooo close, but theres yet another error. Here it is.

checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
[root@localhost gimp-2.2.1]#

Never mind, fixed that by myself (im so proud!)

Once again, new error, somebody hates me lol!


checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.4.5... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: Test for GLIB failed. See the file 'INSTALL' for help.
[root@localhost gimp-2.2.1]# urpmi glib
Everything already installed
[root@localhost gimp-2.2.1]#

chuck232 01-13-2005 05:30 PM

If you just urpmi to install glib again, it'll find glib already installed and won't install I think. You may have to actually find that version of it and manually rpm it and use --force. I'm quite the linux newbie myself, but that's how I upgraded to Python2.4 from 2.3...

simeandrews 01-13-2005 06:07 PM

Ok, I downloaded glib, but sadly, Ive used Linux for three months of my life and have never come accross a tar.bz2 file. How do I open it, and what do I do from there?

reddazz 01-13-2005 06:28 PM

tar -xjvf file.tar.bz2
change into the directory you extracted and then do
$./configure --prefix=/usr
#make install

I am sure Mandrake puts the glib in /usr, just cross check by doing
$whereis glib
a pathname will be printed onscreen.

Just be careful with glib coz any errors can make your system unstable.

simeandrews 01-13-2005 06:33 PM

Because now would be a horrid time to make my system unstable, I'm going to leave this for now.

What does glib do anyway?

chuck232 01-13-2005 06:41 PM

Oh the wonders of google... ;)

reddazz 01-13-2005 06:53 PM

I didn't mean to scare you off installing it. Just make sure you can revert to your old packages if something goes wrong (e.g. by having the rpms handy). I've just upgraded glib and gtk on my Fedora Core 3 system and what I had to do was,

1) upgrade pango to version 1.8 (Not necessary if it's up to date)
2) upgrade glib to 2.6.1
3) upgrade gtk+ to verison 2.6.1

Everything works fine on my system, but if not installed properly some gtk stuff can be broken.

All times are GMT -5. The time now is 03:52 AM.