LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Can't change the computer name from dhcp-181-18 and can't start ftp because it (https://www.linuxquestions.org/questions/mandriva-30/cant-change-the-computer-name-from-dhcp-181-18-and-cant-start-ftp-because-it-158151/)

rocketman3245 03-15-2004 07:32 PM

Can't change the computer name from dhcp-181-18 and can't start ftp because it
 
I'm pretty new to linux. I set up proftpd but when I try to start it is says can't find address. If I hook up my old broken router and restart my computer name will change to localhost and ftp will start and it will stay running after I unplug the router and go directly to the modem. I tried to change my computer from getting the address from dhtp server but that doesn't work. This is the thing given me the most trouble every other program works good. btw os is mandrake 9.2

colnago 03-16-2004 03:11 AM

I am not sure exactly what you want, but to just change your hostname...

hostname yourcomputername

works. You can set up all your networking by hand to use a static ip if you add this:

HOSTNAME=yourcomputername
NETWORKING=yes
GATEWAY=192.168.0.1

in /etc/sysconfig/network (substitute your gateway IP and host name) and then in ./network-scripts/ifcfg-eth0, you will want:

DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.0.100
NETMASK=255.255.255.0
NETWORK=192.168.0.0
BROADCAST=192.168.0.255
ONBOOT=yes

Where you will have to cange for your specific IPs. Then make sure your /etc/resolv.conf has a valid nameserver entry in it and that your /etc/hosts file has an entry for your computer. For example, if you computer was named linuxquestions, then you want a line like this in hosts:

127.0.0.1 localhost linuxquestions

You can also put it in front of your IP if you know it...

127.0.0.1 localhost
192.168.0.100 linuxquestions

rocketman3245 03-21-2004 02:47 PM

I have a dynamtic ip address. If I change the hostname with: hostname localhost it changes my hostname so I could start proftpd and stays started ubtill i reboot. Once I restart I have to go and change hostname again and then start proftpd.

This is the error message I get it I try to start proftpd without changing my host name

Failed to start FTP server : Starting proftpd: - getaddrinfo 'dhcp-181-18' error: Name or service not known - error: unable to determine IP address of 'dhcp-181-18' - error: no valid servers configured - Fatal: error processing configuration file '/etc/proftpd.conf' [FAILED]

Is there a way to fix this so every time i restart i have to change my hostname then start proftpd. I even tried mandrake 10.0 on another partition and get the same error and have to do the same to get it to work.

freakmn 04-01-2004 03:57 PM

I just had the same problem, and I found that you need to add the new server name and ip to /etc/hosts.


All times are GMT -5. The time now is 11:05 AM.