LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Can't boot anymore "L 9A 9A 9A" (https://www.linuxquestions.org/questions/mandriva-30/cant-boot-anymore-l-9a-9a-9a-214262/)

nadim khemir 08-06-2004 10:02 AM

Can't boot anymore "L 9A 9A 9A"
 
So I was gently working on a perl module when a gaming fever got me. I could get CS to install on one of my windows box so I thought I'd reboot my linux box (I have a dual booot) to try to install it there. Fatal mistake!

Some details:
A rather moder P4 box with Mandrake10.0 and WinXP.
Never had much problems before.
Thought I had installled GRUB!

The problem:
I can't boot no more.

What I've done so far:
Search the net for hours.
Tryed the rescue mode, reinstalled the boot loader in 10 different ways
mounted the drives, chrooted, ran lilo -v -C /etc/lilo.conf
Tried again and again in different ways.

I simple words, I'm stuck. I first can't understand how this can happend! Second I don't know how to fix it.

Someone knowladgable please help or point at something I can read and do.

Cheers, Nadim.

rossAINTfakin 08-06-2004 11:54 AM

somethoing similar happened to me when i removed my linux drive, and just tried to boot my windows drive, i have it installed on two sepearte hdd's, it was fixed when i reconnected the linux drive. i dont think you removed a drive, but my general attitude, when in doubt with linux, and to get it to a working state, reinstall...

nadim khemir 08-06-2004 12:00 PM

Quote:

Originally posted by rossAINTfakin
my general attitude, when in doubt with linux, and to get it to a working state, reinstall...
That might work if you have 3 hours to waist for reinstalling the system but I also need another 2 or three days more to reinstall all I need. I've installed the system a week ago. That makes for a very bad Installation-time/usage ratio.

Cheers, Nadim.

rossAINTfakin 08-06-2004 12:49 PM

true, i do hope this gets fixed for you, best of luck.

arvind_sv 08-06-2004 07:50 PM

Did you actually search at Google for "L 9A lilo"? I doubt it. Because, the first link would have interested you.

Also, NEVER reinstall a Linux system. It's not needed, except in the worst circumstances. Try using grub. You're using lilo.

If that does not work, post your lilo.conf here, alongwith your /etc/fstab.

Arvind

nadim khemir 08-07-2004 02:46 AM

I did that search but the first link didn't make me more inteligent! My situation differs in those point:

I haven't modified anything! I didn't try to add a splashscreen or whatever.

I have installed Mandrake in a very "standard" fashion and I am pretty sure Grub was installed. I usualy get a flashy graphical boot screen. I took me a while to find out it was lilo. This is one of the most bothering parts. How could I go from Grub (if it 's what I had before) to a lilo error? I'm pretty sure the mandrake installation says "installing Grub". Obviously I"m wrong and the data in the lilo.conf seem pretty much those right. This is making me crazy!

I agree with you, re-installing a system that I can obviously boot, mount partitions and access data would be a waist of time specially after taking in to account all the time spend installing other stuff by hand.

Here is a listing of the files you named:

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

boot=/dev/hda5
map=/boot/map
default="linux-smp"
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda5
initrd=/boot/initrd.img
append="devfs=mount acpi=ht resume=/dev/hda6 splash=silent"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda5
initrd=/boot/initrd.img
append="devfs=mount acpi=ht resume=/dev/hda6"
read-only
image=/boot/vmlinuz-2.6.3-7mdk
label="263-7"
root=/dev/hda5
initrd=/boot/initrd-2.6.3-7mdk.img
append="devfs=mount acpi=ht resume=/dev/hda6 splash=silent"
read-only
image=/boot/vmlinuz-smp
label="linux-smp"
root=/dev/hda5
initrd=/boot/initrd-smp.img
append="devfs=mount acpi=ht resume=/dev/hda6 splash=silent"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda5
initrd=/boot/initrd.img
append="failsafe acpi=ht resume=/dev/hda6 devfs=nomount"
read-only
other=/dev/hda1
label="windows"
table=/dev/hda
other=/dev/fd0
label="floppy"
unsafe


/dev/hda5 / ext3 defaults 1 1
/dev/hda3 /data vfat users,owner,umask=0,rw 0 0
/dev/hda4 /data2 vfat users,owner,umask=0,rw 0 0
none /dev/pts devpts mode=0620 0 0
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/windows ntfs umask=0,nls=iso8859-1 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0

jomen 08-07-2004 03:39 AM

from you first post: if you've ever done "lilo -v" - and it ran - then you have lilo indeed - not grub.

The /etc/lilo.conf looks o.k. - except for the fact, that the first entry says:

boot=/dev/hda5

that would need to be changed to read:

boot=/dev/hda

so lilo gets installed to the mbr of this disk and not to the beginning of /dev/hda5 - where it is now and probably is not found by the looks of it...

How did you do the chroot to reinstall lilo - any errors or warnings?
Was the /dev/hda5 mounted r/w so you could really write to it?

I'd do:

chroot /mnt/mountpoint_of_dev_/hda5

/usr/bin/env -i HOME=/root PATH=/bin:/usr/bin:/sbin:/usr/sbin
--> to chean the environment and set a path

bash --login
--> to read the environment from _your_ system

lilo -v

exit --> log out of bash

exit --> get out of chroot

reboot

nadim khemir 08-07-2004 04:04 AM

Hi, I really appreciate your help.

I got "L 9A ...." before I ever run 'lilo -v'; so the Grub/lilo question still stands.

I booted in "rescue" mode and choose the option to mount my partitions. The contents I used to have in '/' are now under 'mnt'. I have /mnt/etc, /mnt/dev ..... I did 'chroot mnt'.

I'll run the commands you proposed and come back with the results ASAP.

Cheers, Nadim.

jomen 08-07-2004 04:19 AM

just to clarify...

I was trying to say about you using lilo or grub:

if you have issued the command: "lilo -v" - and it actually did something - then you have installed lilo _somewhere_ - you have the program and it wrote something to your disk when you where running it - but maybe not the right thing, since you cannot boot...

...english is not my native language - but I try to make it my friend...:D

nadim khemir 08-07-2004 04:21 AM

It worked like a charm. Thanks a lot. I can now boot in linux and mandrake.

Still. How can this happend? That the installation says grub and I get lilo sucks but not a problem. But how can the boot loader stop loading. I _really_ didn't change a thing. I was programming on my build system.

I have two other small problems with this new installation (I'll start new theads). I doubt it is related but one never knows.


Cheers, Nadim.

jomen 08-07-2004 04:39 AM

I KNEW it ! :D ...good !

It _might_ just be that you installed grub to boot and it pointed to lilo, which was installed on /dev/hda5 - this would be really weird, but - who knows?

sorcerer01 08-07-2004 04:32 PM

Mod Edit: Advertising Removed

jomen 08-07-2004 04:51 PM

Hey sorcerer01!

...besides the fact that it's already solved - the link to your site does not work...

XavierP 09-04-2004 04:46 AM

The forum rules do not permit advertising. Please visit http://www.linuxquestions.org/advertising/ for more information on advertising. Feel free to contact the forum admin if you have any questions about this policy.


All times are GMT -5. The time now is 03:55 PM.