LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 11-07-2004, 11:39 AM   #16
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0

i feel pretty phstupid
ive been at this linux for 3 days now


anyway it didnt help

I tried to open a folder called BenQ
this is what poped up:

Couldn't display "/mnt/misc/BenQ".
the attempt to login failed
 
Old 11-07-2004, 12:14 PM   #17
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Hmm, login? Sorry, but from my perspective it should work. Maybe one last guess: try without 'gid=users' and with 'users'.

The option 'users' allows a normal user to mount and unmount a partition. 'gid=users' sets the group which has access to the partition. BTW: what is the group of your user? Maybe the standard group is named differently in Mandrake. Then change it to gid=<yourgroup>.

Sorry for that trial and error playing, I am sitting on a Windows machine and cannot look up the parameters.

@the others out there:

Can't someone give idagon a sample fstab-line from Mandrake? One that is working with fat32.
 
Old 11-07-2004, 06:12 PM   #18
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
In Linux Mandrake, the default group for a user is the same as the username. So by default other users cannot read your files. If you are the only user of the computer, you can use the options uid=idagon,gid=idagon.
If there is more than one user, make up a group name and use that one. Make users members of the group to control access. If this is the only such drive where you need to control access this way, Mandrake has a group setup for this called fileshare. Make users a member of the fileshare group and change the option to gid=fileshare.

The 'diskdrake' program should be able to do all of this for you. It will also include the correct language encoding option and save the changes to fstab if you tell it to when you finish. Before finishing, try to mount it with the program to make sure the options and fs type are correct.

Good Luck!

ps. I just stepped outside for a smoke before posting the message.
The Northern Lights are going to be spectacular tonight!

Last edited by jschiwal; 11-07-2004 at 06:17 PM.
 
Old 11-07-2004, 07:33 PM   #19
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
im the only user on mandrake.

what i found out was, when i mount the drive in diskdrake i have access to the files and the icons are correct.

as soon as i reboot, the drive unmounts itself

i am the only user but i am not sure where to enter the uid= or the gid=

Last edited by idagon; 11-07-2004 at 08:49 PM.
 
Old 11-08-2004, 07:53 AM   #20
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
any idea why the drive unmounts itself after reboot?
 
Old 11-08-2004, 07:59 AM   #21
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Quote:
i am the only user but i am not sure where to enter the uid= or the gid=
Are you seriously asking this question again? So I answer a third, but last time: in /etc/fstab the line that you are changing all the time!

jschiwal:
Lucky you! Whenever I had time to look for northern light (or whenever I remembered to do so), it was cloudy or only very low probability. BTW: The place you live, is it the Fargo from Coen brothers Fargo? Wow! I thought that was fiction...

EDIT: drives are always unmounted during reboot, but if they have a correct entry in /etc/fstab, they get mountet again. If you want it to get mounted automatically, you need to add the option 'auto' to the /etc/fstab line. Before you ask: the line where all the other options for this partition are. No spaces in the options section, just commas!

Last edited by abisko00; 11-08-2004 at 08:04 AM.
 
Old 11-08-2004, 08:27 AM   #22
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
i would have quit asking dumb questions if i were able to fix it.

call me stupid but ive been at linux for 4 days maybe 12 hours

the other drives in the system do not have the auto command and they get recognized at boot
the only thing in their lines different than the disappearing mount drive is the 'ro' command

/dev/sdb1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/sdb6 /home ext3 defaults 1 2
/dev/hda /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
/dev/hdc /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/sdc1 /mnt/misc vfat umask=0,user,nls=iso8859-1,gid=users,exec 0 0
/dev/sda1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0
/dev/sda5 /mnt/win_d ntfs umask=0,nls=iso8859-1,ro 0 0
none /proc proc defaults 0 0
/dev/sdb5 swap swap defaults 0 0
 
Old 11-08-2004, 08:37 AM   #23
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
The uid= option goes towards the end of the entry with the comma seperated options. You can use a uid number or the username.

It could be that the drive isn't beiing mounted at boot time. Make sure that you are not using the 'noauto' option. Try the 'auto' option instead. But first, try to mount it manually after changing the /etc/fstab line. Just enter the mount point for the partition after the mount command. This way you can test that the fstab entry is correct, otherwise you won't be able to boot up.

---
By the way, the movie is fiction but the city Fargo is real! One time I was walking home from work at night. The Northern Lights were all over the place. I looked straight up and one formed right above my head as I watched. Sometimes they will even appear toward the south. One night the moon was almost blotted out.

I've also seen some very interesting meteorites. One night, there was one that broke up over a house in West Fargo. It broke up at a lower altitude then where I was.

Last edited by jschiwal; 11-08-2004 at 08:38 AM.
 
Old 11-08-2004, 08:38 AM   #24
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
so i took out the exec command and put in the missing ro command and now it stayed mounted

thanks for the help, really

without you guys out there, people like me would be lost... at least as far as linux is concerned
 
Old 11-08-2004, 08:58 AM   #25
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Some options are default values, so if you don't need to specify them. Have a look in 'man mount'. The ro (read only) option is used for ntfs drives, since there is no real write access for it.

Maybe you should delete the entry for /dev/sdc1 from fstab totally and use this 'diskdrake' to create it from scratch. I don't know this tool, so I can't give any recommendations...

EDIT: just saw your last post: congratulations!
 
Old 11-08-2004, 09:05 AM   #26
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
well i jumped the gun

that was a logout when it stayed mounted

when i cold booted it unmounted , even with the auto command entered

will try your last post when i get home from work
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
new harddrive for data, linux and fat?? itsjustme Linux - Hardware 1 04-22-2005 08:04 PM
Resizing a fat 32 drive... RoaCh Of DisCor Linux - Software 1 12-09-2004 11:04 AM
fat drive permissions problem llimllib Linux - General 2 07-18-2003 07:51 PM
Data loss on a FAT partition. What caused it? correro Linux - General 3 03-10-2003 08:42 PM
recovering a fat 32 hard drive kingswood76 Linux - General 13 07-26-2002 08:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 02:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration