LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 11-06-2004, 11:41 AM   #1
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Rep: Reputation: 0
cannot see any data on fat 32 drive


Hello all,

Im new to linux and mandrake, so please bear with my ignorance.

i have a dual boot system with xp on one drive and mandrake community on another drive by itself.

there is a 3rd drive that is a fat 32 drive.

everything was fine until i unmounted and remounted the fat 32 drive and now i cant see any data on it. reads the size properly, and i can access it in xp fine.

when i open the folder it is empty (file:/mnt/misc)

ive also moved the boot point from c2 to misc
but i could not see any data before i moved the boot point

thanks in advance

Dan
 
Old 11-06-2004, 12:03 PM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
So how do you mount? Do you have an entry for the drive in /etc/fstab or do you mount as root manually? In the first case, please post the /etc/fstab, in the second case the mount command. From your description I would assume that the drive isn't mounted at all. You can check that if you type 'mount -l' on a console. If your drive doesn't appear there, it is not mounted.
 
Old 11-06-2004, 02:45 PM   #3
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
thanks for replying,


i dont think it is mounted, here is the terminal report

[d@localhost d]$ mount -l
/dev/sdb1 on / type ext3 (rw) []
none on /proc type proc (rw)
none on /proc/bus/usb type usbfs (rw)
none on /sys type sysfs (rw)
/dev/sdb6 on /home type ext3 (rw) []
none on /mnt/floppy type supermount (rw,sync,dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,codepage=850)
/dev/sda1 on /mnt/win_c type ntfs (ro,umask=0,nls=iso8859-1)
/dev/sda5 on /mnt/win_d type ntfs (ro,umask=0,nls=iso8859-1)
capifs on /dev/capi type capifs (rw,mode=0666)
[d@localhost d]$

in control center, when i try to mount the drive it says mount failed
i will login as root and try again

Last edited by idagon; 11-06-2004 at 02:58 PM.
 
Old 11-06-2004, 02:50 PM   #4
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
it says mount failed using root login
im trying to mount using control center--mount -points--partitions
 
Old 11-06-2004, 02:54 PM   #5
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
sorry, her is the ftab listing

/dev/sdb1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/sdb6 /home ext3 defaults 1 2
/dev/hda /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
/dev/hdc /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/sdc1 /mnt/misc ntfs umask=0,nls=iso8859-1,ro 0 0
/dev/sda1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0
/dev/sda5 /mnt/win_d ntfs umask=0,nls=iso8859-1,ro 0 0
none /proc proc defaults 0 0
/dev/sdb5 swap swap defaults 0 0
 
Old 11-06-2004, 02:54 PM   #6
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
/etc/fstab is a file, not a directory. I don't know mandrake, but it should be there.

I would suggest to login as root and check on which device the drive is located (type 'fdisk -l'), but I would guess it's sdc1. Then try to mount manually with 'mount -t vfat /dev/<the-device> /mnt/misc'.
 
Old 11-06-2004, 02:59 PM   #7
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Didn't get your last post in time:

If you are sure that the drive is fat32 and not ntfs, try to change the entry for /dev/sdc1 to the following (need to be root):

Code:
/dev/sdc1 /mnt/misc vfat umask=0,gid=users,nls=iso8859-1 0 0
Be sure that every entry is in one line only!
 
Old 11-06-2004, 03:05 PM   #8
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
thanks

i tried this


[root@localhost d]# mount -t vfat /dev/sdc1/mnt/misc
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .
 
Old 11-06-2004, 03:10 PM   #9
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
where/how do i enter this?

/dev/sdc1 /mnt/misc vfat umask=0,gid=users,nls=iso8859-1 0 0

i saw in system configuration it was listed as an ntfs, although in xp it is a fat32
 
Old 11-06-2004, 03:15 PM   #10
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Quote:
where/how do i enter this?

/dev/sdc1 /mnt/misc vfat umask=0,gid=users,nls=iso8859-1 0 0
In /etc/fstab (open a console, become root by typing 'su' followed by the password, use your favourite editor, eg. 'pico /etc/fstab' and change the line that starts with "/dev/sdc1").

Quote:
i tried this


[root@localhost d]# mount -t vfat /dev/sdc1/mnt/misc
There is a space missing between sdc1 and /mnt
 
Old 11-06-2004, 03:40 PM   #11
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Thats done it!

thanks

I had to change permissions using permdrake to group access (had root only after mounting)
 
Old 11-07-2004, 10:49 AM   #12
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
this is weird!

the drive has unmounted itself
could not read files on it
i remounted. and now all directories and files have the same icon, and when i right click on a known doc file, (to open it with a reader)the options grey out and i cant open directories ----- basically unusable .but it does show the correct size and free space

here is the fstab

/dev/sdb1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/sdb6 /home ext3 defaults 1 2
/dev/hda /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
/dev/hdc /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/sdc1 /mnt/misc vfat umask=0,gid=users,nls=iso8859-1 0 0
/dev/sda1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0
/dev/sda5 /mnt/win_d ntfs umask=0,nls=iso8859-1,ro 0 0
none /proc proc defaults 0 0
/dev/sdb5 swap swap defaults 0 0



here is the fdisk-l

[root@localhost d]# fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3917 31463271 7 HPFS/NTFS
/dev/sda2 3918 19457 124825050 5 Extended
/dev/sda5 3918 19457 124825018+ 7 HPFS/NTFS

Disk /dev/sdb: 37.0 GB, 37019566080 bytes
255 heads, 63 sectors/track, 4500 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 764 6136798+ 83 Linux
/dev/sdb2 765 4500 30009420 5 Extended
/dev/sdb5 765 827 506016 82 Linux swap
/dev/sdb6 828 4500 29503341 83 Linux

Disk /dev/sdc: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 9964 80035798+ c W95 FAT32 (LBA)


any ideas?
 
Old 11-07-2004, 11:04 AM   #13
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Try to append the option 'exec' to the /etc/fstab line. This allows to execute of programs from that location. Maybe that helps...
 
Old 11-07-2004, 11:11 AM   #14
idagon
LQ Newbie
 
Registered: Nov 2004
Posts: 19

Original Poster
Rep: Reputation: 0
how/where do i append exec?
 
Old 11-07-2004, 11:21 AM   #15
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Come on, have a little phantasy!

In /etc/fstab

/dev/sdc1 /mnt/misc vfat umask=0,gid=users,nls=iso8859-1,exec 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
new harddrive for data, linux and fat?? itsjustme Linux - Hardware 1 04-22-2005 08:04 PM
Resizing a fat 32 drive... RoaCh Of DisCor Linux - Software 1 12-09-2004 11:04 AM
fat drive permissions problem llimllib Linux - General 2 07-18-2003 07:51 PM
Data loss on a FAT partition. What caused it? correro Linux - General 3 03-10-2003 08:42 PM
recovering a fat 32 hard drive kingswood76 Linux - General 13 07-26-2002 08:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 12:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration