LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 12-20-2004, 07:08 PM   #1
cawwt
LQ Newbie
 
Registered: Mar 2004
Posts: 18

Rep: Reputation: 0
Unhappy Cannot run Firefox on MDK10.1 Official


When I try to install firefox(1.0) by running the installtion script, the output is as the following:

mmy@localhost firefox-installer]$ ./firefox-installer
SCIM: im_module_init
free(): invalid pointer 0x81d8f30!
free(): invalid pointer 0x81d8f08!
./firefox-installer: line 56: 5236 Segmentation fault ./${BINNAME}-bin $@

I almost have a complete installation, everything is installed except mail/router servers and the extra windows managers other than KDE and Gnome. Please advise what I can do with this. thanks
 
Old 12-20-2004, 08:08 PM   #2
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Rep: Reputation: 30
try su-ing to root and then installing it.
 
Old 12-20-2004, 10:47 PM   #3
cawwt
LQ Newbie
 
Registered: Mar 2004
Posts: 18

Original Poster
Rep: Reputation: 0
run it as root doesn't help at all. As a matter of fact, there are problems with the installation as the no installer version of firefox does not work either.

I did another installation, same problem. I was using firefox in Slackware on this same computer, so I know some how this is Mandrake's fault.

I am thinking my installation CDs might be bad, but I don't know how to verify them. Can someone please tell me? thanks
 
Old 12-20-2004, 11:09 PM   #4
reynacho_au
Member
 
Registered: Nov 2004
Distribution: Mandrake 10.1
Posts: 43

Rep: Reputation: 15
if you downloaded the iso's just verify the md5sums. They are listed on linuxiso.org as what they should be. Then just run md5sum Mandrake.iso and it'll tell you what they are.
 
Old 12-20-2004, 11:11 PM   #5
reynacho_au
Member
 
Registered: Nov 2004
Distribution: Mandrake 10.1
Posts: 43

Rep: Reputation: 15
also, I would try re-downloading firefox. Don't use a nightly build if that's what you are using. It says there's a segmentation fault at line 56 of the installer so the downloaded file could have been corrupted or damanged.
 
Old 12-20-2004, 11:23 PM   #6
cawwt
LQ Newbie
 
Registered: Mar 2004
Posts: 18

Original Poster
Rep: Reputation: 0
thanks for the replies.

to be honest, I downloaded and tried at least 10 different copies of various builds of firefox. None of them work. They all fail for the same reason.

SCIM: im_module_init
free(): invalid pointer 0x8b1ecf0!
free(): invalid pointer 0x8b1ecc8!


sometimes the firefox qualify agent comes out.
 
Old 12-21-2004, 07:31 AM   #7
rider343
LQ Newbie
 
Registered: Dec 2004
Posts: 4

Rep: Reputation: 0
Use URPMI

First go to http://www.thebrix.org.uk/ and http://urpmi.borgnet.us/ add sources and run

urpmi mozilla-firefox

 
Old 12-21-2004, 07:54 AM   #8
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi there

u need to run this before installing forefox
first clean all ur previous installations then
run these commands

> scim -f x11 -c simple -ns socket -d
> export LC_CTYPE=en_US.UTF-8
> export XMODIFIERS=@im=SCIM
> export GTK_IM_MODULE=xim

then, launch firefox-installer

and thjen when u reboot again then u need to run this from shell

export GTK_IM_MODULE=xim

each time u need to start firefox
and u can start firefox from shell only
i got forefox working this way!!
for more info

http://www.linuxformat.co.uk/modules...0062&forum=1&9

regards
 
Old 12-21-2004, 09:18 AM   #9
cawwt
LQ Newbie
 
Registered: Mar 2004
Posts: 18

Original Poster
Rep: Reputation: 0
I appreciate everyone's help.

Now my firefox works too. And here is what I did. I downloaded and installed the firefox rpm, but still doesn't work. But it WORKS after I installed every singal bug fixing updates.

again, thanks very much for the help
 
Old 12-21-2004, 09:43 AM   #10
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
Quote:
Originally posted by cawwt
I appreciate everyone's help.

Now my firefox works too. And here is what I did. I downloaded and installed the firefox rpm, but still doesn't work. But it WORKS after I installed every singal bug fixing updates.

again, thanks very much for the help
hey which bug updates did u install???

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to compile X11R6.8.1 on mdk10.1 official quatsch Mandriva 3 12-12-2004 09:08 PM
Serious Problem with MDK10 Official and java dabump Mandriva 10 10-08-2004 04:38 AM
What the difference between MDK10 Official and MDK10??? unixfreak Mandriva 1 08-18-2004 03:35 PM
ATI Drivers in MDK10 Official Borka Mandriva 3 07-19-2004 02:39 PM
Geforce 4 and MDK10 official Warmaster Mandriva 18 05-24-2004 04:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 01:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration