LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   cannot read init (https://www.linuxquestions.org/questions/mandriva-30/cannot-read-init-288963/)

sumesh 02-11-2005 10:35 AM

Init not found
 
Hi all,
I had a dual boot with Windows XP and Mandrake 9.0. I sucessfully resized my XP partition to give me some extra space. But this seems to have affected my linux partitions.
It would not boot and fails with the following message:
pivotroot: pivotroot/sysroot/sysroot/initrd failed
init not found. try init =

I have tried to recue using a Mandrake resue disk. Did a fdisk -l, lsparts to see if my partition table is available. Thereon I fixed my lilo.cof, installed lilo again by running /sbin/lilo. Fixed my fstab. Tried giving init=3 in lilo.conf. I also verified if I have a /initrd directory and initrd images in /boot.


Can somebody suggest what else might be wrong ? If
I would really appreciate it, I dont want to reinstall my linux

thanks
Sumesh


sgrayban 02-11-2005 12:08 PM

Opps seems your beloved dual boot XP has borked your disk and over-wrote something.

A reason why dual-booting sucks.


All times are GMT -5. The time now is 04:43 AM.