-   Mandriva (
-   -   Cannot get Firefox 1.5 to recognize JRE 1.5 plugin (

Cara25 05-28-2006 03:26 AM

Cannot get Firefox 1.5 to recognize JRE 1.5 plugin
I'm using Mandriva 2006

I have Firefox 1.5 up and running and installed in,

I have JRE 1.5 installed at,

I have installed at,

Firefox has Java and JavaScript enabled at the Edit/Preferences/Content window

I still get a "message bar" at that plugins are missing, when I check which plugin is missing, Firefox tells me that the Java Run Time plugin is missing.

What have I done wrong ?

dexter11 05-28-2006 04:18 AM

Try linking it to your /home/yourname/.mozilla/plugins directory. The path is not accurate but there is a plugin directory in your /home/.../.mozilla dir.

fingal 05-28-2006 06:19 AM


I used to have this problem as well, but solved it a few months ago. It really is a case of creating symbolic links from your plugins directory to your JRE directory. Because it's a while since I did this I don't remember the precise paths involved but you would need to use the ln command:

ln -s <path to Java runtime environment>

I think there are some hints on the Firefox site to get you going. This is one of those things that can be sorted out once you 'get the picture' rather than an irritating long term problem.

evodawg 06-06-2006 10:33 PM

Java should have created a directory in /usr

My file for java

Link the / to your home directory


and your


then go and test* is the plugin you want to link to all mozilla and FireFox plugin directories.

evodawg 06-06-2006 11:04 PM

the official Java Download and Help site for Linux

polemon 10-08-2006 04:04 AM

If you installed the JRE-1_5_0_xx package, you night have two's, like in my case.

I'm running FC5 and I was desperately trying to find the plugin-module, since i didn't know where the RPManager had put it.
Once I found it, I found actually two of them:


I'd suggest linking them, one at a time, and testing which one's working best.


All times are GMT -5. The time now is 06:49 AM.