LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Cannot connect to ISP (https://www.linuxquestions.org/questions/mandriva-30/cannot-connect-to-isp-198950/)

une 06-28-2004 11:45 PM

Cannot connect to ISP
 
I just installed Mandrake 10 and followed the setup process to establish a new connection with my ISP without success. The setup program showed that the system detected the modem on the port correctly and the setup process seemed to work (I double checked all the details regarding dialup number, username and password). However dialling commences but the connection will not establish.
There were some options during the setup sequence that I did not understand and just went with the default choice.
One thing I did notice when setting up the new connection was that at one point the GUI prompted me to choose my ISP from a list. As my country (Australia) and therefore my ISP (Telstra) was not listed I tried to progress past this question without making a selection. For some reason the setup program would not allow a "non choice" here and always chose an ISP in Austria (first in the list by the looks of it) for me and then went to the next step in the setup process. Don't know if this is relevant to the problem.
I have a dual hard drive system and my Windows OS uses the same port and modem without a problem.
Any ideas?

jblpogger 06-29-2004 04:18 AM

It is probably because you set your country as autria... so when it dials it is trying to call austria to make a connection xD

MunterMan 06-29-2004 05:46 AM

Your location is unimportant. You dial into your isp and connect to the internet via them.
In MCC there is a network and internet option. There is a wizard that will go through the setting up of your modem. These settings will be the same as your windows connection. ie. account name, password, dns (isp) name.

Word of warning. What type of modem do you have?
Linux will detect a winmodem, but wont be able to use it (not without a great deal of pain and suffering).

une 06-29-2004 05:35 PM

I have an external modem that is Linux compatible (it worked fine on a Redhat system I used to have set up - Mitsubishi Diamond SE).
Also the setup wizard will not let me pass throught the "Select conutry and ISP" page without making a selection, even if I ensure no selection is highlighted and try to move on the wizard chooses the 1st in the list for me automatically before it moves to the next step in the wizard.

MunterMan 06-29-2004 06:20 PM

There is no select country and isp page in the wizard.
Check the 'normal modem connection' box.
It then asks you for connections name, phone number, login id, password, authentication, domain name, DNS server (optional).
Then it asks if you want to test your connection.


Have you got your timezone set for the computer?

une 06-29-2004 08:43 PM

I must be going through a different setup wizard as the "Choose country and ISP" page always appears. I am using the create new connection wizard. Yes, I set the timezone during the install process to my local zone.

MunterMan 06-30-2004 06:17 AM

That's me beat. I haven't got 10 yet and it sounds like they are doing things differently.
I have never been able to connect via mcc, I thought it was just me.

Use kppp. If it isn't in the menu under 'networking->remote access' install it using the software manager.

Type kppp at a console prompt. (kppp is a gui front end for ppp).
Go into setup and fill in the relevent fields. It looks complicated but is straight forward.

hints: check the dynamic ip address, dont fill in the dns bit, dont edit the login script, the defaults for the device should be ok.

Any problems, post here.

une 07-01-2004 02:54 AM

Thanks, I'll give it a go and post result.

une 07-03-2004 03:19 AM

I gave up and just reinstalled the whole OS. Then the create new connection wizard worked fine. I find this typical of PCs in general, when in doubt reinstall. What actually went wrong will always remain a mystery and the effort requred to pinpoint the problem is not worth it, supposing that to do so is even possible. Anyway thatś my pointless bleat into the void. I feel a little better now!

MunterMan 07-03-2004 05:33 AM

Said like a true windoze user. Reinstalling the os every time the numlock light came on was something I got used to.

However, apart from upgrades, I have NEVER reinstalled linux. I find that if you shout at it long enough, it will start to work.

And it is always possible to pinpoint the problem, it may not be worth the effort of trawling through 170MB of source code but it is possible.

mjc43 07-11-2004 05:50 PM

Mandrake 10 dialup problems
 
Thank god (or somebody) that someone else is or was having the EXACT same problems as me. To the letter!
Have reinstalled Mandrake numerous times and have been connected but not all the time. I use the kppp tools? interface? but I also get the ppp timeout and am disconnected before I can do anything. I can try and star up Konquer or whatever but that does not work. Anyway I hope that simple re-install does the trick for you but so far has not helped me in the slightest. I did import my outlook exp. email files to Mandrake which has been my problem according to some others and will give it a try sometime today. Thanks all mjc43.

MunterMan 07-13-2004 07:11 PM

mjc43. The timeout can be set in the kppp->configuration->device->modem timeout box. This usually defaults to 60 seconds. Set it to 600, if nothing happens in those 10 minutes you have a different problem

une 07-17-2004 12:55 AM

Try forgetting the wizard and manually configuring kppp. Other weird stuff has also happened to my system, I had to switch from using gnome to KDE desktop as clicking on gnome menu bar items continually did nothing, the links were dead it seems?

mjc43 07-19-2004 12:11 AM

I am in! (again0 yippee!
 
All I did was to re-install the system again, about the 39th time I think. Only just then and went straight to my mailbox to see if I received any replies, and thank you all for your efforts. This time I did not enter my IE mail defaults that I had imported before and also went back and used the kppp setup as I had changed to gnome. But it all seems good now and will be awaiting a few more lonins before I am convinced entirely. I do hope all of this keeps going as I am a bit keen to get on with some ideas of my own and this seems to be the way. This system is not as closed up as some others. Anyway thanks again all, Mike, mjc43


All times are GMT -5. The time now is 07:26 AM.