-   Mandriva (
-   -   Can anyone help me to fix my mbr? (

Thug21 04-24-2004 01:32 PM

Can anyone help me to fix my mbr?
Hi I have a question regarding my mbr/partition table I have a dual boot between Mandrake 9.2 and Windows XP home edition everything was working fine I installed both lilo and grub as my boot loaders and everything was good but a month passed and I started to get errors when I restarted my computer lets say I was in Windows and I wanted to restart the computer to go on linux but when it restarted it showed me a black screen with 0 and 1 all over it, it only happens when I restart the computer but when I shut it down and power it back on it works fine it shows me my boot loader. Also my Windows is on my Master HD and linux on my slave HD the mbr is installed on my slave because that's were linux is (if I'm not wrong) I wanted to install the new Mandrake 10 but when it was on the installation procedure it didn't pick up my slave HD were I have mandrake 9.2 and I wanted to upgrade that one it only shows my Master HD where Windows XP is. I wanted to restore the Windows' default mbr I went into the restore console but my dumb brother doesn't remember the administrator password so I'm stocked there I tried to restore the default Windows' mbr using Mandrake's 9.2 installation cd but it showed me an error when I wanted to do so I think that I have a bad mbr or partition table and that's why I'm getting those errors this is where my question pops up how should I fix it? I want to have the possibility of installing mandrake where the old version is and also solve that problem when I restart my computer, any help will be appreciated.

fancypiper 04-24-2004 02:09 PM

Sounds as if lilo is misconfigured.

Look in one of the first 2 links on how to boot Mandrake rescue with either the install CD, floppy or boot floppy.

# Mandrake links
Mandrake home page
Mandrake Users website
Easy urpmi config for Mandrake
urpmi mini-HOWTO
All You Ever Wanted to Know About Urpmi But Never Dared Asking Before
Maximum RPM
You didn't install the developmental packages? As root, command:
urpmi gcc
An Introduction to the Midnight Commander. You can install it by commanding:
urpmi mc
Midnight Commander home page

Then perhaps this will help.
# ARRGH! I hosed my box
LILO fails: Error messages and their interpretation
Multiboot with LILO HOWTO
LILO, Linux Crash Rescue HOW-TO
Installing a bootloader
Multiboot with GRUB Mini-HOWTO
Linux+Win9x+Grub HOWTO
Linux Bootable Business Card
Windows 2000 Recovery Console
Windows XP Recovery Console

Thug21 04-24-2004 02:35 PM

Can you be more specific? I already read those tutorials but I don't find anything related to my problem it just says how to install/uninstall lilo but I think that you have a point maybe is my lilo that is not working fine but how should I fix it like it was before? I just want to get rid of those annoying 0 and 1, also I want to be able to detect the other hard drive so I can make a clean install of the new mandrake 10 on that existing partition where I have mandrake 9.2 (on my other hard drive) thank you for your answer.
by the way I tried grub alsd and the same thing happens

fancypiper 04-24-2004 03:08 PM

Can you boot into rescue mode and examine /etc/lilo.conf?

You stated you read this? Was it of no help?
LILO fails: Error messages and their interpretation

Thug21 04-25-2004 01:41 PM

Yes sure I just did it and here is what i have:


        append="devfs=mount splash=silent splash=silent hdc=ide-scsi acpi=ht resume=/dev/hdb2 splash=silent"
        append="devfs=mount splash=silent splash=silent hdc=ide-scsi acpi=ht resume=/dev/hdb2"
        append="devfs=mount splash=silent hdc=ide-scsi acpi=ht resume=/dev/hdb2"
        append="failsafe devfs=nomount splash=silent splash=silent hdc=ide-scsi acpi=ht resume=/dev/hdb2"

Can you explain me what I have to modify from this code or what's wrong with it? I appreciate your help

fancypiper 04-25-2004 04:39 PM

I haven't used lilo since 1999, so I can't really tell.

Since a cold boot is ok, I doubt that lilo is misconfigured unless you did something to mess it up.

If it cold boots OK but messes up on reboot (or more programs crash as you run longer), I would suspect overheating and it wouldn't hurt to check bad ram.

Memtest86 - A Stand-alone Memory Diagnostic

Thug21 04-25-2004 06:14 PM

Is there any way to clean up my mbr and my partition table so i can format my linux partition so lilo will get removed and I can install the new Mandrake 10 and configure lilo like it was before? because I think that my problem is with my mbr that is messed up maybe doing that my Mandrake 10 cd installation will pick up my other hard drive where I have mandrake 9.2 so I can install Mandrake 10 in that partition

fancypiper 04-25-2004 06:43 PM

Do you know how to use the recovery console?

# OK, I tried Linux, I think it sucks and I don't like it. I want to go back to Microsoft Windows
# Microsoft's instructions: How do I uninstall Linux completely and keep/use Microsoft Windows only?
How to Remove Linux and Install Microsoft Windows 2000
How to Remove Linux and Install Microsoft Windows XP
You can remove lilo from the mbr with
/sbin/lilo -u
You can remove grub or lilo from the mbr by booting with a Microsoft Windows 98 boot floppy (at the prompt, type fdisk /mbr), or by using the Windows XP Recovery Console or the Windows 2000 Recovery Console

# Basic Microsoft Windows security (can be out of date as I don't really keep up)
Firewall: ZoneAlarm Virus protection: AntiVir
Multi spyware removal utility: Lavasoft

# Microsoft Windows help sites
Windows BBS
Microsoft's Computer Management

fancypiper 04-25-2004 06:46 PM

I would only install one bootloader as well. Reading over your first post, that caught my eye. I don't know if that is causing the problem or not. I still suspect heat or memory if it works with a cold boot.

d4d4n9 04-25-2004 09:06 PM

IMHO, shouldn't you put lilo at mbr of the primary master harddisk ?
HTH ;)

Thug21 04-26-2004 12:39 AM

It doesn't matter were you put it actually I have no idea where it is my guess is that it is in the slave hard drive because thats were Mandrake is installed but thats just my guess.
I recovered the Windows' boot loader now using the cd recovery console from Mandrake 9.2 now my computer boots directly to Windows at startup but now I have another problem when i went on Windows my slave hard drive was gone it's not being shown on Windows I tried to browse it with partition magic but is like if it disappeared I only have my master hard drive, I opened my case to see if my hard drive was still plugged and it is so I don't know what happened any ideas?

d4d4n9 04-26-2004 01:34 AM

You lost your slave harddisk because you booted into Windows OS, meanwhile Windows OS can not read Linux file system ( ext2, ext3, etc ). You can boot from linux CD and choose "Rescue" and try to make bootable floppy disk that contain bootloader. When you succeed to load the linux system, then you go to MCC to install bootloader into primary master harddisk MBR ( Sorry, I could not be more specific because in my office, I still use windoze OS. I'm sure that you can figure it out ;)

Thug21 04-26-2004 02:28 AM

I finally got my other hard drive back thank you guys, sorry to bother you again with another question but I don't want to be without Mandrake so here it is the first time that I installed mandrake on my computer it worked but I formatted that hard drive where Mandrake was and I didn't uninstall lilo so when I restarted my computer I had no boot loader and I couldn't get to any OS, to solve this I had to install Mandrake back again here is where my question comes I switched from lilo to the default windows' loader as I said in my past post I want to format my slave hard drive will this affect my boot loader the one that I have now the default from windows? I got windows on my master hard drive and linux on my slave hard drive i want to format my slave hard drive because when I want to install Mandrake 10 it doesn't show me my slave hard drive it only shows me my master hard drive (this is when selecting the hard drive where you want to install Mandrake) also as I said I don't have my administrator password for Windows' xp recovery console if something goes wrong can I use a windows 98 boot disk to fix my mbr as a remainder I have windows xp not 98 that's why i'm asking. Thank you

d4d4n9 04-26-2004 03:17 AM

I'm not sure whether WinXP can format your second ( primary slave ) hard disk with linux system on it. You just try it. If it failed, look and download a program named "Delpart.exe" and use it to delete linux partition. Warning: Be sure what partition that you choose to delete ! You can do a clean install and put lilo or grub boot-loader ( either one ) into primary master hard disk MBR and not into primary slave hard disk MBR even though your linux system resides in it.
Hope this help.

bfbf504 05-01-2004 06:10 PM

I'm having kinda the same problem. I started with a freshly formated PC and installed Windows 2000 Pro (FAT32) and after that installed Linux 7.2 as a dule boot. This has been my 1st experience with Linux. I set up the partitions during the inital format. My PC is 30GB and I think I set the Linux partitions at about 5GB with some swap space.

I think it was LILO that was the boot loader as it would display a redhat logo when booting up and ask to select a OS, Windows 2000 or Linux.

Well I've been running out of space on my Windows PC and wanted to uninstall Linux, install it on a different machine (and use VMWare), and change Linux partition back to Fat32 to be used by Windows.

Someone advised that I use Partition Magic. So I used it and merged the 2 Linux partitions and then converted them to Fat32. Everything seemed fine, but when I booted up the next day I get the "LI" displayed on the screen. I can get in the BIOS set up, but after that I get the "LI" and that's it.

In hind sight this might not have been the best wat to "uninstall" Linux.

I had a feeling my problem had something to do with the Boot Loader and the GREAT info posted by Fancypiper above confirmed that for me.

But I don't know what to do to resolve my problem

I DONT have the Windows 2000 CD.
I do have the Redhat 7.2 CDs and I have a Knoppix CD.

The things I read above seem to indicate I need to run FDISK in DOS which I'm guessing would fix my problem. But I can't get to DOS. HELP

All times are GMT -5. The time now is 03:59 PM.