LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 10-19-2004, 06:04 AM   #1
mythief
LQ Newbie
 
Registered: Oct 2004
Posts: 25

Rep: Reputation: 15
Unhappy Can't find X includes (Mandrake 10.1)


when i try install kopete 0.9 i wrote console ./configure and then i got this error massage

checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!

i look at the these paths /usr/include/X11 --> /usr/X11R6/include/X11/ and i couldnt find any think like a header files or libraries so i think i have XFree86-devel but i cant find for Mandrake 10.1 ... i look at my CD's i couldnt find anythingor on ftp's.
so where can i find this file or what must i do ? pls help me ?
 
Old 10-19-2004, 06:29 AM   #2
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
see my answer in This Thread, post #2.

otis
 
Old 10-19-2004, 11:29 AM   #3
mythief
LQ Newbie
 
Registered: Oct 2004
Posts: 25

Original Poster
Rep: Reputation: 15
thanks but i think you are wrong

XFree86-devel-4.3-5mdk.i586.rpm or XOrg-devel-4.3-5mdk.i586.rpm are for mandrake 9.x but i m using mandrake 10.1 when i tried to install XFree86-devel-4.3-5mdk.i586.rpm i got error massage XFree86-devel-4.3-5mdk.i586 (XFree86-libs[== 4.3-5mdk] it is needed) so i downloaded XFree86-libs-4.3-5mdk.i586.rpm and then i tried to rpm but this time i got this error massage
install was failed.
file /usr/X11R6/lib/libGL.so.1.2 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libICE.so.6.3 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libOSMesa.so.4.0 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libSM.so.6.0 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libX11.so.6.2 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXTrap.so.6.4 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXaw.so.6.1 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXaw.so.7.0 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXcursor.so.1 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXext.so.6.4 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXfont.so.1 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXft.so.1.1 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXft.so.2 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXi.so.6.0 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXmu.so.6.2 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXmuu.so.1.0 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXp.so.6.2 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXrandr.so.2.0 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXrender.so.1 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXt.so.6.0 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libXtst.so.6.1 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libdps.so.1.0 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libdpstk.so.1.0 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk
file /usr/X11R6/lib/libpsres.so.1.0 from install of XFree86-libs-4.3-5mdk conflicts with file from package libxorg-x11-6.7.0-2mdk

i think i have already libxorg-x11-6.7.0-2mdk and i must find XFree86-devel-package in accord with this libxorg file isnt it ?
 
Old 10-19-2004, 04:43 PM   #4
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Yup...

Mandrake 10.0 uses XFree

Mandrake 10.1 uses Xorg

These two are different enough that it's screwing up your attempt to install your program from a TAR file.

You shouldn't be doing this anyway.

Rather you should utilize the repositories

See: http://www.zebulon.org.uk

and then

urpmi kopete
 
Old 10-19-2004, 05:16 PM   #5
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
mythief..........

as was stated, MDK10.1 uses Xorg by default. you'd need the libxorg-x11-devel-<version number> package, not XFree86-devel. in terminal as root type xorg. see what it lists. if it says "everything already installed....." then i'd have to agree & say try getting an rpm of kopete. actually, that is probably the easiest way, though i don't agree that nothing can be successfully compiled on Mandrake (no offense, opjose). i have compiled many apps successfully. but, that's besides the point.........

if when you do urpmi xorg & it lists the -devel package as available, install it, then try the compile again.

otis
 
Old 10-19-2004, 06:16 PM   #6
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Never said you couldn't compile things.

Rather you shouldn't if the package is available in Mandrakified form from the repositories.

Not only does this make things easier but trying to fix dependencies becomes trivial, without accidentally trashing something important in your system.
 
Old 10-20-2004, 12:17 PM   #7
mythief
LQ Newbie
 
Registered: Oct 2004
Posts: 25

Original Poster
Rep: Reputation: 15
Unhappy (devel(libfreetype) ?

thank you very much ... but i have another problem now. when i tried to install libxorg-x11-devel-6.7.0-2mdk.i586 ... i got this error massage

Some package requested cannot be installed:
libxorg-x11-devel-6.7.0-2mdk.i586 (devel(libfreetype) is missing )
are you agree ?

where can i find devel libfreetype for MDK 10.1 ?
 
Old 10-21-2004, 02:52 AM   #8
mythief
LQ Newbie
 
Registered: Oct 2004
Posts: 25

Original Poster
Rep: Reputation: 15
Question pls help me

i cant find right file for libfreetype devel ....
 
Old 10-21-2004, 03:14 AM   #9
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Have you tried

urpmi freetype
 
Old 10-21-2004, 03:59 AM   #10
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
you need the package libfreetype6-devel-<version number>mdk. so, in terminal as root do urpmi libfreetype.

a word of caution........... get the -devel package only. certain freetype packages can play havoc with your fonts. make sure you get the libfreetype-devel only............

otis
 
Old 10-23-2004, 05:23 AM   #11
mythief
LQ Newbie
 
Registered: Oct 2004
Posts: 25

Original Poster
Rep: Reputation: 15
Thumbs up thanks

i solved my proplems thank you very much ... everybody who use MDK must check this site http://www.zebulon.org.uk/
 
Old 10-25-2004, 07:14 PM   #12
maximusIII
LQ Newbie
 
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
Hey I got the same problem too when I tried to compile Kopete. How did you resolve it? I visited the website but it was not much help. I just installed Mandrake 10.1 and A NEWBIE. Please help me out.

Thanks
 
Old 10-26-2004, 08:39 AM   #13
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
If you follow the above link and do what it says, then all you have to do is type in

urpmi kopete

and everything is taken care of for you.

Start by following the link and setting up URPMI as indicated.

This should be mandatory reading!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't find x includes nicdee Linux - Newbie 2 07-31-2005 05:24 PM
cant find x includes sandman545 Linux - Newbie 5 05-09-2005 03:44 PM
Can't find X includes linmix Linux - Software 2 06-19-2004 01:48 PM
Can't find X Includes Zb7 Linux - Newbie 3 12-13-2003 07:44 PM
Can't find X includes? Avatar Linux - Newbie 17 12-09-2003 01:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 11:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration