LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   aureal soundcard drivers mdk9.1 (https://www.linuxquestions.org/questions/mandriva-30/aureal-soundcard-drivers-mdk9-1-a-92139/)

Peacedog 09-12-2003 05:59 PM

aureal soundcard drivers mdk9.1
 
i'm a newb ran mdk 8.1 and luvd it. decided to upgrade to 9.1 ...bad very bad. Fortunaly didn't have much to lose so i did a clean install of 9.1 and all is well but, when I modprobe for the sound card driver I get error (this module compiled w/ gcc2 kernel compiled with gcc3 this is known not to work) the card is a vortex 1 aureal au8820 chip. everything worked fine in 8.1. is the answer to downgrade? can anyone help?thx

Peacedog 09-13-2003 10:08 AM

burned the midnight oil. got it worked out. vortex 1 card working fine on mdk9.1. all sound devices working.

Peacedog 10-04-2003 07:00 PM

sorry folks, i posted a bit too soon. i had been learning linux in the gnome interface. i had the presence of mind to check that sound was working in kde, however, my check was inconclusive. i today felt i was pretty comfortable with gnome so i thought i'd try out kde. to my dismay i have no system sounds. my previous check was to log into kde and see if xmms would play audio. ithought that to be pretty safe. as my experience is you have sound or you don't. turns out that arts has a real problem w/ my card and or driver. no system sound will play (e.g startup sound, login new user..etc.) but only in kde. as of this post i have thoroughly checked gnome and all is well w/ all devices, file types, and users. kde will play sound from xmms. (i haven't checked any of the other players). but no sys sounds. i have searched the forum and others are having this problem. i have downloaded and installed the latest version of the driver. had to download it from another post that i found in my forum search...(which is not posted on sourceforge...i thought that strange) i am looking for any answers as i would like to explore my options w/ inux and decide which interface (if any) i like best. does anyone know if this issue is dead or still being adddressed? if so could you please inform me. thx.

Peacedog 10-05-2003 06:27 PM

i have done a little resaerch and the alsa site seems to have support for my card. could the answer be to download and install the latest alsa package? i am only concerned because if you read my last post the new mod that i installed was downloaded not from the sourceforge project but from a link on another post i found here. any ideas, suggestions..?

estatik 10-06-2003 07:06 PM

Hey Peacedog,

I too have an Aureal Vortex Chip (onboard au8810) and have been searching and scouring the internet for months, looking for any solutions to get the sound working on this spare box. I use KDE specificly and I can say verify that you are right...with KDE, arts is disabled. And if I try to activate it, I will get errors (can't remem them right at the moment). Although, xmms, xine, mplayer, kcsd, grip, realplayer and all other sounds will play fine in KDE(with the exception of system sounds :rolleyes: ), any package that depends on arts (noatun), will not.

I dunno about you, but not having system sounds, doesn't bother me, since I usually always have my music on; I usually deactivate it anyways :rolleyes:. but, that's interesting that gnome will have no issues with system sounds...even though I'm an avid KDE user, I might give gnome a whirl.

Which package did you d/l and from where?

From researching numerous sources, I've concluded that the cvs version is the one to use. Here's what I have done to install the drivers...

1) Installed kernel-source(doh! ;)), gcc-3, glibc-develop, libncurses5-devel, cvc, openssh, openssh-clients

2) # cvs -d: pserver:anonymous@cvs.sourceforge.net:/cvsroot/aureal login (no space between the "-d:" and "pserv....")

3) [enter]

4) # cvs -z3 -d: pserver:anonymous@cvs.sourceforge.net:/cvs/aureal co aureal (no space between the "-d:" and "pserv....")

5) cd /where_you_downloaded_cvs_files/aureal

6) ...aureal] # vi Makefile

7) edit all occurances of "/sbin/lspci" to "/usr/bin/lspci"

8) open emacs and edit "gcc2_compiled" to "gcc3_compiled" for files: asp10.o, asp20.o, asp30.o

9) # make install-all

10) reboot

Seems like this is the easiest way I've found to install the drivers...YMMV

estatik

Peacedog 10-07-2003 05:33 PM

hi estatik, the driver i downloaded was from a link on a thread here.

http://jayasolutions.cjb.net/

it is ver. 1.1.3.1 where it came from i have been unable to find out. it works pretty good though as i stated above. all i did to install was unpack and

make au8820 install-all

everything went fine w/ the exception of the arts thing. not having system sound is not a big deal,but, i just love to tweak things. i'll be looking for a fix till i find it. when and if i do i'll post it here in this thread. so check back.

estatik 10-11-2003 03:06 AM

Hey Peacedog,

Quote:

make au8820 install-all
From reading various posts regarding the aureal driver, (and since the one you downloaded was fron openvortex, so I'm not too sure if it applys) but shouldn't you have installed the driver with # make au8820 install20? I know from using the sourceforge cvs driver, I installed it with # make install-all and only the au8810 drivers were installed. Was it the same with your driver?

I am still interested if you can get arts to work in KDE or get alsa drivers working with the aureal. I, too, will try to find a solution to this arts/aureal issue and post any progress.

estatik

Peacedog 10-12-2003 04:04 PM

hi estatik that command

Quote:

make au8820 install20
worked w/a previous driver. the current driver was installed using the commands as stated in my last post. i took them off of the readme file. i believe the # make au8820 handles the driver that is installed since au8810 or au8830 is not made then the only driver that can be installed is the au8820. i too am still looking into the arts problem and will post any victories. hopefully one of us or somone else will find a solution. good luck.

Peacedog 10-13-2003 07:09 PM

i actually had system sound in kde this morning at starup then recieved an error that arts had crashed. i had no time to write down the error had to go to work. that is progress though. i have been unable to recreate the error so that i can post it. will continue to try and recreate the error and the sound!!!! so that i can post it.

phanly 11-11-2003 07:38 PM

See:
http://alsa.opensrc.org/index.php?page=au88x0
and the links from there about getting alsa-***-0.9.8 working with an aureal card.
cheers
Paul


All times are GMT -5. The time now is 11:07 AM.