LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 08-31-2005, 02:25 PM   #1
sam.pedraglio
Member
 
Registered: Jul 2005
Distribution: Mint 14 64bit
Posts: 71

Rep: Reputation: 16
Another problem configuring the wireless


Using the MCC I configured my wireless card Intel/pro 2200 bg. The installation system recognized it. I set the right operating mode, the ESSID and the autentication key. At the end of the procedure I could reach the wireless router and my firewall.

Here my problem: when I reboot the system the kernel recognizes the card, starts it up but I need to run a script to send the authentication key, using the iwconfig option:

Code:
iwconfig eth3 key s:xxxxx
Do I need to config the card in other way?
 
Old 08-31-2005, 06:40 PM   #2
chiefreborn
Member
 
Registered: Jun 2005
Location: Ohio
Distribution: OpenSuSE, WHAX, Auditor, Fedora Core, Ubuntu, Knoppix, FIRE, SLAX
Posts: 61

Rep: Reputation: 15
Do you already have that command running on boot? You might need to configure some more things. If you have an ifcfg-wlan0 file in /etc/sysconfig/network (this might only be on SuSE, not quite sure how it works in Mandriva...) then you should be good to go, and just fill out any missing areas. Copy your iwconfg and ifconfig output in here so I can see if anything is missing. Of course cover up/remove the wireless key from the posting. I know how you feel, I have been trying forever to get wireless working in linux (Fedora, SuSE, Knoppix, WHAX, you name it) and I just got it working a couple days ago.

chiefreborn
 
Old 09-01-2005, 02:58 AM   #3
sam.pedraglio
Member
 
Registered: Jul 2005
Distribution: Mint 14 64bit
Posts: 71

Original Poster
Rep: Reputation: 16
At the moment I haven't the possibility to check what you're asking for, I need to wait this evening at home but I'd tell you other info:
-if I set the card to work with DHCP, during the boot I'd see the system is waiting for an IP address, then it exit with an error because it canno't reach the DHCP server until I run the script into the X-server.

-if I set a static IP, like at the moment, the boot sequence go on without error messages, when I enter the X-serverr I can see the "started network" icon on the task bar but I'm not able to ping the firewall until the script.


For the other request see you this evening (Italian evening)
 
Old 09-01-2005, 05:08 AM   #4
chiefreborn
Member
 
Registered: Jun 2005
Location: Ohio
Distribution: OpenSuSE, WHAX, Auditor, Fedora Core, Ubuntu, Knoppix, FIRE, SLAX
Posts: 61

Rep: Reputation: 15
Okay. Whenever you give me the other info I'll try to help you out some more.
 
Old 09-01-2005, 04:20 PM   #5
sam.pedraglio
Member
 
Registered: Jul 2005
Distribution: Mint 14 64bit
Posts: 71

Original Poster
Rep: Reputation: 16
Here I'm with the requested informations.
The ifcfg-wlan0 in Mandriva is called ifcfg-ethx (where x is the card number) and it's located in /etc/sysconfig/network-scripts (just fyi) and, here, you'll find the content of my one:

DEVICE=eth3
BOOTPROTO=static
IPADDR=192.168.0.15
NETMASK=255.255.255.0
NETWORK=192.168.0.0
BROADCAST=192.168.0.255
ONBOOT=yes
HWADDR=00:0e:35:9f:3a:fc
METRIC=10
MII_NOT_SUPPORTED=yes
USERCTL=yes
WIRELESS_MODE=Master
WIRELESS_ESSID=WiFiCasa
WIRELESS_ENC_KEY=xxxxxxxxxxxx


here the iwconfig, cleaned by the no-wireless-cards informations:

eth3 IEEE 802.11g ESSID:"WiFiCasa" Nickname:"Notebook"
Mode:Managed Frequency:2.462 GHz Access Point: 00:01:E3:04:F7:2A
Bit Rate=54 Mb/s Tx-Power=20 dBm
RTS thr: off Fragment thr: off
Encryption key:6275-6C67-6172-6F67-7261-7373-6F Security mode: open
Power Management: off
Link Quality=73/100 Signal level=-55 dBm Noise level=-87 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


and finally the ifconfig:

eth0 Link encap:Ethernet HWaddr 00:40: D0:69:3E:E0
inet addr:10.0.20.241 Bcast:10.0.20.255 Mask:255.255.255.0
inet6 addr: fe80::240:d0ff:fe69:3ee0/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:3062 (2.9 Kb)
Interrupt:10 Base address:0xeb00

eth1 Link encap:UNSPEC HWaddr 00-40-D0-01-00-28-AC-2A-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth3 Link encap:Ethernet HWaddr 00:0E:35:9F:3A:FC
inet addr:192.168.0.15 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20e:35ff:fe9f:3afc/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:718 errors:0 dropped:0 overruns:0 frame:0
TX packets:692 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 txqueuelen:1000
RX bytes:297020 (290.0 Kb) TX bytes:92689 (90.5 Kb)
Interrupt:10 Base address:0x2000 Memory:d0001000-d0001fff

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:21 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1816 (1.7 Kb) TX bytes:1816 (1.7 Kb)

sit0 Link encap:IPv6-in-IPv4
inet6 addr: ::192.168.0.15/96 Scope:Compat
inet6 addr: ::10.0.20.241/96 Scope:Compat
inet6 addr: ::127.0.0.1/96 Scope:Unknown
UP RUNNING NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)




I hope you'd find what you're searching for.
I needed to isert some spaces somewhere into the code because the string ": o" (for example from the string ": off") introduces a smile.

Thanks for your help.
 
Old 09-02-2005, 09:56 PM   #6
chiefreborn
Member
 
Registered: Jun 2005
Location: Ohio
Distribution: OpenSuSE, WHAX, Auditor, Fedora Core, Ubuntu, Knoppix, FIRE, SLAX
Posts: 61

Rep: Reputation: 15
So you statically set your IP and routing information? Here's an example of my ifcfg-wlan0 file:

BOOTPROTO='dhcp'
MTU=''
NAME='Ethernet Network Card'
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='yes'
WIRELESS_AP=''
WIRELESS_AUTH_MODE='open'
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL='6'
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID='CodifNet'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0='insert your key here'
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'
WIRELESS_WPA_PSK=''
_nm_name='static-0'

You might want to replace 'static' with 'dhcp' so that it automatically sets your routing settings and IP info. If this is not possible, try adding your default access point/router IP with the 'route add default gw [insert IP address here]'. Try pinging 'google.com'. If that doesn't work, try a 'dhcpcd' (if it exists in Mandriva) and try pinging google again. And if all THAT doesn't work, let me know. BTW, your wireless key is in your post in case you haven't noticed.
 
Old 09-02-2005, 10:00 PM   #7
crAckZ
Member
 
Registered: Sep 2004
Location: LOUISVILLE KENTUCKY
Distribution: mandriva 2006
Posts: 155

Rep: Reputation: 30
did you set your modem to bridge intead of pppoe?
 
Old 09-03-2005, 01:18 AM   #8
sam.pedraglio
Member
 
Registered: Jul 2005
Distribution: Mint 14 64bit
Posts: 71

Original Poster
Rep: Reputation: 16
@chiefreborn: I forgot to clean my key, you're right. I chose to use static IP because the system wasn't able to find a free IP due to the lack of activationduring the boot (my main problem).In this way I have an address which is useable immediatly after the key encyiption.

@crAckZ: I didn't configure the modem, maybe it's something standard in Mandriva.
 
Old 09-03-2005, 10:48 AM   #9
chiefreborn
Member
 
Registered: Jun 2005
Location: Ohio
Distribution: OpenSuSE, WHAX, Auditor, Fedora Core, Ubuntu, Knoppix, FIRE, SLAX
Posts: 61

Rep: Reputation: 15
Well, does your card work once you run the script? If it does, find the equivalent of the 'rc.local' file in the /etc/init.d directory. If you just need to execute a shell script on command, edit the rc.local file and put the line:

./shell_script_name.sh

Or whatever command you use to execute the script.
 
Old 09-06-2005, 02:31 AM   #10
sam.pedraglio
Member
 
Registered: Jul 2005
Distribution: Mint 14 64bit
Posts: 71

Original Poster
Rep: Reputation: 16
Finally I found the time to do what you've suggested and it works! Thanks a lot.

This is a good way to solve the problem but I still have a question: which is the reason why the official configuring tool (MCC) doesn't configure the card in the right way?

In your opinion, is this a bug to be send to the Mandriva devel team?
 
Old 09-08-2005, 05:20 PM   #11
chiefreborn
Member
 
Registered: Jun 2005
Location: Ohio
Distribution: OpenSuSE, WHAX, Auditor, Fedora Core, Ubuntu, Knoppix, FIRE, SLAX
Posts: 61

Rep: Reputation: 15
Yes. If it is a problem with Mandriva, send it in. This is what worked for me in SuSE so it's definitely a problem with Mandriva.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Wireless abelloda Linux - Laptop and Netbook 2 11-11-2005 07:17 AM
Configuring Wireless mtecknology Linux - Software 0 07-29-2005 10:21 AM
Problem configuring wireless card in laptop smruti Linux - Laptop and Netbook 1 11-16-2004 08:50 AM
Configuring Wireless hybrid0006 Linux - Newbie 13 08-02-2004 09:49 PM
Problem Configuring Linksys WPC11 ver 3.0 wireless card laughner Linux - Wireless Networking 5 07-12-2004 07:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 07:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration