-   Mandriva (
-   -   ALPS touchpad, no tapping in 10.2 (

thunderweasel 08-23-2005 06:20 AM

ALPS touchpad, no tapping in 10.2
So I just upgraded from Mandrake 10.1 to 10.2 (Mandriva 2005 LE), and my ALPS touchpad, which was working perfectly fine in 10.1, no longer works with double tapping (well, that's not entirely correct. It works if I slowly, carefully tap 2 times in perfect sequence, but I can no longer quickly tap twice on the touchpad to open things anymore). I tried using generic P/S2 mouse drivers and the synaptics touchpad driver, and neither work correctly. I was reading and searching a bit, and this problem seems to be fairly common, but solutions do not. Apparently this can be fixed with a kernel patch that I have no idea how to apply (I'm new to this whole linux thing). I tried adjusting values in my xorg.conf file, and none of them work, problem's always the same. So if somebody could show me a solution, and put it in moron terms that I can actually understand, I'd appreciate it greatly.


Isn't the purpose of an *upgrade* to fix bugs from previous versions? This problem seems to have cropped up in the 2.6.11 kernel. Back when I was using 10.1 with the 2.6.8, everything was fine. I'd like to congratulate the kernel designers on a wonderful revision.

simcox1 09-04-2005 05:24 AM

Is it not possible to adjust it in system configuration, like you can change the speed for double clicking of the mouse? I dont know. Is there a way to configure the touchpad?

thunderweasel 09-04-2005 05:38 AM

Nope, that wouldn't work. I already got it figured out a while ago though. The problem turned out to be with the Synaptics driver. I passed the line "psmouse.proto=imps" to the kernel by adding it to my grub.conf file, and that solved it entirely (now the touchpad simply emulates an ordinary PS/2 mouse like it used to in previous kernel versions).

All times are GMT -5. The time now is 01:33 AM.