LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 07-23-2004, 04:30 PM   #61
Lennart
Member
 
Registered: Mar 2002
Posts: 40

Rep: Reputation: 15

Thanks Thort, the steps you went through look perfectly alright to me and are the same as the ones I used. Nowadadays though my router is doing the logging in so i can't go back and check. However, there's one thing that was always troubling me and that might also be a problem in your case. Whenever I was switching from Windows to Linux, eth0 wouldn't connect. I then first had to unplug the computer and modem and telephone plug, wait for some twenty minutes, plug in the phone connection and router first, wait for the adsl connection to be established and only then start the computer. Only then I would get eth0 running and a working internet connection.
I guess you did try connecting by using MCC->network & internet & "monitor connections"?
 
Old 07-23-2004, 04:59 PM   #62
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Quote:
Originally posted by Bebo
OK, try doing the exact same thing but set it to an ADSL connection instead of a LAN connection. I have no idea of why it would be any differently doing it like that, but anyway...
MCC - ADSL Configuration - Step 1

MCC - ADSL Configuration - Step 2

MCC - ADSL Configuration - Step 3

MCC - ADSL Configuration - Step 4

MCC - ADSL Configuration - Step 5

MCC - ADSL Configuration - Step 6

MCC - ADSL Configuration - Step 7

MCC - ADSL Configuration - Step 8

Logged out of KDE, and in again. But still no connection.

I assume Mandrake would have bring up the et0 network at once after configuration where finished. Or, at least after logging out and in to KDE.
Quote:
Originally posted by Bebo
Also, do an lsmod (as root if it doesn't work as an ordinary user) and see if the driver for your network card is listed....
It turned up ismod is no valid parameter in the Terminal. I tried as root also.
Quote:
Originally posted by Bebo
...and see if the driver for your network card is listed. Was it fealnx?
Yes, that's right.



Thanks for your suggestions. May I ask you for more ideas?
 
Old 07-23-2004, 05:11 PM   #63
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Thanks for your reply Lennart !
Quote:
Originally posted by Lennart
Nowadays though my router is doing the logging in so i can't go back and check.
I have my username and password stored in my adsl modem/router. As the modem act as a router, it handle the contact itself against the provider "Tele 2". The contact between the modem and the computer is a lan connection. The modem assign an ip address for the connection at every start-up.

So, as I understand, you and me have exactly the same kind of connection today. I'm quiet sure "Tele 2" provides the same kind of adsl for the whole of Sweden.

Therefore, if you check your settings today, they would show me how I shall configure my system.

Last edited by thort; 07-23-2004 at 05:12 PM.
 
Old 07-23-2004, 05:36 PM   #64
Lennart
Member
 
Registered: Mar 2002
Posts: 40

Rep: Reputation: 15
Sorry, I don't have the same ISP, but that doesn't matter. After I had the correct configuration for my router I set up the adsl connection as you did in your last example.

Last edited by Lennart; 07-23-2004 at 05:59 PM.
 
Old 07-23-2004, 06:28 PM   #65
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31
Can it be that the router somehow doesn't "let go" of the connection when you switch from Windows to Linux? So that when Mandrake tries to set up a new connection it can't, because the connection Windows set up is "in the way". Maybe a long shot (again) but what if you do like Lennart said? Unplug everything, or at least wait for some time before you start up Mandrake.

Also, it's not ismod, it's lsmod; little L.
 
Old 07-24-2004, 02:12 AM   #66
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Quote:
Originally posted by Bebo
Can it be that the router somehow doesn't "let go" of the connection when you switch from Windows to Linux? So that when Mandrake tries to set up a new connection it can't, because the connection Windows set up is "in the way". Maybe a long shot (again) but what if you do like Lennart said? Unplug everything, or at least wait for some time before you start up Mandrake.
I'm thankful you still have ideas. Every stone has to be turned.

I will read through the manual of my modem to learn more in detail how it works. Then I know more about how my system works and what will happen if I follow Lennarts suggestion and unplug.
Quote:
Originally posted by Bebo
Also, it's not ismod, it's lsmod; little L.
Here is the result of lsmod:
Code:
[root@localhost thort]# lsmod
Module                  Size  Used by
sg                     38044  0
sr_mod                 17060  0
lp                     12200  2
emu10k1                69348  0
soundcore               9248  1 emu10k1
ac97_codec             17804  1 emu10k1
af_packet              20520  0
hid                    53312  0
raw                     7616  1
ide-floppy             18752  0
ide-tape               34864  0
ide-cd                 40548  0
cdrom                  37184  2 sr_mod,ide-cd
floppy                 59444  0
fealnx                 17032  0
mii                     4992  1 fealnx
nls_iso8859-1           3904  3
nls_cp850               4736  3
vfat                   13760  3
fat                    45120  1 vfat
supermount             37876  3
intel-agp              17372  1
agpgart                31016  1 intel-agp
ppa                    12296  0
parport_pc             32832  1
imm                    12360  0
parport                38952  4 lp,ppa,parport_pc,imm
quickcam              109792  0
videodev                9536  1 quickcam
uhci-hcd               29104  0
usbcore                99132  5 hid,quickcam,uhci-hcd
rtc                    11576  0
ext3                  110376  2
jbd                    54328  1 ext3
sd_mod                 16576  0
aic7xxx               193292  0
scsi_mod              114072  6 sg,sr_mod,ppa,imm,sd_mod,aic7xxx

Last edited by thort; 07-24-2004 at 02:14 AM.
 
Old 07-24-2004, 04:31 AM   #67
Lennart
Member
 
Registered: Mar 2002
Posts: 40

Rep: Reputation: 15
Thort, from Windows you can give the command to release the ip numbers. In the dos-window the command "ipconfig" or "ipconfig /all" will give you the ip addresses, "ipconfig /release *kal*" will release the whole lot. Check afterwards with "ipconfig". If the addresses were released it will show zero's and you're in the clear for booting into Linux; are there still any numbers left you'll have to unplug first. Check if you get "eth0 ok" when booting up Mandrake.
By the way, waiting didn't do the trick; I had to unplug. Believe me, I've tried!

Last edited by Lennart; 07-24-2004 at 04:39 AM.
 
Old 07-24-2004, 09:31 AM   #68
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Hi again Lennart !

I see, you have done some good thinking. Your idea about releasing the ip addresses in Windows XP seems to me as a possible way to go. Here is the result:

Quote:
Originally posted by Lennart
Thort, from Windows you can give the command to release the ip numbers. In the dos-window the command "ipconfig" or "ipconfig /all" will give you the ip addresses, "ipconfig /release *kal*" will release the whole lot.
Here is the result. Sorry, but my Windows XP is in Swedish:
Code:
C:\>ipconfig

IP-konfiguration för Windows


Ethernet-kort Tele 2 - ADSL:

        Anslutningsspecifika DNS-suffix . :
        IP-adress . . . . . . . . . . . . : 192.168.2.2
        Nätmask . . . . . . . . . . . . . : 255.255.255.252
        Standard-gateway  . . . . . . . . : 192.168.2.1

C:\>ipconfig /release *kal*

IP-konfiguration för Windows

Åtgärden misslyckades eftersom inget nätverkskort är
i ett tillstånd som tillåter åtgärden.
"Åtgärden misslyckades eftersom inget nätverkskort är i ett tillstånd som tillåter åtgärden." Translation: "The task failed because no network card is in a state that permit this task."

I don't understand why the network card doesn't permit the release.

So, I wasn't able to release the ip numbers.
Quote:
Originally posted by Lennart
By the way, waiting didn't do the trick; I had to unplug. Believe me, I've tried!
I gave this a try. I turned my modem off. Then unplugged the modem, computer and the telephone plug. I waited for about three quarters.

Then I plugged everything in. I turned my modem on and waited for it to establish the dsl connection to the telephone station. Now, I directly started up my system and booted into Mandrake 10.

But, the eth0 network didn't start. A red "Failed" occurred.



This was no good news.

Do you Lennart, or someone else here, have some more ideas?
 
Old 07-24-2004, 09:49 AM   #69
Lennart
Member
 
Registered: Mar 2002
Posts: 40

Rep: Reputation: 15
Bad news Thort, very bad news. I'm lost for words (and ideas) but I do think that you have nailed the problem. I hope the experts in the forum can come up with some good ideas. The only thing I can still offer is to try the command (as su) "ifup eth0" it seems to work wonders for others but if it will do anything for you I haven't a clue. However, it's worth to give it a try. Best of luck!
 
Old 07-24-2004, 10:18 AM   #70
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Quote:
Originally posted by Lennart
Bad news Thort, very bad news. I'm lost for words (and ideas) but I do think that you have nailed the problem. I hope the experts in the forum can come up with some good ideas. The only thing I can still offer is to try the command (as su) "ifup eth0" it seems to work wonders for others but if it will do anything for you I haven't a clue. However, it's worth to give it a try. Best of luck!
ifup eth0:
Code:
[root@localhost thort]# ifup eth0
Determining IP information for eth0... failed; no link present.  Check cable?
No pleasant sight!
 
Old 07-24-2004, 10:28 AM   #71
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Hi again

Quote:
Originally posted by thort
Nätmask . . . . . . . . . . . . . : 255.255.255.252
Thort, I just noticed that your Netmask is not the usual 255.255.255.0 but instead 255.255.255.252. So have you tried setting the default route with that netmask defined?

See, previously I told you to try doing the following:

Quote:
Let's try it with a DHCP assigned IP address since I'm sure you're using the DHCP server in the router: Do the following in the terminal:

ifup eth0
route add -net 192.168.2.0 netmask 255.255.255.0 dev eth0
route add default gw 192.168.2.0
Which doesn't use the correct netmask. What if you try the above again but change netmask 255.255.255.0 to netmask 255.255.255.252 ? If that doesn't work, also try the same set of commands, but use ifconfig eth0 up instead of ifup eth0.

Ok, so to recap, first try:

ifup eth0
route add -net 192.168.2.0 netmask 255.255.255.252 dev eth0
route add default gw 192.168.2.0

then if the above doesn't work, try

ifconfig eth0 up
route add -net 192.168.2.0 netmask 255.255.255.252 dev eth0
route add default gw 192.168.2.0


Besides that, I'm out of ideas (and would still wonder if this isn't a network module issue).
-Nick
 
Old 07-24-2004, 10:47 AM   #72
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Ok,

Ignore my last post as that is going down the wrong path. I was looking at the ifup script (located in /sbin/ifup) and it is supposed to and does automatically set all the neccesay routes for a device brought up by it (I don't know how i failed to realize that? ).

We need to figure out why the ifup script is failing.

Could you answer these questions which I asked in a previous post?:

"Also, does your network card and router/modem have lights on them to indicate network link and status? If so, what do they do? When the computer is on in Mandrake do they light up solid showing a link? Do they blink during boot up while mandrake is trying to bring up eth0? The answers should be yes."

The network status lights can help us determine if there is a good link, if traffic is actually occuring between the modem and computer, etc... so go see what they are doing

-Nick
 
Old 07-24-2004, 10:58 AM   #73
Lennart
Member
 
Registered: Mar 2002
Posts: 40

Rep: Reputation: 15
It sucks! At this stage I would get suspicious of 1. the settings of the router, but they work in Win XP and Mandrake 9 so they should work for Mandrake 10. 2. I'm still not sure even after three quarters of an hour if the ip-addresses are released however ridiculous that may sound, but give it another try before you go out or whatever and unplug it for at least an hour (preferrably more, I know, I know it really sounds ridiculous!), unplug even modem-computer connection, 3. I don't know how consistent hardware support is from one distro-version to the next. Could it be that your network card is no longer supported? Do you have another one hanging around that you could try?

Other than that it has to be a setting that has been overlooked but I think you pretty much covered them all by now! Good luck
 
Old 07-24-2004, 12:22 PM   #74
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Hi XJNick !

I am glad you are still with me!

I have good news !

We have network activity in Mandrake!

Look here at the "MCC - Monitor Connections" window

I see the LAN lamp blinking on my modem during Mandrake start-up and continuous when started. I measured the blinking, and during one minute the lan lamp made three short blinkings at three different occasions.

As you see at the graph in the link the network only receives data. No sending. Could it be these received data is the common background data flow on Internet? There is always some unnecessary and worthless trafik from Internet in to the computer.



On noteworthy thing is the behavior during start-up. When Mandrake 10 comes to the stage when the eth0 network shall start it do not prompt to search for the network. It just rushes by on the screen displaying the red "Failed" message. No blinking on the lan lamp on the modem here either. Before, when I had Mandrake 9.2 installed, the start-up process halted some seconds when the eth0 network should start. It was like it was searching for the connection and after some seconds found it. Why doesn't Mandrake 10 behave the same?

Quote:
Originally posted by XJNick
The network status lights can help us determine if there is a good link, if traffic is actually occurring between the modem and computer, etc... so go see what they are doing
The answer is obviously, yes.



How do we go on now?

Last edited by thort; 07-25-2004 at 03:05 AM.
 
Old 07-25-2004, 03:02 AM   #75
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Hi Lennart !

Quote:
Originally posted by Lennart
3. I don't know how consistent hardware support is from one distro-version to the next. Could it be that your network card is no longer supported? Do you have another one hanging around that you could try?
My network card is "Surecom EP-320X-S".

It seems to have Linux support. Here is a link to the support site of the manufacturer, Surecom, discussing Linux driver for my network card. This site is from September 2002. I hope Mandrake still support my card. Maybe you have more knowledge than me in understanding the sayings on the site.

Also, I found a Linux driver on the cards installation floppy. The driver is called "fealnx", which is the same name as the driver installed in my Mandrake 10.
Quote:
Originally posted by Lennart
2. I'm still not sure even after three quarters of an hour if the ip-addresses are released however ridiculous that may sound, but give it another try before you go out or whatever and unplug it for at least an hour (preferably more, I know, I know it really sounds ridiculous!), unplug even modem-computer connection
It's easy to give this another try. I will unplug everything next time I leave home.



And once more. Thanks for helping me!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adsl configuration paul62 Debian 9 10-20-2005 02:38 PM
dlink 502T Adsl configuration shueib Linux - Newbie 1 10-19-2005 11:29 AM
slackware network configuration adsl shashank Linux - Software 2 05-31-2005 04:36 AM
Adsl configuration trough the terminal Alex_jacobson Linux - Networking 0 07-09-2004 12:50 PM
Adsl Modem Configuration hemanth_020784 Linux - Hardware 0 01-03-2004 07:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 10:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration