LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 10-13-2008, 12:49 PM   #1
haakond89
LQ Newbie
 
Registered: Oct 2008
Posts: 1

Rep: Reputation: 0
Acer 5930G, RF-kill switch doesn't work


Ok, so i thought i should have a go at installing the Mandriva 09, at my laptop(can't live with W Vista anymore!).

Everyting seems to work just fine, and with the new kernel my wifi-card(Intel Wifi 5100) is also recognised properly. The only problem is that i cant get it to pick up any networks because the RF-Kill switch doesn't work.
I have tried the trick with holding the "Fn" key down while pushing the switch, but it doesn't seem to work. Anybody got an idea how til fix this?

So far, i've just tried booting it of the cd, to ensure that everyting works before i do a OS reinstall, but if necessary i will offcourse install it.
 
Old 10-13-2008, 02:18 PM   #2
Unknown_User
Member
 
Registered: Jan 2003
Location: EU (UK)
Distribution: Ubuntu 10.x, Fedora 9, OpenSuSE 11.3, Mythbuntu (Don't know it? Try - it rocks!)
Posts: 225

Rep: Reputation: 30
Did you find the post at http://www.linuxquestions.org/questi...pw2200-592920/ ?


Quote:
Try set rf_kill to 0

...I read the sourceforge.net/README.ipw2200 and under: 1.4.2 Device Level Sysfs Helper Files I found something about the rf switch.:

rf_kill
read -
0 = RF kill not enabled (radio on)
1 = SW based RF kill active (radio off)
2 = HW based RF kill active (radio off)
3 = Both HW and SW RF kill active (radio off)
write -
0 = If SW based RF kill active, turn the radio back on
1 = If radio is on, activate SW based RF kill


In the following link (on my computer) /sys/bus/pci/driver/ipw3945/0000:05:00:0 I found the file called rf_kill

It had the value 2. As root I changed it to 0 and now the whole thing works. Also after a reboot.
 
Old 10-14-2008, 12:27 PM   #3
drmjh
Member
 
Registered: Mar 2005
Location: North Carolina, USA
Distribution: Ubuntu 12.04LTS
Posts: 258

Rep: Reputation: 31
Question changing value of Rf_kill switch

Thanks for the great tip regarding the Kill_switch. After much searching, I found mine in an adjacent area of the file structure and it was set to 2.
I have run into the oddest problem though. I can't seem to change the contents of this file from 2 to 0. I have chmod the file to rw rw rw and verified this change. Using vim, I was not able to save my change; using nano, I was able to but to no avail. Nano saved the file with the change 0, but reopening the file showed the 2 re-written. Any suggestions?
Matthew
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless gone after kill switch touched stash1071 Linux - Wireless Networking 3 08-12-2008 07:55 PM
enable the RF kill switch for ipw2200 Asuran Mandriva 9 11-28-2007 08:54 AM
acer 4100lmi wireless kill switch problem zalis Linux - Laptop and Netbook 18 11-21-2007 03:57 AM
Problem with Radio Kill Switch ppr:kut Linux - Wireless Networking 0 03-06-2007 02:08 AM
cannot kill process (kill -9 does not work) mazer13a Linux - General 1 05-27-2005 02:32 PM


All times are GMT -5. The time now is 03:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration