-   Mandriva (
-   -   Accessing scanner through SCSI port. (

xode 08-26-2003 02:47 PM

Accessing scanner through SCSI port.
I have a Microtek Color Page Wiz scanner that is connected to the computer through an Initio 9100U SCSI card. I go into the Mandrake Control Center to configure the scanner and it does not autodetect it and asks me to manually select the scanner. Then it says "Scannerdrake was not able to detect your Microtek Color PageWiz scanner. Please select the device where your scanner is plugged" and then gives me a list of devices (eg. /dev/sg0) to "attach" it to. I then select one of the devices and it says my scanner is configured and to run Xsane to scan my documents. I run Xsane and it does go through the motion of scanning my document but ends up aborting with a read error at the end of the scan. What is needed to properly install this scanner? Please advise.

bitpicker 08-27-2003 08:00 AM

Maybe the SCSI card is part of the problem. I have a Microtek ScanMaker 636 which is not attached to its own SCSI card but rather an Adaptec card. Scanner Drake does not automatically install the scanner but choosing it from the list manually works.

There are Microtek scanners which are not fully supported yet; according to the list at your scanner is still in beta stage. As I'm not at all happy with the results achieved with my scanner (and they say that this one is actually stable) maybe SANE needs more development before it really works.


MultiBooter 08-27-2003 09:33 PM

What do you get when you type
scanimage --list-devices
in a terminal? I've had problems with older versions of sane properly detecting my hp3c, but eventually worked them out. Several times I had to su to root to get it to find the scanner and then it worked after that.

xode 08-28-2003 08:33 AM

Scanner was finally made to work.
It turns out that the scanner was "almost" working. It was starting the scan and then aborting about 75% of the way through the scan. Later, I also noticed that the preview function would capture some of the image. So the scanner was definitely communicating with Xsane but something was stopping it from completing its scan.

The solution, which I found by pure chance, is to enable "advanced options" on Xsane's "view" menu and then set the bottom-right-y setting to 27.920 cm (11 inches). The original setting was a lot higher than that. Xsane thinks that the scanner is a flatbed scanner whereas the scanner is really a feedthrough scanner. Consequently, any mismatch of actual and expected page width or length, including a document jam, will cause a read error. Further, trying to scan something smaller than 8.5 by 11 inches will also cause a read error unless an 8.5 by 11 inch backing sheet is put behind the document.

Now, the scanner works just fine.

All times are GMT -5. The time now is 05:14 AM.