-   Mandriva (
-   -   A-L-M-O-S-T There!!! Digikam, KAudioCreator, system bell install problems (

joeaverage 01-04-2006 09:45 AM

A-L-M-O-S-T There!!! Digikam, KAudioCreator, system bell install problems
Hello folks!!! Am using '06 and it's great. Have found the core software that is important to me and short of two titles that continue to frustrate me, Linux is wonderful!

Both titles - Digikam and KaudioCreator WERE working great once upon a time but both suddenly quit working. Won't say they failed at the same time, nor can I tie their failure to an event or action that I took.

I can't install Digikam. I can install the library, can install the extras. I can even install the main program and run it from /usr/bin but sometimes I get limited useability (importing pics creates weird folder names like dates wholly unrelated to the pictures). Have removed it and tried again. No luck. No Urpmi errors. It never gets added to the menus either. Help! Great program, want it to work.

KAudioCreator is also dead. I can start it up and it will accomplish the CBBD lookup on a disc but once I tell it to encode it crashes bigtime. Mentions io-solve, cd-protocol problems. LAME is installed. Grip did work last time I tried it. I prefer the "automation" of KAudioCreator. Place disc in the drive, rips automatically, asks for the next one, and so on. Encodes as quickly as it can (I use 1 track at a time). Am encoding our CD collection for easy Amarok / PalmPilot MP3 player use.

Not sure what else to do. I have removed the software, deleted any related hidden folders in my home folder and reinstalled. Obviously either a related file is missing or corrupted but I don't know where to start.

I have a very good user understanding of the GUI and menus but my command line knowledge lacks much.

HELP! <griN!> Thanks to ALL that try to help!

Chris in Cookeville, TN

camorri 01-04-2006 10:34 AM

Just some thoughts. When you installed , 2006, did you do a clean install or did you do an upgrade? Upgrades are notorious for wierd problems. ( like this ).

I did a clean install about two weeks ago. I just installed DigiKam. There were two versions on URPMI to choose from. Did you install from URPMI or from the CD's? If you havn't configued URPMI, it may be worth the effort. I selected the one with 2006 in the mdk package title. It shows as being Version .080 on the DigiKam help screen. I had used DigiKam under 10.1, and I did not format my home directory, so my albums are still there. DigiKam plays them without an issue.

I can't help much with KaudioCreator, although I do have it installed. It launched for me, but will not do a CDDB look up. I'll spent some time on it to see if I can make it fly.

joeaverage 01-04-2006 12:59 PM

Thanks. When I did my upgrade from 10.1 I did a clean install. If things continue this way I'll do a clean install again. Yes I have the wonderful URPMI setup and it is working like a dream.

I was just curious if a round of updates might have knocked those two titles out of whack.

If I wanted to remove every last bit of a program - how would I do it? Are the paths listed in the URPMI window (dependencies?) all the paths?

Back in Windows land sometimes this seemed to do the trick. Remove every last bit of software and then reinstall. Uninstalling software inevitably left configuration files somewhere (naturally also the registry entry).

I figure some Linux file has a bad line in it and needs to get deleted or overwritten. Am thinking it might be in one of the hidden files in the Home directory.

Am anxious to get it all working because these two titles fit my needs like a glove! Same for Amarok.

Thanks! Loving Linux!!!


joeaverage 01-04-2006 11:32 PM

Got it fixed. Not sure what did it. One webpage suggested I take out the command line parameters for LAME which insert genre. I also switched to my DVD burner as the reading drive for my discs. Also removed kdemultimedia and reinstalled it via the command line urpmi. Wish I could specify exactly what the fix was. My CD-ROM (48x Lite-On) still won't read for KAC. I also get a BIOS warning about connector (or conductor?) #80. Long term problem. Have not researched it but I am suspecting that it is the small cable that comes off the CD-ROM and connects to the motherboard. Anyone know?

Figuring that I have it plugged into my motherboard backwards b/c it fits either way. Will verify this weekend. Also need to read up on it.

Digikam has returned to functional status. Also removed it and reinstalled via the command line Urpmi. During the process I logged into root and deleted the Urpmi cache. Some of the albumns are mixed up but I can sort that out!

Lost the Nvidia driver somewhere along the way...

Thanks, hope this helps someone else.


camorri 01-05-2006 09:23 AM

I glad you now have both programs working. I got KAudioCenter working. I had to configure it to talk to the correct block device. In my case it is /dev sr0.

Last thought, I had a lot of problems with this install at the beginning. A program called 'kat' was installed by default. I had several programs crash with it running. I did some forum searches and found out others had traced it to kat. It was causing the system to be slugish and unresponsive. I uninstalled kat, and now all seems normal. Just my :twocents: worth.

joeaverage 01-05-2006 11:01 PM

Thanks So much. Guess I'll be looking for Kat too!


All times are GMT -5. The time now is 10:34 PM.