-   Mandriva (
-   -   3D Desktop (

sleepykit 03-24-2007 02:22 PM

3D Desktop
I run Mandriva 2007 in a fairly modern computer (2.8GH processor) and an nVidia GForce 6600GT. KDE and GNOME both work fine, but I can't seem get the 3d desktop working.

When I log in and choose drakx3d from the session list, I'm always taken to a screen that asks what I want to use, no 3D at all or full 3D with either AIXGL (?) or XGL. No matter what I choose I am told to log off and log in again. I've tried clicking on "OK" and "cancel" and making no changes at all, but it comes back to that same prompt.

Doing that repeats the process. I get no error output or any indication that any of the changes work. I've tried using both options (XGL and the other one).

I do have nVidia drivers installed for the card via the binaries provided by nVidia. I've also tried the PFL ones but those do not appear to work at all. Ayy clues would be good?

{BBI}Nexus{BBI} 03-24-2007 02:25 PM

When you make your choice of AIXGL or XGL you are told to log off, you then do ALT+CTRL+Backspace before logging back in to activate the 3D Desktop.

sleepykit 03-24-2007 02:32 PM

First of all, thank you for the help!

Well, I tried that, but as long as I choose drak3d as my session manager, it always brings up that screen (the use full 3d effects one). Tried doing all of that and then getting back int KDE and got a white screen. Nothing else, just a white screen.

After I turned off 3d effects, KDE came back up normally. Not sure what I'm doing wrong here.

sleepykit 03-24-2007 02:34 PM

I should've mentioned this as it might make a difference. I have two monitors that are running in Twinview with the help of nVidia drivers. This may or may not make any difference to the situation.

{BBI}Nexus{BBI} 03-24-2007 02:54 PM

I'm not sure if it does, if possible I would go to single monitor mode to see if that's the cause of the problem.

GlennsPref 03-24-2007 09:44 PM

Hi, after you log out, and the login screen re-appears, go down to the display manager selector (where you chose 3ddesktop) and change it to kde or gnome.

The login as usual

I get the beryl 1.4 splash for a second or two while the desktop (kde) starts.
Which, to me, is a confirmation that the 3ddesktop is running.

Hope that helps, I was doing what you are doing for quite a while before I found out what I was doing wrong.

sleepykit 03-25-2007 12:43 PM

Thank you for the suggestion, GlennsPref. I tried that last night and what does come up is a blank white screen on both my monitors. For a while the cursor hovers as if it's doing something, then it stops hovering and all that's left is a blank white screen. No icons or taskbar or anything.

Help, please?

GlennsPref 03-25-2007 09:39 PM

This is a problem that occurs frequently, and answers may be found in their respective FAQ's and or wiki

There are solutions, I've seen them, But I never had the prob myself

sleepykit 03-26-2007 10:52 PM

Ahh, thank you. I will go hunt for that then. =) The help has been muchly appreciated.

{BBI}Nexus{BBI} 03-28-2007 10:04 AM

It might be an idea to backup your .kde folder then delete the original one. A new .kde will be created if you successfully log in.

ernie 03-28-2007 11:42 PM


If you find the solution, post it or a link to it here. You may be of help to others :).

{BBI}Nexus{BBI} 03-29-2007 07:48 PM

** reply removed, post made in error. **

sleepykit 04-01-2007 02:17 PM

Thank you, ernie. I certainly will as soon as I actually get it working. I'm pretty sure my problem stems from the drivers I'm using since all the research points to the fact that the drivers that Mandriva suggests do work, and there it's becomes of how XGL is specified in xorg.conf. However, the drivers I am using are different so that's most likely the cause.

GlennsPref 04-04-2007 08:49 AM

Check these lines
I have a gfx7600 gt, using the nVidia 64bit drivers(.run pakage)

These setting work for me.

Check these lines are in xorg.cof, under device and screen.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Fri Dec 15 10:40:27 PST 2006

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
Identifier "layout1"
Screen "screen1" 0 0
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"

Section "Files"

# font server independent of the X server to render fonts.
# minimal fonts to allow X to run without xfs
FontPath "unix/:-1"
FontPath "/usr/share/fonts/misc:unscaled"

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
# allows the server to start up even if the mouse does not work
Option "allowmouseopenfail"

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us(alt-intl)"
Option "XkbOptions" "compose:rwin"

Section "Monitor"

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
Identifier "monitor1"
VendorName "MEA"
ModelName "1280x1024 @ 50 Hz"
HorizSync 31.5 - 64.3
VertRefresh 50.0 - 70.0
ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616

Section "Device"
Identifier "device1"
Driver "nvidia"
VendorName "Palit"
BoardName "NVIDIA GeForce 7600 gt(Palit) 256Mb"

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
Option "AIGLX" "true"
Option "DPMS"
Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "True"
Option "BackStoring" "True"
Option "DisableGLXRootClipping" "True"
Option "HWCursor"
Option "AllowGLXWithComposite" "True"
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

Section "Extensions"
Option "Composite"
Option "RENDER" "Enable"

azbiza 05-17-2007 11:55 AM

I have the same problem, any idea what to do ?

All times are GMT -5. The time now is 09:36 PM.