LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   3D Acceleration in Mandrake 10.0 Official (https://www.linuxquestions.org/questions/mandriva-30/3d-acceleration-in-mandrake-10-0-official-205225/)

czechknight93 07-14-2004 11:50 PM

3D Acceleration in Mandrake 10.0 Official
 
I am a BIG user of Mandrake and have been since I first used Linux 4 years ago. I am pretty familiar with the Linux system. However, I usually need a good step-by-step approach to complete difficult topics such as this one. I have an ATI Radeo 9600, which is MORE than capable of 3D acceleration. The problem is when I install Mandrake 10.0, I cannot use acceleration or X does not initialize. If I turn acceleration off, no problems occur. This is no big deal except I am planning on using Blender 3D and I am sure it will require 3D hardware acceleration for rendering and such. What is the BEST approach to getting acceleration back? My display settings are appropriate for my ATI Radeon. They are:

Graphic Card: ATI Radeon (fglrx), XFree 4.3 (No acceleration)
Monitor: Custom (Device not available for a 19" Planar LCD)
Resolution 1280x1024 24bpp

A test is successful. Get this: if I test the display with acceleration, it tests just fine :scratch: . However, I cannot keep acceleration selected, because X will not load at first boot. The screen goes black and does nothing. Therefore, I disable acceleration and continue with a very successful install. So, my question is:

What is the BEST and/or easiest way to get 3D Hardware Acceleration back?

Thanks!

stuart 07-15-2004 02:00 AM

this is what i did

goto ATI site and get the official drivers

http://www.ati.com/support/drivers/l...5&submit=GO%21

make sure you have your kernel source installed(you must have them installed for this to work.....again the mandrake control center)

then... and this is important, i had to remove the ATI already installed kernel (which i did through the package manager, i just searched for ATI and remove anything about "ati kernel")

then i rebooted and now X wont work because id removed her graphics modules but, i then installed the ATI drivers

logged in as root

rpm -Uh --force packagename.rpm


you MUST have kernel source installed for this to work, then after that had completed i run "fglrxconfig" from the prompt and answered all the questions.

with the questions i pretty much answered the default to every answer except the stuff for my refresh rates and screen resolutions

except for two things

i chose option to for the FSAA option(not the default 1

and

when asking to use external AGP GART module 'y' (not the default no, this one is suppose t be uber important, but i said y and it all worked fine)



then after all that i restarted the pc and voila

[root@home stu]# fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON 9600 Generic
OpenGL version string: 1.3 (X4.3.0-3.9.0)


:) i hope this helps you out

nat2k4us 07-15-2004 09:52 AM

I did the same thing but i did not uninstall the ATI drivers that were installed by default in mandrake. Still my system works fine.
This might explain why I get get 40 - 45 fps in Ut2004 ( while in windows I get 80 above )

motub 07-15-2004 11:12 AM

Try following the instructions here: ATI Radeon Linux How-To

There are a couple of important kernel options that have to be configured before installing the drivers for them to work properly, and perhaps you have not done so.

czechknight93 07-15-2004 09:44 PM

Thank you Stuart!
...and thanks to everyone else!

That is EXACTLY what I needed. It did the job and I have 3D hardware acceleration. I did it all in less than 30 minutes and it was relatively simple. The only thing I did different was adjust the monitor settings, like refresh rates and default resolution, to the manufacturer specs. Hopefully, I will be working in Blender 3D very soon. Thanks a million!

Billy

stuart 07-15-2004 11:24 PM

Hehe glad it worked for you, i spent 2 days on this one and the only issue i had was those damned ATI modules that were already installed in my system wouldnt allow the newer kernel module to compile. And a total newb like me.....tok two days to find that out. It appears that they only get installed on the "Powerpack" version of Mandrake 10. Anyways im glad it helped you :)

czechknight93 07-16-2004 12:54 PM

Just one more question...(hope this isn't bad)


I typed "fgrlxinfo" and got this:

Code:

xlib:  extension "XFree86-DRI" missing on display ":0.0".
display:  :0.0  screen: 0
OpenGL vendor string:  Mesa project:  www.mesa3d.org
OpenGL render string:  Mesa GLX Indirect
OpenGL version string:  1.3 Mesa 4.0.4

Does this mean my ATI modules didn't work as suspected? Was I supposed to uninstall the ATI kernel AND the ATI modules? I only uninstalled the modules and NOT the kernel. Is there a way to change these settings to ATI Radeon 9600? The display adapter in harddrake is set to ATI Radeon, but still no acceleration. Thanks for the help!

Billy

motub 07-16-2004 01:20 PM

Have you restarted the X server since you installed the drivers? Have you actually loaded the drivers (using modprobe as root)? I assume you ran fglrxconfig to change the settings in your X Configuration file (usually /etc/X11/XF86Config-4, for Mandrake).

czechknight93 07-16-2004 06:25 PM

Quote:

Have you restarted the X server since you installed the drivers? Have you actually loaded the drivers (using modprobe as root)? I assume you ran fglrxconfig to change the settings in your X Configuration file (usually /etc/X11/XF86Config-4, for Mandrake).

How might I go about doing that? I did run fglrxconfig, but I didn't do the modprobe thing. I have never used modprobe. Do I just type in "modprobe" at the prompt? Do Ineed to be out of the graphical interface or can I do this in my root account? Thanks!

Billy

motub 07-16-2004 06:35 PM

You would need to type modprobe fglrx at a terminal prompt, as root. This could be a terminal that you open from your normal desktop, or a console login.

To restart the X server, from X, you can log out and back in, or log out, hit CTRL+ALT+Backspace to make absolutely sure that the X server is restarted, then log back in. From a console login, just type startx.That should get you sorted for this particular session, but you may have special instructions needed to load the driver after a reboot.

I would again suggest you look at ATI Radeon Linux How-To, or at the very least the HOWTO: Installation Instructions for the ATI Proprietary Linux Driver provided on the ATI site.

czechknight93 07-16-2004 07:20 PM

Well, that didn't fix the problem. I still get the Mesa 3D. The ATI Howto was of no help either. I went through the entire process 3 times without ANY error messages and I still get Mesa. I thought this video card was "certified" for Linux compatibility. ANY tips or pointers will be greatly appreciated. Thanks!

Billy :(

czechknight93 07-16-2004 07:49 PM

I decided to take a leap of faith and try to set harddrake to the proper drivers. I opened the configuration tool (in root account) and selected hardware. Then I selected Hardware again. I then clicked on the Videocard "Radeon 9600 AP (AGP)" and clicked "Run config tool." When the window opened up, it had "custom" as the Graphic Card, so I switched it to ATI Radeon (fglrx), which it had already been selected. I then clicked next and selected "XFree86 with Hardware Acceleration" and it requested CD3 of the installation media. After it installed the package(s), I set the Resolution to 1280x1024 24bpp and then clicked on "Test." The test ran perfectly and the X Server restarted and now, I am bact to my desktop with the new settings (something I have never been able to do). The Config tool of the Videocard reads:

Graphic Card: ATI Radeon (fglrx) (this is with 3D Hardware Acceleration)
Monitor: Custom
Resolution: 1280x1024 24bpp

Also, when I go to "Screen Resolution" in Mandrakelinux Control Center, it says:

(Graphics Card: ATI Radeon (fglrx))

Also, when I go to "Graphical Server" in Mandrakelinux Control Center, it says:

Graphic Card: ATI Radeon (fglrx)
Monitor: Custom
Resolution: 1280x1024 24bpp

Now, when I type fglrxinfo, I get:

display: :0,0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4

Which should I believe: fglrxinfo or Mandrakelinux Control Center???????? Obviously, I want to believe MCC and I will until I'm told otherwise. Thanks!

Billy

motub 07-16-2004 07:53 PM

The drivers do certainly work, I've been using them since I got my AIW 9800 SE several months ago, back when the current driver version was still 3.2.8; and I have used them successfully under Mandrake (9.2), Slackware (9.1) and now under Gentoo.

Did you force install the RPM? Is DRM disabled in your kernel? Does your XFree86 (I assume you are using XFree86 and not X.org to provide X) expect the ATI drivers or some other drivers (what is the contents of the "Screen" section that the "Server Layout" section of your X configuratio file is using)? Perhaps you did not build the kernel module; perhaps you did not install it (did you run the two scripts extracted by the RPM-- make.sh and make_install.sh?) You have not told us the results of modprobe fglrx-- was there any sort of error? Did you by chance do an lsmod following the modprobe to confirm that the driver module was in fact loaded? Have you confirmed that when you ran fglrxconfig that the file was saved to the correct filename (the one X is actually using)? Perhaps you are still loading the kernel's radeon drivers, which conflict with the ATI drivers (and don't work for cards above the 9200 or so). Perhaps you have a KT600 motherboard, or an nForce motherboard, both of which can need additional separate drivers, or other special handling to install the ATI drivers correctly. Heck, we don't even know your currently-running kernel is, so cannot confirm that the kernel source you are using is the correct one for it.

So you see, without going into a great amount of detail as to your current configuration and what precisely you did, it's hard to do anything other than stab in the dark. Which is why I keep referring you to the ATI Radeon Linux How-To, as it does go into a great amount of detail as to how to configure your system precisely for the installation of these drivers, while being clear and easy to follow. If you are using a 2.4 series kernel, rather than Mandrake's default 2.6-series kernel, you might find ATI Radeon Howto useful as well.

czechknight93 07-16-2004 10:25 PM

DETAILS!!!:D Great, let's get to it...


Quote:

Did you force install the RPM?
Yes, I used --force

Quote:

Is DRM disabled in your kernel?
??? What is that?

Quote:

Perhaps you did not build the kernel module; perhaps you did not install it
Build the kernel module? That is not in the instructions from ATI. How do I do this?

Quote:

did you run the two scripts extracted by the RPM-- make.sh and make_install.sh?
I am looking in the directory where I have the rpm package and I see no scrips. When I type those commands, I get "command not found."

Quote:

You have not told us the results of modprobe fglrx-- was there any sort of error?
I get: "FATAL: Module fglrx-- not found." If I type "modprobe fglrx" it goes back to [root@localhost root]#

Quote:

Did you by chance do an lsmod following the modprobe to confirm that the driver module was in fact loaded?
Forgive me, but I'm not at the Linux box because it doesn't have an internet connection. I'm using my iMac. I'll list three lines that may be of interest:
Module Size Used By
fglrx 165549 0
sis - agp 5568 1
agpgart 31016 1 sis - agp


Quote:

Have you confirmed that when you ran fglrxconfig that the file was saved to the correct filename (the one X is actually using)?
It was written to XF86Config-4 in /etc/x11/

Quote:

Perhaps you are still loading the kernel's radeon drivers, which conflict with the ATI drivers (and don't work for cards above the 9200 or so).
What's the difference? Which one is best? I'm using an ATI kernel from the Mandrake Installation. How do I not load its drivers?

Quote:

Perhaps you have a KT600 motherboard, or an nForce motherboard, both of which can need additional separate drivers, or other special handling to install the ATI drivers correctly.
ECS L7S7A2 Mainboard. SiS746 and SiS963/963L chipsets.

Quote:

Heck, we don't even know your currently-running kernel is,
2.6.3-7mdk as per Gkrellm system monitor. The package listed on the installation CDs is: ATI_Kernel-2.6.3.7mdk-3.7.6-2mdk

Quote:

Which is why I keep referring you to the ATI Radeon Linux How-To, as it does go into a great amount of detail as to how to configure your system precisely for the installation of these drivers, while being clear and easy to follow.
I'll check into that. I saw a step I did not perform. When I do make.sh and make_install.sh, can I do this in my root account?


I appreciate you hanging in for me. I REALLY appreciate your help. I hope this is enough info for you. If not, I'll give you more. THANK YOU!!!

Billy

stuart 07-16-2004 11:51 PM

AAAAAHHHH czecknight....YES you remove the ATI kernel, this step is a must if you have it installed, because it wont allow the ATI driver it build and install its own module. You seem to have done everything right except that..

anything like this should go

ATI_kernel-2.6.3.7mdk

But just make sure that after you remove that and logout that you know exactly how to install the driver from the prompt as you wont be able to start X until you rpm your driver again, even if the 3d doesnt work(which it should) it will still re-enable 2d enough to get back to X


"You DO NOT need to play with your kernel option with mandrake10, the default install of the 2.6.X kernel has all the right stuff enabled for this to work. This driver installs easily and works fine with the steps i had provided above, just remove that ATI kernel and do the install again"

I can confirm my method works for radeon 9600 and 9600 mobility cards on
2.6.3.7 and 2.6.3.15 kernels.

Post your reults


All times are GMT -5. The time now is 06:55 AM.