LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   2006-Only root can mount sda2 (https://www.linuxquestions.org/questions/mandriva-30/2006-only-root-can-mount-sda2-400456/)

Lakota 01-07-2006 12:17 AM

2006-Only root can mount sda2
 
Ok, time to suffer through the device mounting changes that were done in 2006 with switch from hotplug and udev to only udev.

I am used to ipod auto mounting while using 2005LE, also does this in 2006 if you did upgrade instead of fresh install. With a fresh install of 2006, sda2 appears in /mnt, but is not mounted. Trying to mount it as regular user is declined and message that only root can do this appears. I realize I can simply open Konsole and su, and mount, but that is adding steps that were eliminated in 2005le, so makes this distro feel like certain elements were a step backwards. I was hoping to find something obvious editing my Groups/Users like a firewire group to add my user to, but did not.

So, does anyone know how to make firewire iPod auto mount, or at very least mountable by regular user? Would like firewire to behave the same as usb in 2006.

aus9 01-07-2006 03:09 AM

some suggestions even tho I don have your device

1 check your /etc/fstab entry for /mnt/sda2 and add users to its entry then reboot and test after backing up of course

2 while there you will notice 2006 re-introduces supermount for the floppy so if 1 fails tries amending your entry to supermount?

GlennsPref 01-07-2006 06:19 AM

My suggestion is to change the security level down to less than high.

I remember seeing a message about that type of thing during install, ie. windows partitions only available to administrator. I haven't tried that yet, though.

And my usb-mem stick is not in the list of devices available for the desktop, even as root.

Go figure!

aus9 01-07-2006 08:43 AM

check out these if you have a chance
http://wiki.linuxquestions.org/wiki/Ipodlinux:firewire

an eg from a kanotix forum where sdb1 was a camera
/dev/sda2 /home/name/ipod vfat rw,users,noauto 0 0

Lakota 01-07-2006 10:40 AM

Ok, back at it, not figured out yet. Really appreciate the guidance though.

GlennsPref: I did notice during install that by default it was going to set security level to high. I changed it to standard, checked and it is still set there. My usb mass storage devices mount automatically when plugged in, it is only firewire that does not and is only mountable by root. This only happens with a true fresh install of 2006. 2005le auto mounted firewire and so does 2006 if it is an ugrade from 2005le instead of a fresh install.

aus9: Your ideas on the fstab file is what I am following now. Have been reading the man and all tutorials I can find on the web about structures of fstab entries. The current auto generated fstab entry confuses the heck out of me with all the extra paramaters. I did change my dev and fstab mount point to be called ipod, originally it was called win_c2. Will get this thing working as I wish if it kills me since I just purchased the powerpack. Anyway here is a short version of what I am looking at right now:
my fstab entry as generated by Mandriva 2006:
/dev/sda2 /mnt/ipod vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0

alternative entries found on web examples:
/dev/sda2 /mnt/ipod vfat noauto,user,rw 0 0
or
/dev/sda2 /mnt/ipod vfat rw,users,noauto 0 0
or
/dev/sda2 /mnt/ipod vfat sync,nodev,nosuid,user,rw,noauto 0 0
or
/dev/sda2 /mnt/ipod vfat defaults,user,noauto,sync,umask=000
or
/dev/sda2 /mnt/ipod vfat defaults,user,noauto 0 0
or
/dev/sda2 /mnt/ipod vfat noauto,user,uid=500,gid=500 0 0

Note that eject has its permissions set for root access only. You could carry on running as root or change the group to users and allow them to execute the program, or set the suid bit.

Lakota 01-07-2006 11:59 AM

Got a happy ipod that now mounts automatically when plugged in.
This is what my fstab entry is now:
/dev/sda2 /mnt/ipod vfat noauto,user,uid=500,gid=500 0 0

Note: the uid and gid numbers may be different if someone tries to use this example for themselves. To find your own uid and gid do this:
Code:

[don@localhost ~]$ id
uid=500(don) gid=500(don) groups=6(disk),80(cdwriter),82(video),500(don)
[don@localhost ~]$

Thanks for the help, next, to figure out how to allow user to eject ipod without root permission. If anyone reading this knows off the top of thier head, please post here.

Aus9, yes, that was your first suggestion on the first reply to my post. Had no idea how to do that prior to tons of reading on the subject, so it took me a while to get it tried out. - Thanks.

Lakota 01-07-2006 01:14 PM

Quote:

Originally Posted by Lakota
next, to figure out how to allow user to eject ipod without root permission.

Hmm, since the new fstab entry, I am now also able to issue the command "eject /dev/sda" as a regular user. This is now one step better than it worked in 2005le.

Ok, this rocks. Now when Gtkpod is given mounting and unmounting control in the preferences of Gtkpod, it works better than on windows with iTunes. Simply closing Gtkpod automatically unmounts and ejects the ipod. Windows with iTunes you must still use the eject button on itunes program to eject it (possibly there is a way to automate that in itunes preferences, don't know, don't use windows enough to know the program well). Anyway, set up better than I expected. Now to see if I can unfreeze my car door locks. Been computer bound for about 36 hours due to frozen car door locks. Gotta have priorities you know, now my pc is happy, time to fix the car! heehee

GlennsPref 01-07-2006 05:20 PM

Excellent!

Hope it thaws out a bit more too.

Man, I prefer it hot. 32 deg celius yesterday, rain today, 9:19am @ 24 deg. cel.
This is the coolest day in about a month or so.

Lakota 01-07-2006 08:55 PM

-3Celcius here, did get into car today. Missed work on Friday because of it.

Rebooted machine, all still works perfectly for ipod. Often I avoid change, trading hotplug for hal-udev, but seems linux is still on the right path. Was actually very easy to set up and works better than it has in past kernel versions. Maybe in the next Mandriva release the fstab entry for ipod will be created to work the ipod the way I like it to without user intervention. Almost there.

GlennsPref 01-07-2006 09:39 PM

That's progress.

Cheers.


All times are GMT -5. The time now is 06:12 AM.