-   Mageia (
-   -   Mageia 3 firewall can't enable everything. (

moshebagelfresser 05-27-2013 02:12 AM

Mageia 3 firewall can't enable everything.
It is blocking eMule and I cannot disable the firewall in MCC. Bug has been filed on Firewall blocking everything.

Anybody got any ideas of a work around?

rokytnji 05-27-2013 10:12 AM

Reading about Mageia Linux. I don't run it so take what I say with a grain of salt. I would Look into uninstalling Shorewall Firewall in Mageia (The web says Mageia uses Shorewall Firewall)

Just use Mageias package manager to uninstall it. If wanting to go into


A note about config files

The default configuration directory is located at /etc/shorewall/.
Shorewall global configuration file is located at /etc/shorewall/shorewall.conf. This file sets options that apply to Shorewall as a whole.
The /etc/shorewall/zones file declares your network zones. Rules about what traffic to allow and what traffic to deny are expressed in terms of zones.
The /etc/shorewall/interfaces file serves to define the firewall's network interfaces to Shorewall.
The /etc/shorewall/policy file defines the high-level policy for connections between zones defined in /etc/shorewall/zones.
To provide exceptions to policies, add rules to /etc/shorewall/rules. Use this file to open or close ports and so on.
To blacklist IPs, applications, MAC address, and subnets use the /etc/shorewall/blacklist file.
to fix/tweak (you are on your own from me on that one)
Like I said. I don't run rpm based distros or Shorewall Firewall. So this is the best I can suggest as a quick fix.

moshebagelfresser 05-27-2013 11:04 AM

Yes! In the Mageia Control Centre as Root using System Konsole I used urpme shorewall and removed it.

I then went to Firewall and disabled the firewall. It asked for Shorewall to be installed which I did.

This uninstall and reinstall did the trick and the problem is solved. I can now connect eMule. The tick remained in the Everything box. This is the way to do it and anyone can set the firewall to personal wants.

You were spot on rokytnji.

courtrrb 07-12-2013 08:19 AM

This has been fixed. Update your system with the latest and it will work as expected.!

All times are GMT -5. The time now is 10:39 PM.